Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2022, 03:18 PM   #1
New Member




Join Date: Oct 2011
Posts: 24
K3ii firmware update

Can anyone help please. Having put the update file [fwdc230b.bin] onto root of formatted sd card and inserted card into slot 1 of camera. Why, whilst holding menu button whilst turning camera on, will the camera firmware not start to update, with the camera just displaying standard menu display.
Many thanks in advance

04-15-2022, 04:08 PM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: May 2015
Location: Melbourne
Posts: 1,262
A few things to check.
Firstly, with the card with the firmware in slot 1 and the camera one, does the camera recognise that there is card in the slot? If not try reinserting, and/or cleaning the card contacts with soft dry cloth.
I assume this is firmware v 1.12, in which case the bin file should be 16.8 MB, probably worth checking that. If not then download again and be sure that the extracted bin file is the correct size.
I would also guess that you have been through the exercise a few times to be sure that you have the menu button fully depressed whilst switching on, if not try again.
Good luck, let's know how you get on...it might help others.

Cheers,
Terry
04-15-2022, 04:11 PM   #3
Site Supporter
Site Supporter
bigted's Avatar

Join Date: Oct 2011
Location: Jessica Lake, Whiteshell Provincial Park, Manitoba, Canada
Photos: Gallery | Albums
Posts: 1,438
Check the file name it is incredibly picky. I just had the same issue and my laptop created a new file name and that is why it wouldn't work.
04-15-2022, 08:37 PM   #4
pjv
Otis Memorial Pentaxian
Moderator
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 8,216
The dual SD card models can be a little tricky, in that they remember which card slots were active when the camera was turned off. If you turned the camera off with only a card in Slot 2, then by default, the camera will use Slot 2 on startup regardless of whether you have Use Slot 1 First as your setting.
With the camera turned off, please remove the card from Slot 2, put the firmware updated card in Slot 1, then turn the camera on. Slot 1 will now be recognized by the camera as the designated SD card to use.

Please also make sure that you have no previous firmware versions on the card, as this also results in a failure to download.

Let us know if this helps. Good luck.

04-16-2022, 02:40 AM   #5
New Member




Join Date: Oct 2011
Posts: 24
Original Poster
QuoteOriginally posted by tduell Quote
A few things to check.
Firstly, with the card with the firmware in slot 1 and the camera one, does the camera recognise that there is card in the slot? If not try reinserting, and/or cleaning the card contacts with soft dry cloth.
I assume this is firmware v 1.12, in which case the bin file should be 16.8 MB, probably worth checking that. If not then download again and be sure that the extracted bin file is the correct size.
I would also guess that you have been through the exercise a few times to be sure that you have the menu button fully depressed whilst switching on, if not try again.
Good luck, let's know how you get on...it might help others.

Cheers,
Terry
Thanks Terry. Yes the camera does recognise that there is a card in slot1 and the file size is 16.444 Mb, but as double check re-downloadedzip file for version 1.12 and extracted the bin file, so that on the newly formatted card are only the zip & bin file.However on pressing menu button and switching on, nothing, display on LCDs is same as normal switch on and menu button definitely bottomed,so fully activated, but still only normal switch-on display.
Any further suggestions gratefully received.
04-16-2022, 02:56 AM   #6
Site Supporter
Site Supporter
microlight's Avatar

Join Date: Sep 2011
Location: Hampshire, UK
Posts: 1,985
Maybe the issue is that you’ve got the zip file on the SD card as well as the bin file - have you tried it with only the bin file on the card?
04-16-2022, 03:07 AM   #7
New Member




Join Date: Oct 2011
Posts: 24
Original Poster
QuoteOriginally posted by microlight Quote
Maybe the issue is that you’ve got the zip file on the SD card as well as the bin file - have you tried it with only the bin file on the card?
Thanks microlight and yes I have tried with only the bin file on the card, but still only the standard switch-on display.
Cheers.

04-16-2022, 03:36 AM   #8
Senior Member




Join Date: Aug 2011
Location: Melbourne, Australia.
Posts: 276
Did you format the card on your computer or in the camera? I would use the camera to format.
This will create a DCIM folder and name the card K-3 ll

Just tried this with my k3ii, I already had version 1.12 but went thru the process
Startup with the menu button held down and it asked if I wanted to update.
If no bin file then it goes straight thru to the normal startup. So maybe its not reading something correctly?
Do you have another card you can try?

Last edited by bill.mc; 04-16-2022 at 03:46 AM.
04-16-2022, 03:53 AM   #9
New Member




Join Date: Oct 2011
Posts: 24
Original Poster
QuoteOriginally posted by bill.mc Quote
Did you format the card on your computer or in the camera? I would use the camera to format.
This will create a DCIM folder and name the card K-3 ll

Just tried this with my k3ii, I already had version 1.12 but went thru the process
Startup with the menu button held down and it asked if I wanted to update.
If no bin file then it goes straight thru to the normal startup. So maybe its not reading something correctly?
Do you have another card you can try?
Thanks bill.mc. I did do the card format in camera, but your observation of no bin file, then normal startup is very interesting. Certainly when I press the menu button and switch on, the led flashes briefly as if the camera is doing something.
Maybe it's a time to start everything again anew, from the beginning and cross fingers.
Cheers,
04-16-2022, 10:49 AM - 1 Like   #10
Site Supporter
Site Supporter
bigted's Avatar

Join Date: Oct 2011
Location: Jessica Lake, Whiteshell Provincial Park, Manitoba, Canada
Photos: Gallery | Albums
Posts: 1,438
Make sure you really start over and delete any downloads. If there is a copy of the bin file on your computer a duplicate will be given another file name and the camera won't recognize the file and it won't update. I had this happen to me. I deleted all the bin files (I had at least 2 on my computer) and started fresh and it worked like a charm.
04-16-2022, 11:10 AM   #11
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 9,226
Are you holding down the menu button when you power on the camera? A card with no bin file on it should show the current FW version on the rear LCD when you do this.
04-16-2022, 12:39 PM   #12
Pentaxian
AfterPentax Mark II's Avatar

Join Date: Mar 2021
Posts: 856
QuoteOriginally posted by Not a Number Quote
Are you holding down the menu button when you power on the camera? A card with no bin file on it should show the current FW version on the rear LCD when you do this.
With most older Pentaxes: Yes, but not with the K-3II. You just use the menu for checking the firmware version. With the K-3II when pushing the menu button and then the power knob set to on, you just get your info screen as usual.
04-16-2022, 01:09 PM - 1 Like   #13
New Member




Join Date: Oct 2011
Posts: 24
Original Poster
QuoteOriginally posted by bigted Quote
Make sure you really start over and delete any downloads. If there is a copy of the bin file on your computer a duplicate will be given another file name and the camera won't recognize the file and it won't update. I had this happen to me. I deleted all the bin files (I had at least 2 on my computer) and started fresh and it worked like a charm.
Many thanks bigted. after re-formatting SD card in camera and deleting zip and bin files from computer and then re-installing new bin file to SD card,SUCCESS!!. Many, many thanks to all collaborators on my problem, as it was great to feel the support on my back.
Cheers
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, firmware, k-3, k-3 ii, k3, k3ii firmware, menu, pentax k-3, update, whilst
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K3ii 1.12 Firmware Update Not Correct? bpcarlson Pentax K-3 & K-3 II 4 08-12-2021 03:02 AM
K3II firmware update retsoor Pentax K-3 & K-3 II 3 05-28-2017 11:41 AM
Firmware Update to 1.1 for K3II Glen Pentax K-3 & K-3 II 2 10-22-2016 11:32 AM
K70 firmware update 1.1.0,DCU update 5.6.1 OoKU Pentax News and Rumors 4 09-07-2016 02:19 AM
Firmware update for K3II yet? TroutHunterJohn Pentax K-3 & K-3 II 2 11-16-2015 03:53 PM



All times are GMT -7. The time now is 09:21 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top