Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-13-2013, 01:22 PM   #1
Site Supporter




Join Date: Jun 2008
Location: McLean, VA
Photos: Gallery
Posts: 78
K-3 auto focus problem

I read on the "other" forum that someone said their K-3 would not AF with their DA*55 lens.
My K-3 won't AF with the DA*50-135 lens, although it does AF with the DA*16-50.
Anyone else having problems?
David

11-13-2013, 01:38 PM   #2
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
Do you have any other lenses (non SDM especially)?
11-13-2013, 01:56 PM   #3
Pentaxian




Join Date: Oct 2010
Photos: Gallery | Albums
Posts: 2,678
My DA*55 focuses just fine with my K-3.
11-13-2013, 01:58 PM   #4
Pentaxian
bobmaxja's Avatar

Join Date: Mar 2010
Location: Laval, Quebec Canada
Posts: 1,724
Could it be that the contact are dirty?

11-13-2013, 02:11 PM   #5
Site Supporter




Join Date: Jun 2008
Location: McLean, VA
Photos: Gallery
Posts: 78
Original Poster
My non-SDM lenses all work fine.
the 50-135 was working great on my K-5 earlier this week.

David
11-13-2013, 02:18 PM   #6
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
Does it still work with the k-5 now? Can you try cleaning the contacts on both the lens and the camera?
11-13-2013, 02:30 PM   #7
Site Supporter




Join Date: Jun 2008
Location: McLean, VA
Photos: Gallery
Posts: 78
Original Poster
I no longer have the K-5; traded it in so I could get the K-3.
I bought it locally at a store, so I can go back and try it with different cameras.
I may be able to do that this weekend.

I'll try cleaning the contacts, but I doubt if that is the problem. Just too much of a coincidence.

Thanks,
David
11-13-2013, 04:00 PM   #8
Pentaxian
Bob from Aus's Avatar

Join Date: Jul 2011
Location: Australia
Photos: Gallery
Posts: 1,083
Did an indoor photoshoot at the weekend with the K3, 50-135 and a pentax flash. Went perfectly. AF seems to work better with all the lenses I have used so far, the most dramatic and impressive has been 100mm macro WR. I'm ecstatic at its ability to AF in crap light with my sigma 500. So far the AF is a winner but I don't own equivalent Nikon to compare.

11-13-2013, 04:22 PM   #9
Site Supporter




Join Date: Jun 2008
Location: McLean, VA
Photos: Gallery
Posts: 78
Original Poster
the AF is amazing with all other lens. Quick AF in almost pitch black rooms.
I'll be taking the 50-135 back to a dealer. (I've had it for years, since it first came out.)
David
11-13-2013, 05:23 PM   #10
Pentaxian
Bob from Aus's Avatar

Join Date: Jul 2011
Location: Australia
Photos: Gallery
Posts: 1,083
QuoteOriginally posted by DAKS Quote
he AF is amazing with all other lens. Quick AF in almost pitch black rooms. I'll be taking the 50-135 back to a dealer. (I've had it for years, since it first came out.) David
before you do
1. Play with the AF/MF switch on the lens
2. i think someone else suggested to clean the contacts - these are 2 contacts on the inside of the lens not on the ones near the bayonet mount.
3. Place the focus on infinity (My 60-250 has an issue when it focuses close up - it is like tooth is missing and works Ok when I manually focus on infinity)
11-13-2013, 05:52 PM   #11
Forum Member
alcstudios's Avatar

Join Date: Sep 2011
Location: Texas
Photos: Albums
Posts: 85
I've had no issues with my K3 and 50-135.
11-13-2013, 05:58 PM   #12
Site Supporter




Join Date: Jun 2008
Location: McLean, VA
Photos: Gallery
Posts: 78
Original Poster
thanks,
seems like a problem with the lens.
I'll try cleaning the contacts, etc. first.
06-20-2014, 08:16 PM   #13
Inactive Account




Join Date: Aug 2010
Location: Canada
Photos: Gallery
Posts: 9
Report of my k-3 AF in low light condition: with my 50-135mm f2.8 Pentax lens phase AF is slow, contrast AF during live view is faster than phase, in some case phase AF does not complete. same with my 16-50mm f2.8 and my 17-70mm f4.

With my Sigma 30mm f1.4 (non hsm lens) the focus is faster and more precise in contast AF rather than phase AF. I tried correct phase by adjusting it but I can not get the same result two times each after other.

My result is that phase AF
10-25-2014, 04:20 AM   #14
New Member




Join Date: Jan 2014
Posts: 13
Another K-3 AF problem

I bought a K-3 late in 2013, IE when the camera was new on the market. I have experienced a problem with the AF, which came after a while.

Sometimes the AF does not kick in. The solution has been to twist the focus ring on the lens so it gets more out of focus. This awaken the AF so it starts working again.
This situation occurs in an ongoing photo session and it come suddenly without warning. When it does happen, I can turn the camera in another direction and the AF works, but when I turn it into the direction where the problem showed up, the problem comes back. The turning-the-focus-wheel trick works every time.

As a side note, I did have a problem just recently where the AF stopped working 2 times after I re-mounted a lens. It turned out I got dirt on the contacts, so do try and keep those clean, it helps.
10-25-2014, 05:22 AM   #15
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,627
QuoteOriginally posted by FilipWessman Quote
The solution has been to twist the focus ring on the lens so it gets more out of focus. This awaken the AF so it starts working again.
Hmmm...Unless your lens has quick shift, that is a good way to damage the AF mechanism on lens and/or body.

My understanding is that you are not seeing any indication of AF operation at times. Do you have the green hexagon? Are you able to get the AF to work by pointing the camera at something very near or very far? Physically jogging the system should not wake up anything unless there is a physical problem somewhere.

What lenses?


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, dslr, k-3, k3, lens, pentax k-3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Focus Problem Unregistered Visitors' Center 6 02-28-2013 01:04 PM
Pentax K5 Auto Focus Problem Dobson Troubleshooting and Beginner Help 7 01-14-2013 04:46 AM
Auto-focus problem with beloved k-10 PC_pentax Pentax DSLR Discussion 5 01-18-2012 04:53 AM
auto/manual focus problem ndarby1 Troubleshooting and Beginner Help 6 12-10-2011 02:00 PM
K10D auto focus problem? Tom C Pentax DSLR Discussion 18 05-08-2008 01:13 AM



All times are GMT -7. The time now is 01:57 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top