Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-24-2013, 11:32 PM   #31
Veteran Member




Join Date: Jan 2011
Posts: 327
Items included say the grip is part of that package, so I think it is the same as before.

11-25-2013, 04:11 AM   #32
Senior Member
aaalegre's Avatar

Join Date: Aug 2007
Location: new jersey
Photos: Gallery | Albums
Posts: 110
QuoteOriginally posted by David&karen Quote
Items included say the grip is part of that package, so I think it is the same as before.
You're right sorry about that
11-25-2013, 08:12 AM   #33
dbh
Inactive Account




Join Date: Jan 2007
Location: Edmonton
Photos: Gallery
Posts: 404
I finally received a reply to my email to Pentax Canada. In it they described how they were unable to replicate the issue with their K-3 + D-BG5, and "also contacted the Director Service to see if we received any further inquiries regarding this issue, but it appears to be an isolated issue."

I was then advised to send it in for inspection.

In light of this thread, I think I'll hold off on doing that until at least the first firmware update is released, you know, just in case that fixes it for me. At least Pentax Canada has now heard of this issue.
11-25-2013, 08:44 AM   #34
Forum Member




Join Date: Dec 2011
Location: Edmonton, AB
Photos: Gallery
Posts: 50
Original Poster
QuoteOriginally posted by dbh Quote
I finally received a reply to my email to Pentax Canada. In it they described how they were unable to replicate the issue with their K-3 + D-BG5, and "also contacted the Director Service to see if we received any further inquiries regarding this issue, but it appears to be an isolated issue."

I was then advised to send it in for inspection.

In light of this thread, I think I'll hold off on doing that until at least the first firmware update is released, you know, just in case that fixes it for me. At least Pentax Canada has now heard of this issue.
I will send them an email too. Then it will no longer be an "isolated" incident. But it will be interesting to see if I get a similar response.

11-25-2013, 06:07 PM   #35
Senior Member
aaalegre's Avatar

Join Date: Aug 2007
Location: new jersey
Photos: Gallery | Albums
Posts: 110
QuoteOriginally posted by rskura Quote
I will send them an email too. Then it will no longer be an "isolated" incident. But it will be interesting to see if I get a similar response.
I also sent an email USA I will keep you posted
11-26-2013, 07:19 AM   #36
Senior Member
aaalegre's Avatar

Join Date: Aug 2007
Location: new jersey
Photos: Gallery | Albums
Posts: 110
QuoteOriginally posted by aaalegre Quote
I also sent an email USA I will keep you posted
They got back to me and hers what they said

Thank you for contacting RICOH.

We have not been informed by RICOH Japan of an issue with the BG-5 battery grip for the K3. If possible you may want to try and exchange the grip with the dealer.

If you are in need of further assistance, please respond to this email or call our technical support center at 800-877-0155.

Sincerely,
Randall S.
RICOH IMAGING AMERICAS CORPORATION
PHONE: 800.234.0276 / 800.877.0155



Your Email:
K-3 Power-on issue I have been having problems with the battery grip installed It will not power on most of the time. Are you aware of this and what shall I do Wait for the firmware first or return it ? Heres the tread in the forum.
I replied back and told them that I had the Silver edition.I hope they can exchange it
11-26-2013, 08:33 AM   #37
Forum Member




Join Date: Dec 2011
Location: Edmonton, AB
Photos: Gallery
Posts: 50
Original Poster
QuoteOriginally posted by aaalegre Quote
They got back to me and hers what they said

Thank you for contacting RICOH.

We have not been informed by RICOH Japan of an issue with the BG-5 battery grip for the K3. If possible you may want to try and exchange the grip with the dealer.

If you are in need of further assistance, please respond to this email or call our technical support center at 800-877-0155.

Sincerely,
Randall S.
RICOH IMAGING AMERICAS CORPORATION
PHONE: 800.234.0276 / 800.877.0155



Your Email:
K-3 Power-on issue I have been having problems with the battery grip installed It will not power on most of the time. Are you aware of this and what shall I do Wait for the firmware first or return it ? Heres the tread in the forum.
I replied back and told them that I had the Silver edition.I hope they can exchange it

If I had the silver edition, I'd be hesitant to send the grip in for exchange. Unless maybe you can buy a new one, and then send this one in for credit once you have the new one in hand. Can you even buy a silver grip on it's own? Maybe not.

I still think I am going to wait for a firmware upgrade before I consider sending my black grip in for exchange. It would be nice to have a more definitive answer from Ricoh, rather than just, "we haven't heard anything."
12-09-2013, 10:39 AM   #38
New Member




Join Date: Mar 2009
Location: Almelo, The Netherlands
Posts: 15
It has become quiet on this thread. Does this mean we are the only few with a D-BG5 grip-related power on issue or do others also suffer from this problem? In other words: who has a D-BG5 grip and never has been confronted with the power on issue?

12-09-2013, 12:34 PM   #39
Senior Member
aaalegre's Avatar

Join Date: Aug 2007
Location: new jersey
Photos: Gallery | Albums
Posts: 110
I still do I just turn the battery around inside the grip as a spare.. Hoping and waiting for a firmware update ..
12-09-2013, 12:58 PM   #40
Forum Member
alcstudios's Avatar

Join Date: Sep 2011
Location: Texas
Photos: Albums
Posts: 85
I have been one of the lucky ones, never had an issue with the grip.
12-09-2013, 01:22 PM   #41
Loyal Site Supporter
RockvilleBob's Avatar

Join Date: Dec 2011
Location: Lewes DE USA
Photos: Albums
Posts: 1,698
I feel the "back order" situation with the grip may indeed indicate a design issue with the grip. An email I received from Ricoh indicated the the grips were on back order with the manufacturer. B&H has been out of stock for about a month. I also think it has to do with how you set the battery options in the K-3 menu. I changed mine from AUTO to grip first then K-3, I just do not like auto unless I know what auto means.perhaps leaving it on the default auto results in no issue? Either way I was out in the snow/sleet/rain storm in the Washington DC area this week taking pictures of my grandson's football game and had to change batteries - boy I needed that grip. Changing batteries with cold numb fingers in bad weather is not easy.
12-09-2013, 01:33 PM   #42
Forum Member




Join Date: Dec 2011
Location: Edmonton, AB
Photos: Gallery
Posts: 50
Original Poster
I am also still waiting and hoping for a firmware update solution. It doesn't seem to matter which battery settings I use, the problem remains. The frustrating part is that sometimes it will work fine, other times it just won't. No apparent change in any conditions. For now, I keep the grip on the camera, but just don't keep a battery in it. I like aaalegre's temporary solution to turn the battery around in the grip to have it for a spare. Still, not very convenient when you do have to change batteries.

The thing that worries me is the problem doesn't seem all that widespread, so maybe I should have returned my grip to the store. Maybe it is a manufacturing problem and I just got a bad one.
12-09-2013, 02:53 PM   #43
dbh
Inactive Account




Join Date: Jan 2007
Location: Edmonton
Photos: Gallery
Posts: 404
It does indeed look like the problem is uncommon - however my hunch is that the bug is actually with the camera. The reason I think this is that I tried out my K-5's grip (D-BG4) on the K-3 (temporarily removed the plate with the pins on it so it would attach) and the camera behaved the same way as it did with the new D-BG5 - intermittent power-on problem after sitting a few minutes while turned off.

If the first firmware does not solve the problem, I'll then just send the whole thing in for warranty repair. Meanwhile I have never once had the power-on problem while having only one battery in the camera so the frustration is really minimal for me, for now.
12-09-2013, 03:47 PM   #44
Senior Member
gryhnd's Avatar

Join Date: Jul 2013
Location: Southeastern MA
Posts: 225
QuoteOriginally posted by Miguel Quote
Yes, yesterday was my first time using the grip. After attaching the grip I turned on the camera and it froze, the screen remaining the same even if the camera was switched off. I was flabbergasted. And a little nervous as the soccer match I was scheduled to shoot was ten minutes from starting. So I unhitched the grip and removed the battery and life was good. But that's strike one against the camera and Ricoh. They should have rigorously tested stuff like that prior to releasing a product.
FWIW, I've had a similar problem twice with my K5iis+grip whereby the screen suddenly locked up and turning off body and grip did nothing. This happened in the middle of a wedding too! Both times necessitated removing the grip and the main battery to restore normal function. I was terrified the first time it happened at the wedding that I'd lose my shots, but I did not...whew.
12-09-2013, 03:58 PM   #45
Site Supporter
G_Money's Avatar

Join Date: Jul 2007
Location: London, Ontario, Canada
Posts: 594
FWIW mine does the same thing, but using just one battery and having it in the grip works fine. Also, one time it powered on and started in machine gun mode, firing at maximum burst rate until the battery was pulled. Fingers are crossed for a timely firmware upgrade.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, d-bg5, dslr, grip, issue, k-3, k3, pentax k-3, position, power, problem, thread, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Q Power Up Issue Smash Pentax Q 30 02-24-2017 09:29 PM
K-3 flash issue konraDarnok Pentax K-3 68 03-13-2014 06:07 AM
WB issue in LR 5 with K-3 DNG Azzy Pentax K-3 21 12-16-2013 04:51 PM
Power Zoom Lens on a K-x Alizarine Pentax SLR Lens Discussion 10 07-16-2013 09:19 AM
Power issue with Yongnuo Flashes/Eneloops philbaum Flashes, Lighting, and Studio 7 10-30-2012 10:21 PM



All times are GMT -7. The time now is 11:05 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top