Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-17-2013, 05:56 AM   #1
Site Supporter




Join Date: Jul 2011
Location: Melbourne
Photos: Gallery
Posts: 65
Camera hung after turning off in LV

Strange thing happened tonight. I was watching the rear screen in Liveview with an FA 85mm. After testing out the low light focus assist light etc I switched the camera off. The rear screen stayed on with a last image showing on the screen. A sort of electronic humm was coming from the camera and turning the camera on and off at the switch had no effect. Eventially I removed the grip and body batteries to turn off the display and camera. The batteries were replaced and the camera fired up fine with no further issues. Loving the camera so far and finding the focus accuracy fantastic with the exposures spot on. I guess version 1.0 firmware needs a slight tweak

11-17-2013, 09:28 AM   #2
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,656
QuoteOriginally posted by garywakeling Quote
Strange thing happened tonight. I was watching the rear screen in Liveview with an FA 85mm. After testing out the low light focus assist light etc I switched the camera off. The rear screen stayed on with a last image showing on the screen. A sort of electronic humm was coming from the camera and turning the camera on and off at the switch had no effect. Eventially I removed the grip and body batteries to turn off the display and camera. The batteries were replaced and the camera fired up fine with no further issues. Loving the camera so far and finding the focus accuracy fantastic with the exposures spot on. I guess version 1.0 firmware needs a slight tweak
I does seem that there is some bug with the grip and various battery settings.
11-17-2013, 09:57 AM   #3
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
Hopefully these quirks don't show up while being used professionally.
11-17-2013, 09:59 AM   #4
Pentaxian




Join Date: Jan 2011
Location: New York
Posts: 3,311
I've seen the K-5 lockup for different reasons. When it happens, the power switch also fails to reset it just like your K-3, pulling batteries is the only fix.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, dslr, focus, k-3, k3, light, pentax k-3, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
turning display off Bill G Pentax K-30 & K-50 2 10-14-2013 03:38 PM
Optio RZ18 turns off right after turning it on SithLord Troubleshooting and Beginner Help 3 07-05-2013 05:20 AM
K-5 - Turning off the Histogram in Replay Mode jeallen01 Pentax K-5 2 03-26-2011 04:20 PM
Pictures lost after turning camera off and back on! (K7) Help! Arrvon Pentax DSLR Discussion 3 10-18-2010 06:13 PM
Switching lenses without turning off camera? hcc Pentax DSLR Discussion 48 05-27-2010 01:22 AM



All times are GMT -7. The time now is 02:39 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top