Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Have you experienced any problems with your K-3?
My K-3 has never had any problems 5963.44%
My K-3 has or have had minor problems that do not render it unusable 3032.26%
My K-3 has or have had major problems that render it unusable 44.30%
Voters: 93. You may not vote on this poll

Reply
Show Printable Version Search this Thread
11-21-2013, 03:27 PM   #46
Pentaxian
mattb123's Avatar

Join Date: Apr 2010
Location: Colorado High Country
Photos: Gallery
Posts: 7,034
I've had a couple of lock ups. I think that is more likely to happen with a low(ish) battery. At least that's the only time my K-5 would lock up was on a battery that was getting low (but may not yet show as low, or only a little low on the display).

11-21-2013, 03:31 PM   #47
Site Supporter
K David's Avatar

Join Date: Oct 2012
Location: SF Bay Area
Photos: Gallery
Posts: 1,201
My glitch has occurred when scrolling through photos quickly: [URL="https://www.pentaxforums.com/forums/172-pentax-k-3/242887-my-first-k-3-glitch.html#post2583070"My First K-3 Glitch[/URL]
11-21-2013, 03:56 PM   #48
Forum Member




Join Date: Dec 2011
Location: Edmonton, AB
Photos: Gallery
Posts: 50
K-3 doesn't always power on when grip is installed

My K-3 won't power on sometimes when the D-BG5 grip is installed.

Details here: https://www.pentaxforums.com/forums/172-pentax-k-3/242792-k-3-power-issue.html
11-21-2013, 10:07 PM   #49
Forum Member




Join Date: Jan 2012
Location: Melbourne Outer East
Photos: Albums
Posts: 94
Stupid FLU Card is not recognised by the K-3, other than that I have a fine example.

11-22-2013, 07:48 AM   #50
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,754
QuoteOriginally posted by DaveXT Quote
Stupid FLU Card is not recognised by the K-3, other than that I have a fine example.
You got a FLUcard? How did you pull that off?
11-22-2013, 03:26 PM   #51
Forum Member




Join Date: Jan 2012
Location: Melbourne Outer East
Photos: Albums
Posts: 94
QuoteOriginally posted by normhead Quote
You got a FLUcard? How did you pull that off?
Standard 8 gb FLU cards were bundled with the K-3 in Australia.
These are not the FLU cards dedicated to the K-3 and are next to useless.
11-22-2013, 03:29 PM - 1 Like   #52
Forum Member




Join Date: Apr 2008
Location: Australia
Photos: Albums
Posts: 81
QuoteOriginally posted by normhead Quote
You got a FLUcard? How did you pull that off?
The Australian Pentax distributor, CR Kennedy, bundled a generic Flucard Pro with the K-3. This card is not the proprietary Flucard, which will carry the Pentax branding.

There is some confusion about whether this card is working correctly with the K-3, as the card is not recognized in the wireless settings menu in the K-3. However, the generic Flucard does seem to work correctly, by following the operating instructions provided with the card.

The K-3 does recognize the generic Flucard as an SD card. For this reason, I believe that these cards are working as intended in the K-3, and that the menu options for the Flucard will only be applicable to the Pentax proprietary Flucard.
11-23-2013, 08:59 AM   #53
Senior Member




Join Date: Jun 2013
Posts: 217
These issues are making me have concerns about purchasing a K-3.

11-23-2013, 09:12 AM   #54
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,754
If you can find something else that's perfect, go with that. I'm not sure it's going to reduce you chances of having problems. We sent our K-5 back a while ago because it locked up. Pentax reported, when they opened the box and inserted a battery, there was no issue. They tried multiple times over a number of days to lock it up again without success, then sent it back to us. Sometimes with electronics, things happen. That's just life. So unless you're thinking of buying a K-1000, I'm not sure what you're going to find that's better.
11-23-2013, 09:22 AM   #55
Junior Member




Join Date: Nov 2013
Posts: 41
QuoteOriginally posted by Winder Quote
Mine has locked up twice while shooting a long burst and once while processing a test shot of one of the filters. Out of 2000 images that's nothing to worry about. I'm sure firmware will improve stability.
Mine did the exact same thing. Couldn't technically turn it off (screen stayed on); it required a battery pull.
11-23-2013, 11:28 AM   #56
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,754
QuoteOriginally posted by phreon Quote
Mine did the exact same thing. Couldn't technically turn it off (screen stayed on); it required a battery pull.
We had pulled the battery numerous times, done a reset. everything we could think of. Somewhere between our house and Ricoh Canada, it fixed itself.
11-23-2013, 12:40 PM   #57
Veteran Member
ChrisJ's Avatar

Join Date: Nov 2008
Location: Eckington, Derbyshire UK
Photos: Gallery | Albums
Posts: 316
QuoteOriginally posted by Winder Quote
Mine has locked up twice while shooting a long burst and once while processing a test shot of one of the filters. Out of 2000 images that's nothing to worry about. I'm sure firmware will improve stability.
Was it a slow card? Once the buffer is full or close to full it can take an age to empty the buffer onto the card with slow cards.

Edit: the light next to the SD slot will flash slowly, it's the card activity lamp.

Chris
11-23-2013, 03:07 PM   #58
Junior Member




Join Date: Nov 2013
Posts: 41
QuoteOriginally posted by ChrisJ Quote
Was it a slow card? Once the buffer is full or close to full it can take an age to empty the buffer onto the card with slow cards.

Edit: the light next to the SD slot will flash slowly, it's the card activity lamp.

Chris
In my case, I was using 32 Gig Sandisk Extreme card B&H bundled with the camera. The camera was not busy writing - the rear display stayed on displaying exposure info (not updating) regardless of power switch setting, none of the controls responded, the secondary display showed semi-random info regardless of power switch settings as well.

Doug
11-23-2013, 03:40 PM   #59
New Member




Join Date: Nov 2013
Posts: 10
Well add me to the list of people who has at least one problem with the camera.

Yesterday when I first received my camera, I immediately went to test it indoors. Everything was fine until I decided to test the 8.3 fps burst. I followed what the manual stated (shutter speed is dependant on continuous shooting). So I went for the high shutter speed numbers, at least starting from 100, and went my way up to see if it gets any faster. I was curious about the shutter speeds at 3000 with continuous shooting, it was lovely to say the least. Then when I lowered the shutter to 200-400 instantly and pressed the shutter, it went beserk. It shot continuous frames for 10 seconds and it was still going mad with the shooting! I couldn't control the camera in any way, no button interaction, no LCD interaction, not even the power switch worked. So I had to resort to remove the battery and try again. It hasn't done that again after testing it outside with wildlife, but I am still a bit fearful of my new pentax product. Should I contact B&H and possibly get a replacement? Or should I just let it be and hope for a firmware stability update?
11-23-2013, 03:43 PM   #60
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
QuoteOriginally posted by Jbloomerjo Quote
Well add me to the list of people who has at least one problem with the camera.

Yesterday when I first received my camera, I immediately went to test it indoors. Everything was fine until I decided to test the 8.3 fps burst. I followed what the manual stated (shutter speed is dependant on continuous shooting). So I went for the high shutter speed numbers, at least starting from 100, and went my way up to see if it gets any faster. I was curious about the shutter speeds at 3000 with continuous shooting, it was lovely to say the least. Then when I lowered the shutter to 200-400 instantly and pressed the shutter, it went beserk. It shot continuous frames for 10 seconds and it was still going mad with the shooting! I couldn't control the camera in any way, no button interaction, no LCD interaction, not even the power switch worked. So I had to resort to remove the battery and try again. It hasn't done that again after testing it outside with wildlife, but I am still a bit fearful of my new pentax product. Should I contact B&H and possibly get a replacement? Or should I just let it be and hope for a firmware stability update?
Sounds like a firmware fix might be what you need. Others have reported something similar to this too.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, future, k-3, k3, pentax k-3, poll, reliability
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DPR/Pentax K-3 ongoing poll results Greyser Pentax K-3 37 10-07-2013 07:41 PM
OFFICIAL K-01 Styling Poll Adam Pentax K-01 136 04-13-2012 11:58 AM
K-r reliability poll bwDraco Pentax K-r 30 02-24-2012 04:05 PM
3 lens combo poll vrrattko Pentax SLR Lens Discussion 9 07-14-2011 02:07 PM
Looking for owner reviews on the K-7, performance, reliability, use SkagitFly Pentax DSLR Discussion 42 10-07-2010 04:46 AM



All times are GMT -7. The time now is 08:32 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top