Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-22-2013, 04:47 AM   #1
Junior Member




Join Date: Jan 2013
Location: Adelaide, South Autralia
Posts: 36
K3 Firmware 1.01 What's the secret?

What is the secret in loading firmware 1.01 into my K3. I've formatted a new Sandisk extreme pro SD card, copied the 16.8mb fwdc220b.bin file to the SD card (alongside the DCIM ) but every time i turn the camera on with the menu button pressed it goes to the normal status screen!
Does the camera need to see the bin file before allowing the upgrade to appear on the screen when turning on?
I've tried deleting the DCIM so there is only the bin file showing etc, etc.
I can view the present software by going to the Firmware info/Options in the menu but whatever i do, i can't seem to access the firmware update by turning the camera on with the menu button pressed.
Is anyone having similar problems? I could certainly appreciate some help here.

12-22-2013, 04:52 AM   #2
Pentaxian
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,655
Are you using slot 1 or slot 2? I needed to use slot one for the upgrade to work.
12-22-2013, 05:10 AM   #3
Junior Member




Join Date: Jan 2013
Location: Adelaide, South Autralia
Posts: 36
Original Poster
QuoteOriginally posted by wizofoz Quote
Are you using slot 1 or slot 2? I needed to use slot one for the upgrade to work.
Much appreciated WIZOFOZ. I really thought i'd already tried this one along with others. All loaded. Cheers.
12-22-2013, 05:32 AM   #4
Pentaxian
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,655
Glad to help

12-22-2013, 07:06 AM   #5
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,423
QuoteOriginally posted by wizofoz Quote
Are you using slot 1 or slot 2? I needed to use slot one for the upgrade to work.
QuoteOriginally posted by Jimlad Quote
Much appreciated WIZOFOZ. I really thought i'd already tried this one along with others. All loaded. Cheers.
I get confused by the LOCATION of Slot 1. It doesn't seem intuitive that from the back it is Rear / High.

I loaded my Eye-Fi card to play with the new wireless menu.
  • First time it said, "No WiFi card loaded in slot 2." Huh? Oh, Duh.
  • Second time - I had already programmed that card for my Q - there was no Menu action to do - it just instantly connected and the Wi-Fi icon appeared on my LCD.
    • My K3 is now IP Address xxx.xxx.x.112. Don't hack me, bro!
12-22-2013, 01:39 PM   #6
Pentaxian
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,655
QuoteOriginally posted by monochrome Quote
I get confused by the LOCATION of Slot 1. It doesn't seem intuitive that from the back it is Rear / High.

I loaded my Eye-Fi card to play with the new wireless menu.
  • First time it said, "No WiFi card loaded in slot 2." Huh? Oh, Duh.
  • Second time - I had already programmed that card for my Q - there was no Menu action to do - it just instantly connected and the Wi-Fi icon appeared on my LCD.
    • My K3 is now IP Address xxx.xxx.x.112. Don't hack me, bro!
Interesting.

My flu card that came with the K-3 is not recognised as being a wireless card by the camera. I was hoping the firmwre update would fix this, but no. Hopefully the Pentax branded flu-card will not have the same problem.

(sorry to the OP for being so off topic)
12-22-2013, 02:49 PM   #7
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,655
QuoteOriginally posted by wizofoz Quote
Interesting.

My flu card that came with the K-3 is not recognised as being a wireless card by the camera. I was hoping the firmwre update would fix this, but no. Hopefully the Pentax branded flu-card will not have the same problem.

(sorry to the OP for being so off topic)
Remember the Pentax specific Flu card is not supposed to be available for at least another month. There have been several threads discussing this. The camera can apparently recognize only that card and the Eye-Fi card. However, any other wifi card will work normally if you set it up according to the card specific instructions. The other cards do not need Pentax to recognized them it is just easier if it does. Be sure to change your power saver settings so the camera does not shut down while the card is connecting. I just put a Transcend WiFi card in my K3 slot 2. Camera said no WiFi present. I proceeded to connect easily to the card from my phone by selecting the card's wifi signal.
12-22-2013, 04:05 PM   #8
Pentaxian




Join Date: Apr 2007
Location: Romania
Posts: 9,311
QuoteOriginally posted by monochrome Quote
I get confused by the LOCATION of Slot 1. It doesn't seem intuitive that from the back it is Rear / High.
IIRC they're marked with a number and a small arrow - am I right?

12-22-2013, 05:48 PM   #9
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,423
QuoteOriginally posted by Kunzite Quote
IIRC they're marked with a number and a small arrow - am I right?
Well yeah, if you look.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bin, button, camera, dcim, dslr, firmware, k-3, k3, k3 firmware, menu, pentax k-3, screen, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's going on with the 01 lens mdintx Pentax Q 4 12-18-2013 05:32 AM
what is the secret of this hack ?? photoshoper Pentax DSLR Discussion 3 06-13-2013 04:43 AM
K-01 firmware update 1.01 kesong Pentax K-01 87 03-13-2013 05:31 PM
Does anyone know if it's possible to downgrade Firmware from 1.03 to 1.01? Christine Tham Pentax K-5 73 03-15-2011 02:00 PM
What's the secret or trick for eyes? kklabunde Photographic Technique 10 10-07-2009 01:52 AM



All times are GMT -7. The time now is 11:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top