Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-23-2013, 02:18 PM   #1
Junior Member




Join Date: Mar 2011
Location: Amersham, UK
Photos: Albums
Posts: 26
AF assist light only works in green mode

The camera's internal AF Assist light and the AF Assist LED on the AF360FGZII appear to work only in green mode. I have just upgraded my firmware to 1.01, and am sure it used to work in other modes before the software upgrade.
All comments appreciated!
Regards Rob


Last edited by robheath; 12-23-2013 at 03:03 PM. Reason: typo
12-23-2013, 02:44 PM   #2
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,180
Did you check the AF light setting?
I know that my K-5II only uses it when it's really (really really) dark. Maybe the Auto mode just uses it at higher light levels.
12-23-2013, 03:08 PM   #3
Junior Member




Join Date: Mar 2011
Location: Amersham, UK
Photos: Albums
Posts: 26
Original Poster
The AF Assist light is turned on in the menu. And yes I went really dark (lens cap on), but still got the same result
12-23-2013, 03:15 PM   #4
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
I just checked my K-3 with the AF540 FGZII and the LED assist comes on in all modes.

With the flash removed the green assist light works in all modes also.

I am running FW 1.01
AF assist light setting is on.
I tried it in a dark room, not with the lens cap on.


Last edited by crewl1; 12-23-2013 at 03:22 PM.
12-23-2013, 03:49 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,032
QuoteOriginally posted by robheath Quote
The camera's internal AF Assist light and the AF Assist LED on the AF360FGZII appear to work only in green mode. I have just upgraded my firmware to 1.01, and am sure it used to work in other modes before the software upgrade.
All comments appreciated!
Regards Rob
The update may have reset your custom settings, so I would start by checking those.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-23-2013, 04:07 PM   #6
Veteran Member




Join Date: May 2012
Posts: 698
I have just checked my K-3 and I get the same result - that is assist light only in green mode, well almost.

I found that in the U1, U2 and U3 modes the green assist light does work. Now those modes override most of the settings so I am guessing there is some setting somewhere that is preventing the focus light from doing its thing. However I've been going through the settings and one by one making them match what is in U1 and still cannot get the focus light to come on. Even tried it in a completely dark room. So dark that a 30 second exposure at max ISO gave a completely black image except for the noise.

Maybe a factory reset would fix it but I'm not going to try that as there are too many things I'll need to set up again. I might eventually though if nothing else fixes this issue.

I have a feeling that this went wrong after upgrading to 1.01 but I'm not sure.
12-23-2013, 04:17 PM - 2 Likes   #7
Veteran Member




Join Date: May 2012
Posts: 698
Figured it out - if I switch from AF.C to AF.S the light works just the same as it does in green mode.

What was in common between the User modes and green mode is that all four were doing AF.S or AF.A (which includes S).

I don;t know if this is a bug or design intent.Could be some sense in not using the focus light for AF.c but not so sure when I think about it.

Strangely enough then in live view it works both in af.c and af.s
12-23-2013, 04:35 PM - 1 Like   #8
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
QuoteOriginally posted by lister6520 Quote
Figured it out - if I switch from AF.C to AF.S the light works just the same as it does in green mode.

What was in common between the User modes and green mode is that all four were doing AF.S or AF.A (which includes S).

I don;t know if this is a bug or design intent.Could be some sense in not using the focus light for AF.c but not so sure when I think about it.

Strangely enough then in live view it works both in af.c and af.s
I reproduced it here, good catch. Must be by design, hope that is the OP's situation.

Edit: confirmed on P45 only says Assist function in AF-S. Omitted from AF-C.

Attached Images
 
12-23-2013, 07:58 PM   #9
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
I think it has to work that way (no AF assist light in AF.C mode) otherwise you'd get an inaccurate metering and perhaps the subject looking like an alien in the shots.
12-24-2013, 12:30 AM   #10
Junior Member




Join Date: Mar 2011
Location: Amersham, UK
Photos: Albums
Posts: 26
Original Poster
Great research thanks
AF.S is the answer!
I did read the manual cover to cover, but it was a while ago.
I can see some logic in it not turning on for AF.C: if it was on for AF.C presumably it would have to occult each time the shutter opens in order to avoid affecting exposure/colour cast.
09-30-2017, 09:53 AM   #11
Senior Member




Join Date: Jan 2011
Location: Missouri
Photos: Gallery
Posts: 199
Thanks for figuring this out. I thought mine was burnt out or something!
10-01-2017, 10:33 AM   #12
Senior Member
Larrymc's Avatar

Join Date: Jun 2014
Posts: 224
QuoteOriginally posted by robheath Quote
Great research thanks
AF.S is the answer!
I did read the manual cover to cover, but it was a while ago.
I can see some logic in it not turning on for AF.C: if it was on for AF.C presumably it would have to occult each time the shutter opens in order to avoid affecting exposure/colour cast.

Just curious, why have you not updated to ver. 1.30 of the firmware? If I read correctly you do own a K-3 not a K-3II.


Larry
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, af assist light, dslr, k-3, k3, light, mode, pentax k-3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Af assist light Dionisis_K Pentax Camera and Field Accessories 5 11-21-2012 04:56 AM
AF assist light HSV Pentax DSLR Discussion 7 09-10-2012 07:03 PM
Green dot in movie mode on K5 and AF lamp not auto ligh haisun Troubleshooting and Beginner Help 10 07-08-2012 10:48 AM
K7 in Green Mode - JPEG only? jpzk Pentax DSLR Discussion 22 08-10-2010 04:56 PM
K-7 shake reduction only in green mode MikeOz Pentax DSLR Discussion 4 01-16-2010 02:07 PM



All times are GMT -7. The time now is 09:38 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top