Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-28-2014, 02:37 AM   #1
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 1,273
Pentax K3 jpeg unknown lens in Aperture

In addition to there being no Apple support yet for RAW files from the Pentax K3, there is even a problem with jpeg. With all lenses, Aperture reports "Unknown Lens" in the EXIF for jpeg files. Pentax Digital Camera Utility 5 reports the correct lens. Has anybody else seen this? I have tried Pentax DA 40 Ltd, DA 18-135, and Tamron 90 (actually, DCU doesn't report the Tamron, but I guess that's normal). I have the latest Aperture (3.5.1) and Version 1.01 firmware in the K3.

01-28-2014, 04:21 AM   #2
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,472
Testing now...
01-28-2014, 04:31 AM   #3
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 1,273
Original Poster
QuoteOriginally posted by Paul the Sunman Quote
In addition to there being no Apple support yet for RAW files from the Pentax K3, there is even a problem with jpeg. With all lenses, Aperture reports "Unknown Lens" in the EXIF for jpeg files. Pentax Digital Camera Utility 5 reports the correct lens. Has anybody else seen this? I have tried Pentax DA 40 Ltd, DA 18-135, and Tamron 90 (actually, DCU doesn't report the Tamron, but I guess that's normal). I have the latest Aperture (3.5.1) and Version 1.01 firmware in the K3.
Just discovered the K-30 does the same. The K-5 is fine though.
01-28-2014, 04:55 AM   #4
Senior Member




Join Date: Nov 2007
Location: Berlin, Germany
Photos: Gallery
Posts: 151
QuoteOriginally posted by Paul the Sunman Quote
In addition to there being no Apple support yet for RAW files from the Pentax K3, there is even a problem with jpeg. With all lenses, Aperture reports "Unknown Lens" in the EXIF for jpeg files. Pentax Digital Camera Utility 5 reports the correct lens. Has anybody else seen this? I have tried Pentax DA 40 Ltd, DA 18-135, and Tamron 90 (actually, DCU doesn't report the Tamron, but I guess that's normal). I have the latest Aperture (3.5.1) and Version 1.01 firmware in the K3.
Same here. Pentax Q and K20D are reported correctly (i.e. cam + lens).

01-28-2014, 05:07 AM   #5
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,472
Confirmed. K-3 says "unknown lens" in Aperture when looking at the camera generated JPG file.
However, when I upload a JPG directly to Flickr, the information is there.
01-28-2014, 09:43 AM   #6
Veteran Member
maxfield_photo's Avatar

Join Date: Mar 2011
Location: Cincinnati, OH
Posts: 1,215
It's possible that the lens information is stored in a different memory address in the Jpeg files, and so Aperture is just looking in the wrong place and not finding what it needs. If this is the case it's something their tech support needs to address, but the good news is it should be a very easy fix for them. I would contact their tech support, or report it as a bug if there is a forum for that.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, dslr, files, jpeg, jpeg unknown lens, k-3, k3, lens, pentax, pentax k-3, pentax k3 jpeg, reports, tamron
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aperture v Lightroom for Pentax K3 lochness Digital Processing, Software, and Printing 18 12-13-2013 03:00 PM
K3 Jpeg EXIF Data is missing values unkipunki Pentax K-3 9 11-14-2013 03:22 AM
Aperture Software and Pentax Unknown Lens debkim Digital Processing, Software, and Printing 7 12-08-2012 04:14 PM
Unknown Pentax and Lens spotted in Kruger Park GordonZA Pentax SLR Lens Discussion 29 12-24-2011 11:02 AM
WAH! Unknown or Invalid JPEG Marker Ira Digital Processing, Software, and Printing 6 08-24-2010 02:25 AM



All times are GMT -7. The time now is 03:53 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top