Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-24-2015, 03:17 PM   #796
Pentaxian
Arjay Bee's Avatar

Join Date: Sep 2006
Location: Bamaga, QLD
Photos: Gallery | Albums
Posts: 3,004
QuoteOriginally posted by BigMackCam Quote
And that's with the Prestige version, yes?
Yes.

Was doing ANZAC dawn service earlier today, camera on tripod, long exposures repeatedly, grip attached, flash attached - no repetitions of the flutter.

May just ignore it as I have 6 months on my warranty to monitor it before I do anything.

04-25-2015, 03:07 PM   #797
Moderator
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,285
QuoteOriginally posted by Arjay Bee Quote
Yes.

Was doing ANZAC dawn service earlier today, camera on tripod, long exposures repeatedly, grip attached, flash attached - no repetitions of the flutter.

May just ignore it as I have 6 months on my warranty to monitor it before I do anything.
Sorry to hear that. Well, as I've suggested before, no product this sophisticated is totally bug free. I think you're right to hold fire for now and see how you get on, especially with so much of your warranty period left...
04-26-2015, 04:07 AM   #798
Forum Member




Join Date: Dec 2014
Photos: Gallery
Posts: 74
QuoteOriginally posted by WPRESTO Quote
FOLLOWUP on my experience. Since the mirror went crazy during our trip to Africa I've taken 8,000+ shots with no repetition of wild mirror mirror syndrome.
Did you change anything after it happened? Or did you just leave everything as it was? Say batteries, grip, settings etc.
04-26-2015, 04:50 AM   #799
Loyal Site Supporter
WPRESTO's Avatar

Join Date: Aug 2010
Location: Massachusetts
Photos: Gallery | Albums
Posts: 25,046
QuoteOriginally posted by CNunez Quote
Did you change anything after it happened? Or did you just leave everything as it was? Say batteries, grip, settings etc.
I installed a firmware upgrade - forget offhand what is in the camera now.

05-30-2015, 09:36 PM   #800
Loyal Site Supporter




Join Date: Jun 2012
Location: South Coast, NSW
Posts: 257
Mine has started doing it, and also seems to be locking up occasionally. Still under warranty for another couple of months so will contact Kennedy once home from holiday on Tuesday.

Anyone from Australia had experience with actually getting it fixed?
05-30-2015, 10:01 PM   #801
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,018
QuoteOriginally posted by snpsht Quote
Still under warranty for another couple of months so will contact Kennedy once home from holiday on Tuesday.
It would be interesting to hear whar they have to say about it.
05-30-2015, 11:23 PM   #802
Site Supporter
Dougg's Avatar

Join Date: Jan 2011
Location: Central Washington
Photos: Albums
Posts: 251
An update to my repair process might be useful.
1 Apr 2015 shipped from US northwest to US northeast, enclosing copy of purchase receipt with handwritten note about the mirror problem
6 Apr No communication from Precision but package tracking indicates delivery today
16 Apr Camera arrived back to me with note that repair was complete on 4/9/2015
Pretty pleased at speed of service, not so happy about lack of communication but their speed largely makes up for it!

Their note with the camera said:
A complete repair and return all functions to factory specs.
Cleaned image sensor
Auto focus test, check, calibration and realignment
Firmware download: corrections and adjustments; address values measured and adjusted
Complete cleaning (internal - external) and optical system.

Doug
05-31-2015, 12:27 AM   #803
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
QuoteOriginally posted by snpsht Quote
Mine has started doing it, and also seems to be locking up occasionally. Still under warranty for another couple of months so will contact Kennedy once home from holiday on Tuesday.

Anyone from Australia had experience with actually getting it fixed?
I tried sending mine in before the warranty ran out but was told by Kennedy that there was no fix other than the 1.11 firmware work-around. They did suggest that if there ever was a proper fix that an expired warranty wouldn't be a problem but I don't know how that would work out in practice.

John.

05-31-2015, 03:25 PM   #804
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,018
Thanks for that.
06-01-2015, 04:17 PM   #805
Senior Member
asharpe's Avatar

Join Date: Sep 2007
Location: Palo Alto, CA
Posts: 173
QuoteOriginally posted by Dougg Quote
Firmware download: corrections and adjustments; address values measured and adjusted
Doug
Did they just, in fact, only install the latest firmware that anyone can get, or was your firmware version unchanged, which would indicate that they updated the non-user-accessible firmware?
06-01-2015, 06:39 PM   #806
Pentaxian
audiobomber's Avatar

Join Date: May 2008
Location: Sudbury, Ontario
Photos: Albums
Posts: 6,661
QuoteOriginally posted by asharpe Quote
Did they just, in fact, only install the latest firmware that anyone can get, or was your firmware version unchanged, which would indicate that they updated the non-user-accessible firmware?
My firmware was updated before I sent the camera in. The service ticket says "Reprogrammed camera".

Last edited by audiobomber; 06-01-2015 at 06:59 PM.
06-01-2015, 11:36 PM   #807
Junior Member
dicks's Avatar

Join Date: Mar 2014
Location: Munich, Germany
Posts: 36
I'm in Germany and my Silver K-3 was one of the first but I have never had this issue. Warranty is running out, should I send it in to Pentax to get "the fix" applied (assuming there is a hardware fix)?
06-20-2015, 11:00 PM   #808
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 1,222
I had my second K3 mirror flap episode a couple of days ago on a warm sunny day in Tenerife. Unlike the first time, on April 1 last year (really!), it stopped automatically after about four flaps. No damage done. I had to remove the battery to stop it last time. This time I had V1.21 firmware installed; last time it was V1.03.
06-21-2015, 01:12 AM   #809
Site Supporter
Dougg's Avatar

Join Date: Jan 2011
Location: Central Washington
Photos: Albums
Posts: 251
QuoteOriginally posted by asharpe Quote
Did they just, in fact, only install the latest firmware that anyone can get, or was your firmware version unchanged, which would indicate that they updated the non-user-accessible firmware?
Hi-- The latter. I sent the camera in with fw 1.11 and it came back still reporting 1.11. I expect the firmware they reported installing was the other non-user-accessible one.

Doug
06-28-2015, 06:39 AM   #810
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,526
Has firmware 1.21 solve this issue? I have the gun metal prestige coming and this thread is making me a bit nervous!

Thanks

Randy
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
adapter, batteries, battery, body, camera, conclusion, crazy-ass mirror sickness, dslr, frame, grip, issue, k-3, k3, kiss, mirror, mirror sickness mirror, pentax, pentax k-3, post, shots, sickness, temperature, time, time lapse, view, voltage
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 failure - couldn't stop the mirror flapping up and down Photodana Pentax K-3 26 06-11-2014 03:19 PM
Help - Pentax K2 Mirror Lockup replacement barbosas Pentax Film SLR Discussion 6 11-06-2013 08:09 AM
Mirror lockup O'Brien 860 Pentax K-30 & K-50 23 07-14-2013 05:16 PM
Pentax MX mirror lockup lever mod? asaru Pentax Film SLR Discussion 4 12-24-2012 07:45 AM
mirror lockup Andrew Crouch Pentax K-5 5 12-13-2012 04:42 AM



All times are GMT -7. The time now is 03:28 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top