Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-03-2014, 05:32 AM   #61
Pentaxian




Join Date: Aug 2013
Location: Iloilo City
Photos: Gallery
Posts: 1,107
Does anyone know which serial numbers are the new batches with the new hardware fix?
Are there reports of this mirror flap on the prestige edition?

12-03-2014, 07:16 AM   #62
Forum Member




Join Date: Feb 2008
Location: Alberta, Canada
Photos: Gallery
Posts: 85
Interesting thread - I have a K3 in the cart from B&H photo and was totally unaware of this issue until I came over to this board to look at an old thread I did years ago and decided to peruse the K3 forum. This is something I never experienced with my K10D, in extreme cold (-30 & colder) or in hot weather.

I'm assuming any K3's purchased now would be well past the serial number range where the problems seem most persistent.
12-03-2014, 08:07 AM   #63
Senior Member




Join Date: Jan 2014
Location: Texas
Posts: 258
I haven't had any freezes since the firmware upgrade!
12-03-2014, 08:12 AM   #64
Site Supporter
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,503
QuoteOriginally posted by totsmuyco Quote
Does anyone know which serial numbers are the new batches with the new hardware fix?
Are there reports of this mirror flap on the prestige edition?
Pentax serial numbers are not strictly sequential. A better indication would be the date of manufacture from the exif.


Steve

---------- Post added 12-03-14 at 07:13 AM ----------

QuoteOriginally posted by Glen_S Quote
I'm assuming any K3's purchased now would be well past the serial number range where the problems seem most persistent.
That would be a reasonable assumption. New reports of runaway mirror issues have dwindled to almost zero.


Steve

12-03-2014, 08:23 AM   #65
Senior Member




Join Date: Jan 2014
Location: Texas
Posts: 258
What happened to our advocate, DRabbit? She is strangely quite now that the problem has gone away. Sometimes you only hear from some people when things are going badly. How about an acknowledgement DRabbit that the problem is solved?!
12-03-2014, 10:13 AM   #66
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,330
QuoteOriginally posted by gosman Quote
What happened to our advocate, DRabbit? She is strangely quite now that the problem has gone away. Sometimes you only hear from some people when things are going badly. How about an acknowledgement DRabbit that the problem is solved?!
She sold her K-3´s and bought K-5II´s instead...
12-03-2014, 03:29 PM   #67
Site Supporter
Site Supporter




Join Date: Mar 2008
Location: Prince George, BC
Photos: Gallery
Posts: 2,343
Actually, the problem is not solved with firmware v1.11 on the K-3. It just activates a reset when the flutter condition is detected. For Amy who shoots time lapse, this is not a fix at all since she needs a constant stream of uninterrupted stills. I shoot a lot of astro and run into this just about every session. However, with me, I can instantly tell when it happens. Instead of the usual single press of the IR remote to activate MLU,after a frame has been exposed, I can hear that the mirror has locked up right away after the previous exposure. So when I press the remote, the shutter opens on the first press instead of the second press. Usually I don't even lose the frame. So the fix works in that I never encounter the flutter condition anymore, but there is still the chance of a missed frame.

Jack
12-04-2014, 12:17 PM   #68
Inactive Account




Join Date: Aug 2014
Posts: 76
These are the REPORTED serial Numbers

QuoteOriginally posted by totsmuyco Quote
Does anyone know which serial numbers are the new batches with the new hardware fix?
Are there reports of this mirror flap on the prestige edition?
Members Reporting the Issue

So far, in the various threads about this issue, between me and Jhmos, we've counted a total of 152 people who have reported having the problem at least once. This is a complete list. The names with stars are the ones that have also reported here in this thread (the ones without stars have reported in one of the other threads linked above). I will update the list as more people reply here.

So far, the issue seems to have been reported in serial numbers ranging anywhere from:
482XXXX to 493XXXX (black bodies)
and
2573XXX to 2578XXX (silver bodies)


Read more at: https://www.pentaxforums.com/forums/172-pentax-k-3/254464-k3-crazy-mirror-sic...#ixzz3KxTaXBcr

12-05-2014, 05:29 AM   #69
Pentaxian




Join Date: Aug 2013
Location: Iloilo City
Photos: Gallery
Posts: 1,107
Thanks
12-05-2014, 12:16 PM   #70
Site Supporter
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,056
Prestige body was introduced later, any indication from them?
12-05-2014, 06:52 PM   #71
Senior Member




Join Date: Nov 2012
Photos: Gallery
Posts: 173
I got my k3 from service because of power on issue. I haven't had any issues so far. I wanted to participate on the monthly but have been way too busy. I got it back mid November.
12-06-2014, 06:55 AM   #72
Inactive Account




Join Date: Aug 2014
Posts: 76
Prestige Question

QuoteOriginally posted by beachgardener Quote
Prestige body was introduced later, any indication from them?
Best advice I can offer is to "Google" it and see if you find any reports
12-06-2014, 01:07 PM   #73
Site Supporter
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,056
yeah no worries, just wondering any forum people with the prestige had encountered it, haven't heard of any yet.
12-07-2014, 02:05 AM   #74
Forum Member




Join Date: Dec 2008
Location: Seattle, WA
Posts: 64
so bad seeing so many ppl encoutering this issue... really holding me back from getting one
12-07-2014, 02:08 AM   #75
Site Supporter
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,056
QuoteOriginally posted by ruoyun.huang Quote
so bad seeing so many ppl encoutering this issue... really holding me back from getting one
from what i can see there are not many reports now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, dealers, dslr, evaluation, flutter, grip, issue, k-3, k-3 mirror flutter, k3, michael, mirror, mode, pentax, pentax k-3, range, reports, ricoh, steve, stock, suspect, track
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 1.03 update not on Ricoh site gosman Pentax K-3 4 03-07-2014 02:08 PM
Ricoh promoting the Pentax K-3 bxf Pentax K-3 78 10-29-2013 06:02 AM
RICOH Promo Video for the K-3 Steve.Ledger Pentax K-3 17 10-10-2013 02:02 PM
Pentax Ricoh's reply to your comments at our interview Adam Pentax News and Rumors 302 09-26-2012 08:53 AM
Reply from Ricoh about suggestions. David&karen Pentax K-5 7 11-10-2011 03:46 AM



All times are GMT -7. The time now is 05:07 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top