Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-07-2014, 11:01 AM   #76
Pentaxian
MJSfoto1956's Avatar

Join Date: Dec 2013
Location: Boston
Posts: 1,287
I'm beginning to believe that it might have something to do with Pentax batteries. Since moving my batteries around I have not had the problem. In order to keep better data, I've labeled my Pentax-branded batteries #1, #2, and #3 so that I can keep track of which combinations are problematic (or not). Might take a while to report back but I have some anecdotal evidence that there is something to this.

YMMV

Michael

12-07-2014, 02:04 PM   #77
Senior Member




Join Date: Nov 2012
Photos: Gallery
Posts: 159
QuoteOriginally posted by MJSfoto1956 Quote
I'm beginning to believe that it might have something to do with Pentax batteries. Since moving my batteries around I have not had the problem. In order to keep better data, I've labeled my Pentax-branded batteries #1, #2, and #3 so that I can keep track of which combinations are problematic (or not). Might take a while to report back but I have some anecdotal evidence that there is something to this.

YMMV

Michael
I had 4 Pentax batteries and thought the same so I switched to an off brand and it happened there as well. Someone mentioned it was the way the K3 circuitry wasn't getting the correct power and I think that is more the case than the battery. The batteries are pretty consistently made nowadays and the voltage should be adequate if it can power the K3 as long as they do. I had the issue go away with the firmware update 1.11, albeit, a short time I had to send it in for the no-power-on issue. I sent it in for service and have yet to have the problem. I feel like it's a problem of the past.
12-07-2014, 04:11 PM   #78
Forum Member




Join Date: Aug 2014
Posts: 76
Read "To buy or not to Buy" on Pentax forums

QuoteOriginally posted by ruoyun.huang Quote
so bad seeing so many ppl encoutering this issue... really holding me back from getting one
Apparently you haven't read my detailed experience in response to that question on the Pentax Forum thread "To Buy or not To Buy"
I don't think people would make "a mountain out of a molehill" if they read that first.
I can tell you this, You couldn't PRY my K3 out of my hands!!!!!!!!!

Last edited by Pentaxaholic; 12-07-2014 at 04:12 PM. Reason: error
12-07-2014, 05:15 PM   #79
Pentaxian
MJSfoto1956's Avatar

Join Date: Dec 2013
Location: Boston
Posts: 1,287
QuoteOriginally posted by Pentaxaholic Quote
I can tell you this, You couldn't PRY my K3 out of my hands!!!!!!!!!
+1 -- one of the finest cameras I have ever owned (and I am one of those that has had an occasional hiccup wrt the flutter issue)

YMMV

Michael

12-08-2014, 05:30 AM   #80
Forum Member




Join Date: Aug 2014
Posts: 76
QuoteOriginally posted by WestCoastGuy Quote
Victoria, BC.

I looked into buying a K-3 yesterday, but found all stock here in the suspect serial # range. A couple of the dealers were aware of the issue, having had returned units demonstrating the mirror flop issue. The dealers were all contacting the Ricoh rep to ask about this issue. I have left my name as one holding off purchasing until the issue is resolved.

Hopefully, more info will soon be forthcoming up here in Canada.
Try calling the online dealers and ask them if they have any in stock that are not bearers of the suspect serial number. I'm sure they do. You can have it shipped to your door!

Even if you happen to get one, like I did with my first, they were happy to replace it. I suggest you read my response on Pentax forum to "To buy or not to buy" for details about return policies and helpful information. My second K3 has been problem free and it is not in the serial number range of suspect cameras.

---------- Post added 12-08-14 at 06:33 AM ----------

QuoteOriginally posted by PiDicus Rex Quote
Doing my due diligence reading before purchase,...

Question to all K3 owners who experienced this issue - Has it only been while shooting stills, or has this occurred when moving in to or from Video mode?
I only had it happen during still shots. (and right out of the box, so it was sent in for exchange)
I LOVE IT!

---------- Post added 12-08-14 at 06:38 AM ----------

QuoteOriginally posted by MJSfoto1956 Quote
I'm beginning to believe that it might have something to do with Pentax batteries. Since moving my batteries around I have not had the problem. In order to keep better data, I've labeled my Pentax-branded batteries #1, #2, and #3 so that I can keep track of which combinations are problematic (or not). Might take a while to report back but I have some anecdotal evidence that there is something to this.

YMMV

Michael
Thanks for going through the work to track that suspicion! I have read elsewhere that the fresh batteries (first full charge) trigger the issue. My fiance has an Alpha 77 (Sony) and his did the rapid firing (it's mirror-less) on the first battery charge,. Battery had to be removed and replaced to get it to stop,. Since he wore that battery down, it hasn't re-occurred,

---------- Post added 12-08-14 at 06:39 AM ----------

QuoteOriginally posted by mjsfoto1956 Quote
+1 -- one of the finest cameras i have ever owned (and i am one of those that has had an occasional hiccup wrt the flutter issue)

ymmv

michael
amen to that!!
I've owned Minolta, Sony., Olympus, Pentax K-01 and K3 dslr's and K3 is TOPS! I still have my 2 Oly's and K-01, they're nothing to sneeze at either!

Last edited by Pentaxaholic; 12-08-2014 at 05:42 AM. Reason: added
12-14-2014, 10:19 PM   #81
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
Woe is me.

Finally put my K-3 in for repair (I hope) before my warranty runs out (only had one year). So back to my old K100D and goodbuy to my Sigma 35mm Art, Sigma 70-200 and Pentax 18-135 till I get the K-3 back again (unless I manual focus I suppose). Not sure I have seen posts from people getting the fix done in Australia, hope C.R.Kennedy get it right.

John.
12-15-2014, 09:12 PM   #82
New Member




Join Date: Sep 2014
Location: Brownstown Twp., Mi
Posts: 6
QuoteOriginally posted by MJSfoto1956 Quote
I'm beginning to believe that it might have something to do with Pentax batteries. Since moving my batteries around I have not had the problem. In order to keep better data, I've labeled my Pentax-branded batteries #1, #2, and #3 so that I can keep track of which combinations are problematic (or not). Might take a while to report back but I have some anecdotal evidence that there is something to this.

YMMV

Michael
A couple of days ago I experienced the mirror flutter as well. It happened just as I took a shot and the battery had drained to the point of the K3 shutting itself off. Probably fluttered about 10 times before the unit completely shut off from battery drainage.


That day I had a Wasabi battery in the camera, so it doesn't seem to be related to the name on the battery.


My K3 came with the latest software version - I took delivery mid-September.
12-15-2014, 11:30 PM   #83
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
QuoteOriginally posted by Rligeski Quote
A couple of days ago I experienced the mirror flutter as well. It happened just as I took a shot and the battery had drained to the point of the K3 shutting itself off. Probably fluttered about 10 times before the unit completely shut off from battery drainage.


That day I had a Wasabi battery in the camera, so it doesn't seem to be related to the name on the battery.


My K3 came with the latest software version - I took delivery mid-September.
You can get the current battery voltage in the EXIF data for each photo to check what the battery condition was before fault (assuming you took more than one photo before the fault, since you may lose the last photo.
The times it's happened to me, it didn't seem to be related to battery condition.
I did some tests a while back looking at the current drawn when taking photos and observed occasional (and apparently random) high current spikes. So I think the fault occurs when there is an extreme enough current spike that brings the voltage down too far.
What the 'fix' does exactly I don't know, just hope it works.

John.

12-17-2014, 06:15 PM   #84
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
Just got a phone call from C.R.Kennedy (the Australian service centre). The guy I talked to knew nothing about any fix other than v1.11 firmware. After I told him that v1.11 didn't really fix the problem he said he would talk to the technicians about it. So now I am not so sure about the veracity of reports of a real fix for this problem.

John.
12-17-2014, 07:10 PM   #85
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,036
Going back a year or so, reports on this forum from customers of CHRIS a mob who serviced Pentax back then, said that the real fix was a service centre firmware update to the mirror box mechanism (or some such thing like that). I would hope that the new versions of K-3 have that fix or a new mirror box in place. Not many new reports of the problem for ages now. Sales at CRK may not be aware, but the technicians should have a direct line to Pentax for information on the problem or the fix.
I did email CRK to find out what serial number K-3's they had (they did not reply), it seems that after a certain serial number, or more precisely date of manufacture, it seems like less reports of a problem.
12-17-2014, 09:13 PM   #86
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
QuoteOriginally posted by beachgardener Quote
Going back a year or so, reports on this forum from customers of CHRIS a mob who serviced Pentax back then, said that the real fix was a service centre firmware update to the mirror box mechanism (or some such thing like that). I would hope that the new versions of K-3 have that fix or a new mirror box in place. Not many new reports of the problem for ages now. Sales at CRK may not be aware, but the technicians should have a direct line to Pentax for information on the problem or the fix.
I did email CRK to find out what serial number K-3's they had (they did not reply), it seems that after a certain serial number, or more precisely date of manufacture, it seems like less reports of a problem.
I'll have to look back and find those old posts. I hope your right about the techs and there is an real fix.

John.
12-17-2014, 11:52 PM   #87
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 2,036
In my view Pentax should come out and explain exactly what it is and what they are doing/have done about it, this sort of honesty would come across really well with the Pentax fans and set a precedent for the other companies to be honest with their customers.
12-17-2014, 11:55 PM   #88
New Member




Join Date: May 2014
Location: Victoria, BC
Posts: 18
One of the larger local dealers here in Victoria, BC Canada knew of the issue when I talked to him last weekend. He said "...all units of that serial # series had been shipped back...". I checked that the unit on display was outside the range listed in the beginning on this thread.
12-18-2014, 12:15 AM   #89
Pentaxian




Join Date: Aug 2013
Photos: Gallery
Posts: 1,038
It's funny that here in the Philippines the official dealer CameraHaus Cebu branch hasn't heard of this defect. I don't know if those sold here in Asia are free of such problem. It would be good to hear some feedback from those who bought their units here if there are any with this problem.
12-21-2014, 02:30 AM   #90
New Member




Join Date: Dec 2013
Location: United Kingdom
Photos: Albums
Posts: 7
Hi,
I am in the UK and I have just bought a New K-3 silver edition + Battery grip. The serial number is 2576xxx.
I have just checked the firmware and it is v1.00 do I have to install every firmware individually or do I just install the latest v1.11.
For the record I have owned a K-500,and K-5 and never had an issue with the mirrow flutter, fingers crossed with the K-3.
Because it is a 2576xxx serial number does it mean it is an old stock item particularly as it only has firmware v1.00 installed or is that normal.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, dealers, dslr, evaluation, flutter, grip, issue, k-3, k-3 mirror flutter, k3, michael, mirror, mode, pentax, pentax k-3, range, reports, ricoh, steve, stock, suspect, track
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 1.03 update not on Ricoh site gosman Pentax K-3 4 03-07-2014 02:08 PM
Ricoh promoting the Pentax K-3 bxf Pentax K-3 78 10-29-2013 06:02 AM
RICOH Promo Video for the K-3 Steve.Ledger Pentax K-3 17 10-10-2013 02:02 PM
Pentax Ricoh's reply to your comments at our interview Adam Pentax News and Rumors 302 09-26-2012 08:53 AM
Reply from Ricoh about suggestions. David&karen Pentax K-5 7 11-10-2011 03:46 AM



All times are GMT -7. The time now is 02:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top