Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-15-2014, 12:00 AM   #16
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,177
QuoteOriginally posted by OregonJim Quote
Also, any warranty is likely invalid.
No, that's something Pentax does differently - everyone gets a year of international warranty. Different regions then get other durations (2 years in the EU for example).

06-15-2014, 08:40 AM   #17
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,234
QuoteOriginally posted by felixkh Quote
Exactly the same as he is showing. Looks like region specific.
There you have it Sylvester, your camera is correct for where you purchased it from, no fault of Ricoh's.
06-16-2014, 02:32 AM   #18
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 930
QuoteOriginally posted by Giklab Quote
No, that's something Pentax does differently - everyone gets a year of international warranty. Different regions then get other durations (2 years in the EU for example).
In Singapore, the distributor DOES NOT recognise any international warranty. The nearest neighbour is Malaysia who recognises the international warranty and that is in Kuala Lumpur a 4 hour drive up north from Singapore.
09-09-2014, 07:24 PM   #19
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 53
Same here, but with standard version, I bought from amazon.com, I spected for spanish, but only two languages: english and chinese.

09-10-2014, 12:48 AM   #20
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,109
I purchased mine in Australia and have the same leather strap and the same 4 language choice
great camera!
09-10-2014, 01:36 AM   #21
Forum Member




Join Date: Feb 2009
Location: Örnsköldsvik, Sweden
Posts: 61
The Swedish translation is so crappy, so i use English anyway. Don´t know about Danish, but i wouldn´t expect it to be any better.
So if you ask me, it´s not a big deal to only have English menus.
09-10-2014, 01:52 AM   #22
Site Supporter
savoche's Avatar

Join Date: Jun 2011
Location: Lowlands of Norway
Posts: 8,477
QuoteOriginally posted by Lage Quote
The Swedish translation is so crappy, so i use English anyway. Don´t know about Danish, but i wouldn´t expect it to be any better.
So if you ask me, it´s not a big deal to only have English menus.
I have never looked at the Norwegian translation. Have always used English. Makes it much easier to discuss menu options on international forums
09-10-2014, 02:46 AM   #23
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,322
QuoteOriginally posted by Lage Quote
The Swedish translation is so crappy, so i use English anyway. Don´t know about Danish, but i wouldn´t expect it to be any better.
So if you ask me, it´s not a big deal to only have English menus.
I especially enjoy the translation of Firmware. No wonder I couldnt find it at first...

Also there are some errors in the translation. For instance; Small, medium and Large focus areas have the description mixed up...

09-10-2014, 02:47 AM   #24
Veteran Member




Join Date: Jul 2010
Location: Lyngby, Copenhagen
Photos: Albums
Posts: 742
QuoteOriginally posted by Lage Quote
The Swedish translation is so crappy, so i use English anyway. Don´t know about Danish, but i wouldn´t expect it to be any better.
So if you ask me, it´s not a big deal to only have English menus.
The danish translation is fine, IMHO.
Regards,
--Anders.
09-11-2014, 11:13 AM   #25
Loyal Site Supporter
Crooski's Avatar

Join Date: Feb 2013
Location: Rozenburg , Zuid-Holland
Photos: Gallery
Posts: 1,494
I bought a K01 via Ebay in Japan
There were only two languages ​​available.English and Japanese.

Even after a firmware update, only two languages ​​available

Use plain English went very fast

Greetings Crooski
09-16-2014, 08:20 AM - 1 Like   #26
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,322
I opened my K-3 in Debug Mode. Changed the Region Setting from 01 to 02 and got only English and three asian languages. Set it back to 01 and I now got the possibility to set Swedish again.

Do almost as stated below: Enter Debug Mode, DO NOT REMOVE THE FILES as stated below. Turn camera off and On again.
Choose Region 01 and press OK, open the menu and Wrench 1 and check the languages avalible. Choose your language.

Turn the camera off, remove the files. Turn on and go to "secret menu" where you can disable the Debug Mode.

Turn off and on again. The Debug Mode should have been turned off and you will not see the text "Debug Mode" on the LCD (The LCD needs to be turned on to show the text)

and you will not see the secret menu anymore.

I have tested setting Region 00, 01, 02 and 03.







The K-3 Debug Mode

This is how you enter:

Create 2 files in the root of SD card (Make sure your computer shows the file endings, i.e .txt, .PEF, . JPG etc)

00077760.502
DEVELOP.MOD

Open and add the text [OPEN_DEBUG_MENU] to the first file.

Insert the SD card in slot 1 and turn on the camera without closing the card door.

Enable Debug Mode and press OK. You can now remove the files.

In the Menus, before the C1-menu, you now will find a hidden menu.

DISCLAMER: YOU DO THIS AT YOUR OWN RISK SO READ ABOUT THIS ON THE INTERNET.
JUST ENTERING THE DEBUG MODE SEEMS HARMLESS THIS FAR AND I HAVE USED IT MANY TIMES TO ADJUST THE AF ON MY OLDER CAMERAS THAT DID NOT HAVE THE FINE TUNING THE K-3 HAS.

THERE ARE MANY SETTINGS I HAVE NO IDEA WHAT THEY DO...

Last edited by Tjompen1968; 09-16-2014 at 08:28 AM. Reason: Added warning
09-16-2014, 01:54 PM   #27
Forum Member




Join Date: Feb 2014
Photos: Gallery | Albums
Posts: 53
Great ¡ i changed region from 03 to 01, now I can change to spanish language
09-17-2014, 12:27 AM   #28
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,322
QuoteOriginally posted by kickman Quote
Great ¡ i changed region from 03 to 01, now I can change to spanish language
Nice to hear that it worked as expected.
10-08-2014, 08:16 PM   #29
New Member




Join Date: Aug 2013
Posts: 11
Thanks for sharing! it works with my US version of K-3.. really appreciated that.

Last edited by balapapapa; 10-13-2014 at 09:33 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, edition, k-3, k3, language, language settings, pentax, pentax k-3, service, silver
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recommended Settings on K-50 TzalamChadash Pentax K-30 & K-50 5 04-02-2014 09:04 AM
8mm Rokinon settings on K-01? PBandJ Troubleshooting and Beginner Help 8 05-29-2013 11:06 PM
International entrepreneurs in international waters Winder General Talk 7 03-17-2013 08:09 PM
Question Language Settings Kozlok Site Suggestions and Help 2 10-06-2012 05:09 PM
Language Settings for the K-01 legacyb4 Pentax K-01 5 06-05-2012 05:37 PM



All times are GMT -7. The time now is 07:13 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top