Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-17-2014, 10:57 AM   #1
Forum Member




Join Date: Apr 2011
Location: Southern UK
Posts: 93
K3 Crazy Mirror Sickness (Mirror Flapping Lockup) on firmware 1.10

I didn't see any other reports and thought important enough to start a new thread. Sorry folks 1.10 is not a fix for the mirror flap lockup, not completely anyhow, it happened to me today for the first time, and I already upgraded from 1.03 to 1.10, just double checked my firmware.

Mode : P
Battery: Pentax original fully charged, no battery grip
SD cards : Pentax Flu and Integral Ultima Pro 64GB Class 10

Note : battery had been probably 2/3 and I had topped it up to full last night knowing I was doing some shooting today.

07-17-2014, 11:55 AM   #2
Inactive Account




Join Date: Jul 2014
Photos: Albums
Posts: 1
Yes, happend to me to, 3 times in a day, I called the shop from where I bought it and they told me to send it back, a new one is on it's way, might get it tomorow or on monday. Although I have low hopes it won't have the disiese to. Probably the same batch or some such.
07-17-2014, 01:37 PM - 1 Like   #3
Site Supporter
tabl10s's Avatar

Join Date: Jun 2011
Location: Sacramento(formerly from B'Ham, England).
Posts: 1,394
Well, ain't that a beeeeech,
07-17-2014, 01:45 PM   #4
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,720
QuoteOriginally posted by SteveUK Quote
I had topped it up to full last night
Might be notable. 'Hot' battery.

Still has never happened to me, after 8 months or so of varied usage.
I will probably get my first flap 1 week after my 12 month warranty period expires, I bet.

07-17-2014, 02:51 PM   #5
Forum Member




Join Date: Apr 2011
Location: Southern UK
Posts: 93
Original Poster
QuoteOriginally posted by rawr Quote
Might be notable. 'Hot' battery....
Nope - had been off charge for >8 hrs when it occurred so certainly was not hot at the time or in heavy use at the point it occurred. I just mention as I normally run batteries to flat and just swap a spare then, I don't generally top up battery charge.
07-17-2014, 03:19 PM   #6
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,720
QuoteOriginally posted by SteveUK Quote
Nope -
Oh well. In relation to K-3 flapping, I just keep recalling all the weirdness that went on with the K200D, K-x, K-5 with battery related issues, AA and otherwise.

One day Pentax should do a DSLR with a windup dynamo or something, with a hand-crank. That would likely solve all these problems.
07-17-2014, 03:27 PM   #7
Site Supporter
tabl10s's Avatar

Join Date: Jun 2011
Location: Sacramento(formerly from B'Ham, England).
Posts: 1,394
Never had a problem with the K-5 or even my main LX...except the sticky mirror and both of my winders broke for whatever the same reason and re-broke again after a repair bill of $110 each.
07-17-2014, 07:22 PM   #8
Site Supporter




Join Date: Nov 2010
Location: Long Island, NY
Photos: Gallery
Posts: 593
Sorry to hear it's happening with the latest firmware

Please, if you can, add your reports to the original reporting thread just so we can keep all the reports in one place. I did link to this thread in the updates, and I added your names to the list there, but it would be good for you to add your info to that thread, if you could.

I was considering buying a K3 again just to test, but now I may just hold off some more.

07-17-2014, 07:57 PM   #9
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,088
I was hoping that the firmware would take care of business.

Considering buying a K3 is now out of the question for me after having been reading the two related threads regarding the "crazy-mirror-sickness-mirror-flapping-lockup".

JP
07-17-2014, 11:40 PM   #10
Forum Member




Join Date: Apr 2011
Location: Southern UK
Posts: 93
Original Poster
QuoteOriginally posted by DRabbit Quote
Sorry to hear it's happening with the latest firmware

Please, if you can, add your reports to the original reporting thread just so we can keep all the reports in one place. I did link to this thread in the updates, and I added your names to the list there, but it would be good for you to add your info to that thread, if you could.

I was considering buying a K3 again just to test, but now I may just hold off some more.
I'm fine if a mod now wants to close off this thread now, it was important to start it to make the point that 1.10 is not the fix that we hoped.
07-18-2014, 06:26 AM   #11
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,566
QuoteOriginally posted by DRabbit Quote
Sorry to hear it's happening with the latest firmware

Please, if you can, add your reports to the original reporting thread just so we can keep all the reports in one place. I did link to this thread in the updates, and I added your names to the list there, but it would be good for you to add your info to that thread, if you could.

I was considering buying a K3 again just to test, but now I may just hold off some more.
Sorry to hear that OP has the problem but I agree with Amy that there does not need to be a new thread. These reports should go to the original thread so we do not have bunch of threads on essentially the same topic. Thanks for giving us the update and thanks to Amy for all her work on this frustrating issue. Fingers crossed but I have not had the problem nearing 10,000 actuations. Must be infuriating for those who do have it.
07-18-2014, 11:53 PM   #12
Inactive Account




Join Date: Jul 2014
Location: California
Posts: 5
I've only had my K3 for a few weeks, but haven't come across this problem so far. I did update the firmware when I got it, July 1st, v1.03. After reading these posts I went to Pentax Imaging to get the 1.10 update and it's not there. Still only shows v1.03 as the newest update. I guess they realized the problem can't be fixed with firmware or they've gone back to the drawing board with it. Could be they'll have a big recall on the product which would be extremely inconvenient for us all, but I sure would like to get some feedback from Ricoh on the issue.
07-19-2014, 12:50 AM   #13
Forum Member




Join Date: Apr 2011
Location: Southern UK
Posts: 93
Original Poster
Latest K-3 Firmware Update : Software Downloads | RICOH IMAGING

I can still see 1.10 here.
07-22-2014, 08:08 PM   #14
Inactive Account




Join Date: Jul 2014
Location: California
Posts: 5
QuoteOriginally posted by SteveUK Quote
Thanks for the assist Steve, must have still had the link to the previous version.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, dslr, firmware, k-3, k3, k3 crazy mirror, lockup, mirror, mirror sickness mirror, pentax, pentax k-3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 Crazy Mirror Sickness (Mirror Flapping Lockup) - Report Yours Here! DRabbit Pentax K-3 928 01-17-2017 04:44 PM
K3 Firmware 1.03 and mirror flap Little Ray Pentax K-3 38 05-20-2014 01:34 AM
Mirror lockup O'Brien 860 Pentax K-30 & K-50 23 07-14-2013 05:16 PM
mirror lockup Andrew Crouch Pentax K-5 5 12-13-2012 04:42 AM
Question RE: Mirror Lockup on Asahi K2 geekette Pentax Film SLR Discussion 10 04-16-2011 10:36 PM



All times are GMT -7. The time now is 06:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top