Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-18-2014, 05:14 PM   #1
Site Supporter
pentaxmz's Avatar

Join Date: Dec 2008
Location: Seattle
Posts: 659
Pentax Flucard - embarassing piece of junk!

Hello all,

I received the Flucard about five months ago and 'played' with it for about one hour. Saying that I was underwhelmed would be an understatement. As I recall... I was not happy that:
- With the constant spontaneous disconnections
- Very slow response (at times) to often to make this a usable tool
(no, absolutely no WiFi interference during testing),
- I was also very annoyed that the shamefully primitive web-only interface
- Annoyed that using the product meant giving up your network interface / Internet connection because it didn't include bridging cabability

I meant to post a review about it but other projects got in the way and I just plain put it aside, until today.

I have a paying gig coming up next week and I thought it would be cool to 'tether' to my iPad.

So I plug the toy back into my SD2 slot, power up the camera and NOW I see an error, "Memory Card Error". If I go to the menu selection, "Wireless Memory Card" I see the error message, "No wireless memory card inserted in SD2..."



Did I just waste over a $100? Has anyone else encountered this problem?

Thanks all,
Shawn

P.S. Sorry for my long absence! But I do still love my K3 (best camera I've even owned - and I had or have Canons/Nikons).

07-18-2014, 05:21 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,850
Insert the card into SD1 and format it. That should fix the error. Happened to me too...

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-18-2014, 05:21 PM   #3
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,800
QuoteOriginally posted by pentaxmz Quote
I received the Flucard
Which model? There are several - the 'fancy' official Pentax one (16GB O-FC1), and the 'normal' EyeFi clone Flucards. I've tried the latter, and was also underwhelmed.
07-18-2014, 05:36 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,295
QuoteOriginally posted by pentaxmz Quote
- Annoyed that using the product meant giving up your network interface / Internet connection because it didn't include bridging cabability
Dang, I like a good rant...they are so entertaining and informative!!!


Steve

(...but mostly entertaining...)

07-18-2014, 05:40 PM   #5
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,329
I have both the standard FLUcard and the one tailored for the K-3. It's hard to know what any individual's expectations are from a piece of technology whose strengths and weaknesses have been fairly well documented, other than what they've gleaned from others' experiences. While I couldn't recommend the standard FLUcard as value for money, because of its slow transfer rates, I imagine there may be situations where it is useful, and it did come with my K-3, so value for money wasn't a consideration, in my case.

As for the Pentax version for the K-3, I've found its real usefulness for me has been in setting up photos of close subjects that are in awkward positions, and it doesn't take much imagination to think of other situations (like candid photos) where it might also be useful. Notwithstanding that, it isn't anywhere near a universal replacement for the optical viewfinder or Live View. I paid a lot more for a refconverter, and I've probably used it more, so to me it's good value for money.

I wouldn't dream of using it for paid work until I'd had time to get used to its limitations, let alone learned to appreciate its strengths.
07-18-2014, 06:02 PM   #6
Forum Member




Join Date: Jan 2014
Location: Northern NJ
Photos: Gallery | Albums
Posts: 50
It's been a waste of $$ for me so far too. Temperamental, complicated, etc.
07-18-2014, 06:07 PM   #7
Site Supporter
tabl10s's Avatar

Join Date: Jun 2011
Location: Sacramento(formerly from B'Ham, England).
Posts: 1,401
I guess it's back to wishing for articulated screen.
07-18-2014, 09:11 PM   #8
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,291
I got a freebie FLU card with my K-50, not the PENTAX Flu though. Never taken it out of the packing, I had an EyeFi card once before which caused more grey hairs and strange looks from neighbors than anything computer related has in my life so far. I suppose I should offer it for sale, I'll never use it.

WiFi should be built-in to a 2013/2014 flagship DLSR body, good grief - why isn't it??

07-18-2014, 09:32 PM - 1 Like   #9
Loyal Site Supporter
G and T's Avatar

Join Date: Aug 2011
Location: Langwarrin Australia
Photos: Gallery
Posts: 350
There's a reason its called a Flucard, everytime I put mine in my in my K3 it gets the Flu.
Glenn
07-19-2014, 01:51 AM   #10
Veteran Member
awaldram's Avatar

Join Date: May 2008
Location: Hampshire
Photos: Gallery
Posts: 720
QuoteOriginally posted by pentaxmz Quote
Hello all,

I received the Flucard about five months ago and 'played' with it for about one hour. Saying that I was underwhelmed would be an understatement. As I recall... I was not happy that:
- With the constant spontaneous disconnections
- Very slow response (at times) to often to make this a usable tool
(no, absolutely no WiFi interference during testing),
- I was also very annoyed that the shamefully primitive web-only interface
- Annoyed that using the product meant giving up your network interface / Internet connection because it didn't include bridging cabability

I meant to post a review about it but other projects got in the way and I just plain put it aside, until today.

I have a paying gig coming up next week and I thought it would be cool to 'tether' to my iPad.

So I plug the toy back into my SD2 slot, power up the camera and NOW I see an error, "Memory Card Error". If I go to the menu selection, "Wireless Memory Card" I see the error message, "No wireless memory card inserted in SD2..."



Did I just waste over a $100? Has anyone else encountered this problem?

Thanks all,
Shawn

P.S. Sorry for my long absence! But I do still love my K3 (best camera I've even owned - and I had or have Canons/Nikons).
Well it does everything is said it would on the tin and more.
Its limits a technology related so required a decent understanding of WiFi and congestion it is a full blown computer when alls said and done running Linux and a web server as such it very good value for money.

There are many apps from flu that will happily work with th OFc-1 so your accusation of 'web only' is baseless.

Pentax/Trek could put some effort into documenting app use so those who want it on a plate don't have to put any effort in but its difficult to see how the product could be any better within its technology constraints except enabling client mode.
07-19-2014, 02:21 AM   #11
Site Supporter
pentaxmz's Avatar

Join Date: Dec 2008
Location: Seattle
Posts: 659
Original Poster
QuoteOriginally posted by Adam Quote
Insert the card into SD1 and format it. That should fix the error. Happened to me too...
Thank you for your reply Adam, I just tried that and I am really disheartened to find that it didn't work. Selecting format immediately displays, "Memory Card Error".

FYI, I no longer hear the faint beep sound of the Flucard initializing. I guess I got no more than an hour of use out of this card.
07-19-2014, 02:25 AM   #12
Veteran Member
awaldram's Avatar

Join Date: May 2008
Location: Hampshire
Photos: Gallery
Posts: 720
QuoteOriginally posted by pentaxmz Quote
FYI, I no longer hear the faint beep sound of the Flucard initializing. I guess I got no more than an hour of use out of this card.
Sounds like it isn't booting anymore time to claim warranty repair.
The system boots and then enables the SD connection to the memmory area.

Probably faulty from new.

Just as well you didn't write a review based on an hours experience of a faulty card !!
07-19-2014, 02:40 AM - 1 Like   #13
Site Supporter
pentaxmz's Avatar

Join Date: Dec 2008
Location: Seattle
Posts: 659
Original Poster
QuoteOriginally posted by rawr Quote
Which model? There are several - the 'fancy' official Pentax one (16GB O-FC1), and the 'normal' EyeFi clone Flucards. I've tried the latter, and was also underwhelmed.
I have the long awaited 'fancy' official Pentax one.

Name:  Flucard_IMG_4293.JPG
Views: 1052
Size:  74.3 KB

---------- Post added 07-19-2014 at 02:44 AM ----------

QuoteOriginally posted by stevebrot Quote
Dang, I like a good rant...they are so entertaining and informative!!!


Steve

(...but mostly entertaining...)
Well, I suspect this forum would not exist if Pentax cameras were as underwhelming and unreliable as this Flucard.

I wouldn't consider my post a rant, rather, it is a call for help... or at least an inquiry if others have experienced similar troubles.

A rant, IMO is more like, "Why I won't buy a K3" or "The K3 is stupid because ...."



---------- Post added 07-19-2014 at 02:52 AM ----------

QuoteOriginally posted by tabl10s Quote
I guess it's back to wishing for articulated screen.
Not even in the same league of posts. Articulated screen would be nice, sure! But Pentax got us excited about the Flucard but made a huge mistake by allowing their name to be attached to a poorly implemented, temperamental, product.

BTW, not requiring software (or dedicated mobile app) and working within a browser is NOT a feature, IMO... it is a development shortcut.

Anyway, for me... unless I can find a way to get a refund, I'm out a $120.00 for a 100% non-working product. This is a worse let-down than my old *ist camera... I mean, at least it worked.

---------- Post added 07-19-2014 at 02:59 AM ----------

QuoteOriginally posted by awaldram Quote
There are many apps from flu that will happily work with th OFc-1 so your accusation of 'web only' is baseless.
Besides the rather poor effort of Trek2000, I am curious... please name one or more decent apps that work with the Flucard.

When I said, "web only", I was mainly referring to Pentax/Ricoh's effort.

Anyhow, I'll refrain from criticizing the product any further because frankly, I can't even remember how good or bad the product was... it's dead for me.
07-19-2014, 03:09 AM   #14
Veteran Member
awaldram's Avatar

Join Date: May 2008
Location: Hampshire
Photos: Gallery
Posts: 720
QuoteOriginally posted by pentaxmz Quote
Besides the rather poor effort of Trek2000, I am curious... please name one or more decent apps that work with the Flucard.
https://www.pentaxforums.com/forums/172-pentax-k-3/253672-flucard-impressions...ml#post2736887
07-19-2014, 03:15 AM   #15
Site Supporter
pentaxmz's Avatar

Join Date: Dec 2008
Location: Seattle
Posts: 659
Original Poster
UPDATE

I cleaned the Flucard contacts with IPA and I was able to format the card, like Adam recommended.

The memory card error is gone and but it's not all good, yet. When I power-on the camera, there is no beep sound coming from the Flucard but I see the WiFi signal flash for about 15 seconds and then disappear.
Even though I can now access the Flucard menu, the Communication Info and Firmware Info/Options menus are unpopulated. I also tried reseting 'transfer settings" to default values but that didn't help.

Any ideas?

Any suggestions about how I can go about initiating a warranty repair?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
apps, camera, card, dslr, effort, error, flucard, flucard blues, flucard embarassing piece, interface, k-3, k3, memory, name, pentax, pentax flucard, pentax k-3, post, product, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
First impression of FLUcard on K-3 JPT Pentax K-3 74 07-30-2014 06:59 AM
What a crappy piece of software. Catscradle Pentax K-3 21 12-12-2013 07:27 PM
Abstract do you want piece of me? pavpen Photo Critique 5 08-24-2013 03:23 PM
Embarassing Vintage Pentax Issue Maggiolone Troubleshooting and Beginner Help 18 09-29-2012 09:04 PM
Abstract Reflections of a Junk eaglem Post Your Photos! 4 08-23-2010 07:43 AM



All times are GMT -7. The time now is 10:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top