Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-21-2014, 09:18 PM   #1
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,009
K3 Firmware v1.11 is up.

Latest K-3 Firmware Update : Software Downloads | RICOH IMAGING

The automatic reset function - Mirror Flap fix maybe ?

08-21-2014, 09:33 PM   #2
Site Supporter
K David's Avatar

Join Date: Oct 2012
Location: SF Bay Area
Photos: Gallery
Posts: 1,201
That automatic reset is interesting. It seems like it could lead to a lot of people saying 'I could have sworn I changed that setting.' It should help with some of the issues a few users have noted.
08-21-2014, 09:36 PM   #3
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,009
Original Poster
This also means other camera firmware updates should be about to appear on the six month cycle Ricoh mentioned.
08-21-2014, 09:50 PM   #4
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
I don't know if it applies for mirror flap (had one over the weekend), but today I had my k-3 start firing oddly - shot one shot and it decided to take more shots without being on bracketing or anything. I had to remove the battery, and it reset itself to F4 and 1/50s when my settings prior were F2 and 1/125s. The images were saved and it wasn't fluttering the mirror so I don't think it's mirror flap, but this update sounds like it's intended to return the settings to what I had them before.

Might as well update now then.

08-21-2014, 10:02 PM   #5
Site Supporter




Join Date: Mar 2008
Location: Prince George, BC
Photos: Gallery
Posts: 2,253
Done. Thanks for the heads up.
08-21-2014, 11:57 PM   #6
Pentaxian
kooks's Avatar

Join Date: Apr 2011
Location: San José, Costa Rica
Photos: Albums
Posts: 625
Just installed it and will try it the upcoming days..

Let's see how it goes..
08-22-2014, 02:14 AM   #7
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,287
Anyone that understands the writing? "...when detecting rarely occur abnormal motion of the sequence"



Added automatic reset function when detecting rarely occur abnormal motion of the sequence.
(When automatic reset function is operated, latest setting will be reset)
08-22-2014, 04:19 AM   #8
Pentaxian
raider's Avatar

Join Date: Jul 2007
Location: Perth, Australia
Photos: Gallery
Posts: 1,931
Thanks Op for the headsup. I updated from v1.02. Will observe how this goes.

08-22-2014, 11:59 AM   #9
Inactive Account




Join Date: Jul 2014
Posts: 7
I'm a new K-3 owner. Got the email, went to the site, downloaded what I thought I needed and copied it to the SD card (the DCIM thing) and so on and so forth. Only problem is that when I put the card in Slot 1 and held the menu button down while turning the camera on the promised screen did not appear. So I'm still stuck with Version 1.0. What have I done wrong? Perhaps someone can guide me through the process. I have a Dell Inspiron laptop running Windows 7 if that's any help at all.
08-22-2014, 12:03 PM   #10
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,102
Follow the instructions for extracting the file on your computer. When you transfer the .bin file to your card don't put the file in a folder. It has to be at the top level on the card.
08-22-2014, 12:18 PM   #11
Inactive Account




Join Date: Jul 2014
Posts: 7
QuoteOriginally posted by Parallax Quote
Follow the instructions for extracting the file on your computer. When you transfer the .bin file to your card don't put the file in a folder. It has to be at the top level on the card.
Thanks. I have the file saved (fwdc220b.bin). Instructions I've found on a web search say to drag the file from where I've saved in to the E:/ drive where I have the card and that will put it in the root file. Is that a safe assumption? Sorry to be so dense but I've not done this before and I want to be sure before I do something stupid.
08-22-2014, 12:24 PM   #12
Veteran Member




Join Date: May 2014
Location: Maryland
Photos: Gallery
Posts: 760
QuoteOriginally posted by Ken Kelley Quote
Thanks. I have the file saved (fwdc220b.bin). Instructions I've found on a web search say to drag the file from where I've saved in to the E:/ drive where I have the card and that will put it in the root file. Is that a safe assumption? Sorry to be so dense but I've not done this before and I want to be sure before I do something stupid.
I think so, just open up the drive to make sure, if you can see the file after you click on the drive once, then it is root folder. If you have to look for it, and open another folder, it needs to be moved. Then stick it in slot 1 of the camera, and turn on camera while holding menu button.
08-22-2014, 12:31 PM   #13
Veteran Member
StarDust's Avatar

Join Date: Apr 2008
Location: Uppsala, Sweden
Posts: 400
Let's hope no new bugs appear. Shooting a wedding tomorrow. Did my first update since 1.0 with no apparent problems. Usually I'm an avid follower of if it ain't broke but I did it for the moire bracketing feature.

Wish me luck
08-22-2014, 12:34 PM   #14
Inactive Account




Join Date: Jul 2014
Posts: 7
QuoteOriginally posted by Murfy Quote
I think so, just open up the drive to make sure, if you can see the file after you click on the drive once, then it is root folder. If you have to look for it, and open another folder, it needs to be moved. Then stick it in slot 1 of the camera, and turn on camera while holding menu button.
Got it. The .bin file is there when I open the card, however the DCIM folder is still evident above the desired file even though I just reformatted the card. Is that a problem?
08-22-2014, 12:36 PM   #15
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,102
No, it shouldn't be a problem, but if you're worried about it just delete the folder then re-format the card in camera after the update.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
absence, bark, computer, dog, dslr, firmware, k-3, k3, k3 firmware v1.11, night, pentax k-3, time, tree, word
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
v1.10 firmware messed up my AF even more twitch Pentax K-3 10 07-26-2014 09:54 PM
Firmware? v1.03 or v1.11? Frank B Pentax K-5 1 10-31-2011 09:39 PM
Is there a Firmware v1.3 manual? Pentax_XTC Pentax DSLR Discussion 9 02-26-2008 05:32 PM
K10D New Firmware v1.11 nosnoop Pentax DSLR Discussion 2 03-06-2007 08:39 AM
K10D Firmware V1.10 is Leaked! RiceHigh Pentax DSLR Discussion 2 01-19-2007 08:10 AM



All times are GMT -7. The time now is 11:39 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top