Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-25-2014, 07:43 PM - 1 Like   #16
New Member




Join Date: Feb 2014
Posts: 8
Original Poster
K-3 using 64 GB SD memory

Thanks to all who responded to my problem. The problem I was having was fixed by downloading and installing V1.03 firmware. This group has helped again. I am glad to be a part and really appreciate all the help.




09-25-2014, 08:00 PM   #17
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
QuoteOriginally posted by BarryDarnell Quote
installing V1.03 firmware
??
The K-3 firmware is up to v 1.11 now. May be time to do another firmware update
09-25-2014, 11:35 PM   #18
Forum Member
markf's Avatar

Join Date: Jul 2013
Location: Chicago
Posts: 55
QuoteOriginally posted by Al_Kahollick Quote
Pentax cameras can be finicky when it comes to memory cards. I've had no issues with Transcend or SanDisk cards, but have had issues with Sony and PNY Cards. As you've found out yourself, some work, some don't.
I use a Sandisk in slot 1 and a PNY in slot 2 and have the card error problem with the PNY in slot 2, but not when I put it in slot 1. When I format the PNY card, it works for awhile and when I look at my images from the Sandisk, I then get the card error for slot 2. Its very intermittent. I've reformatted that card in my computer and then the camera a number of times. All my photos are on the Sandisk, so until I fill that one I'm not going to do anything about it. I'll see if the camera starts to put the photos on the PNY card after I fill up the Sandisk card or I have to switch the cards.
09-25-2014, 11:51 PM   #19
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,120
I've had memory card errors with my K-3 on the Pentax FLUcard, and on a 16GB Kingston and 16GB Sandisk Ultra. In-camera formatting seems to have fixed things with the first two, but the error on the Sandisk which occurred just now when I switched the camera on was apparently cured by taking the card out and re-inserting it. I had previously removed it for downloading the images to my computer, and I had properly ejected the card before removing it. I'd never experienced a memory card error before, so I'm left wondering if the K-3 is a bit more finicky than its predecessors, even with lower capacity cards.

09-26-2014, 09:11 AM   #20
Pentaxian




Join Date: Dec 2013
Photos: Gallery
Posts: 501
I am currently using two Kingston SD Cards, both of them are 64 GB, and am yet to experience any problems.
09-26-2014, 09:49 AM   #21
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,187
QuoteOriginally posted by RobA_Oz Quote
I've had memory card errors with my K-3 on the Pentax FLUcard, and on a 16GB Kingston and 16GB Sandisk Ultra. In-camera formatting seems to have fixed things with the first two, but the error on the Sandisk which occurred just now when I switched the camera on was apparently cured by taking the card out and re-inserting it. I had previously removed it for downloading the images to my computer, and I had properly ejected the card before removing it. I'd never experienced a memory card error before, so I'm left wondering if the K-3 is a bit more finicky than its predecessors, even with lower capacity cards.
Are you a Macintosh user by any chance?


Steve
09-26-2014, 10:04 AM   #22
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,120
QuoteOriginally posted by stevebrot Quote
Are you a Macintosh user by any chance?


Steve
Well spotted, that man!
09-26-2014, 10:54 AM   #23
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,187
QuoteOriginally posted by RobA_Oz Quote
Well spotted, that man!
The reason why I asked about the Mac is that the card problems on Pentax seem to be more common when they have used on a Mac due to the computer writing temporary files to the card. The SD formatter (link above) is supposed to cure that problem.


Steve

09-26-2014, 12:58 PM   #24
New Member




Join Date: Feb 2014
Posts: 8
Original Poster
QuoteOriginally posted by rawr Quote
??
The K-3 firmware is up to v 1.11 now. May be time to do another firmware update
I went to link provided and V1.11 is avaliable. Yesterday evening when I downloaded the firmware v1.03 was the latest version. I will do it again this weekend. Thank you very much for your help.
09-26-2014, 01:32 PM   #25
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,120
QuoteOriginally posted by stevebrot Quote
The reason why I asked about the Mac is that the card problems on Pentax seem to be more common when they have used on a Mac due to the computer writing temporary files to the card. The SD formatter (link above) is supposed to cure that problem.


Steve
Yes, and those files are generally hidden from view, but why that would only cause a card error on the K-3 is something of a mystery to me. I've used the same cards on a K20D, a K-5 and now a K-3, and it's only the K-3 that I've experienced the issue with, which suggests that a firmware issue is at the heart of it.
09-28-2014, 11:34 AM   #26
cal
New Member




Join Date: Sep 2014
Posts: 5
I am just getting used to using a Pentax K100D that I inherited. I got excited concerning some of the group using 64g cards. My camera will not accept anything bigger than 2g which are getting very hard to find. I read the part about firmware update. where is it found? Is it difficult to update my camera?
By the way, my last problem was solved by installing lithium batteries. thanks to all for the hellp
09-28-2014, 11:37 AM   #27
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
QuoteOriginally posted by robertchow999 Quote
I have the exact same problem. The crazy thing is that the card works fine with both my 645D and my MX-1, just not the K-3.
This happened with my 128Gb card once. The solution was to put it in the other SD slot (SD2 if SD1 was being problematic), format it in-camera, then move it back to the original slot.

It may be a firmware bug related to which SD slot is currently considered "active", but that's just my guess. I hope the fix works for you!

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-28-2014, 11:47 AM   #28
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
QuoteOriginally posted by cal Quote
I read the part about firmware update. where is it found? Is it difficult to update my camera?
All the Pentax firmware updates are here:
Software Downloads : Support & Service | RICOH IMAGING
The download page for each firmware version has instructions on how to install it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, card error, dslr, error, gb, k-3, k3, memory, message, pentax k-3, samsung sdxc, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware won't update with 64 GB Extreme Pro SD Card Mark K5 Pentax K-3 2 04-04-2014 12:46 PM
Patriot LX Series 64 GB SDXC Class 10 $36.99 w/free shipping jogiba Pentax Price Watch 4 07-18-2012 02:09 AM
1/64 trailing sync on k-7 using 3 flashes Nass Flashes, Lighting, and Studio 14 04-14-2012 03:40 PM
SD card for K-7: Sandisk class 10 extreme...8, 16, or 32 gb? Loren E Pentax Camera and Field Accessories 8 10-26-2010 02:25 PM
For Sale - Sold: Takumar 135mm f/3.5, 16GB SD Memory, K20D Battery ddjchemist Sold Items 4 05-31-2009 03:52 AM



All times are GMT -7. The time now is 06:46 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top