Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-05-2014, 07:01 AM   #1
Junior Member
screamiky's Avatar

Join Date: Nov 2014
Location: Lugano - Switzerland
Posts: 25
K-3 and Lexar Pro SDXC 64GB

Hi everyone, recently I wanted to try some timelapse shooting and I thought I needed a more capable memory card so I bought a "Lexar 64GB SDXC Memory Card Professional Class 10 600x UHS-I". I don't know why but suddenly, from one day to another, the K-3 stopped saving the pictures on this card, before I had no problem in fact I did many timelapse of over 200-300 RAWs without any trouble on the same memory card. Now I can't even format it from within the camera and just keeps saying something like there has been an error with this memory card. I thought it could be physically ruined, but I tried it this weekend on a Nex-6 and everything was fine.

I'm no expert in this field and hope someone could help me. Thanks

11-05-2014, 07:19 AM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
What firmware are you running in the K-3? Sometimes firmware updates include card support improvements.
11-05-2014, 07:27 AM   #3
Junior Member
screamiky's Avatar

Join Date: Nov 2014
Location: Lugano - Switzerland
Posts: 25
Original Poster
I just checked and it's the v1.11. I thought about resetting the K-3 and maybe reinstalling the new firmware, that could help?
11-05-2014, 07:46 AM   #4
Pentaxian
FantasticMrFox's Avatar

Join Date: Oct 2014
Location: Scotland
Posts: 2,097
I think it's neither possible nor useful to 'reset' the K3. You cannot go back to past firmware versions and I can't see how it would help either.

11-05-2014, 07:48 AM   #5
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
QuoteOriginally posted by screamiky Quote
maybe reinstalling the new firmware
You already have v1.11, which is the latest firmware, so I wouldn't bother re-installing.

Card support is always tricky.

Does the K-3 still work fine with other cards, or is it just the Lexar 64GB with issues?

If you are having trouble formatting the card, download this tool and give it a try:
https://www.sdcard.org/downloads/formatter_4/
11-05-2014, 07:59 AM   #6
New Member




Join Date: May 2010
Location: Romsdal
Posts: 24
I'm using two of the same cards (128 GB versions) and no problems so far.
11-05-2014, 08:01 AM   #7
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,323
Its not write protected, right? The little Lock lever is disabled, yes?
Next thing to check is if the card works normally on computer. Save any data from it, then try reformatting in-camera. Maybe even in another Pentax camera, if you have.
First time I hear of Lexar cards making a problem. Usually its Sony or Panasonic cards
11-05-2014, 08:09 AM   #8
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,287
Also test both slots...

I have read in other threads about problems with 64 GB cards. Do not remember the brand.

11-05-2014, 08:11 AM - 1 Like   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,187
Other users on this site have reported problems similar to yours. There are potential problems with the formatting on sdxc cards due to varying computer operating system support and incompatible variants of the exFAT file system. They were solved by reformatting the card using the free formatter from the SD Association Web site:

https://www.sdcard.org/downloads/formatter_4/


Steve
11-05-2014, 08:13 AM   #10
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,287
Another thread with Samsung 64 GB. Try putting it in the other slot and format if possible and then putting it back.

https://www.pentaxforums.com/forums/172-pentax-k-3/273892-k-3-using-64-gb-sd-memory.html
11-05-2014, 10:14 AM   #11
Junior Member
screamiky's Avatar

Join Date: Nov 2014
Location: Lugano - Switzerland
Posts: 25
Original Poster
Well, thanks everybody for the fast responses. I tried a complete format of the card with the SDFormatter software and everything went smooth, but as I put it in my K-3 and took one photo the error showed up again. I'm led to believe that I bought a faulty memory card, because now neither my iMac nor my MacBook or my Nex-6 won't recognize it. As you suggested I tried also both slot without success. I tested my other 32GB SDHC Sandisk and no error showed up, so the camera's slots should be fine. Again, thanks for the amazing support.

Last edited by screamiky; 11-09-2014 at 04:50 PM. Reason: typo
11-05-2014, 11:27 AM   #12
New Member




Join Date: Aug 2014
Posts: 8
I have the same card (lexar 64Gb), and i had a similar problem; after the camera had finished storring the images, i could not view the stored photos, unless i closed and started the camera again. Even then, after 5-10 photos the error message showed again. The photos were saved in the card but i could not see them. In the end i had to use the card at my tablet, where it runs ok.
11-05-2014, 11:36 AM   #13
Veteran Member




Join Date: Nov 2013
Posts: 385
I don't know if this helps but I have had problems with any SD brand other than Sandisk with Nikon (D7000 and D7100) and Pentax (K30 and K3 ). My compact cameras can take pretty much any brand but the DSLRs seem very picky.

So for me it's only Sandisk now.

Last edited by maxxxx; 11-05-2014 at 12:03 PM.
11-05-2014, 11:49 AM   #14
New Member




Join Date: Aug 2014
Posts: 8
My k10d worked ok with whatever card i putted in. Now i'm using a transcend card with the k3, which although is slower, works ok. But for the future maybe it would be better to stay with sandisk.
11-10-2014, 07:31 AM   #15
Pentaxian




Join Date: Jul 2013
Photos: Gallery | Albums
Posts: 601
I had a similar error with my K-3 and a Transcend 64Gb card yesterday. I shot a bunch of photos, downloaded them onto my computer via a card reader, all went well. Then I was just previewing the images on the card, in the computer, when all of a sudden I got a fatal error message (Windows 8.1) requiring a reboot of the computer. When I put that card back in the K-3 it said "can not write to card" so I figured it needed formatted again - did so, in the K-3, same error. On a lark I put the card in a Canon 70D, formatted it in camera, and it worked fine. Transferred it to the K-3 and voila! It worked absolutely fine.

Seems to me the issue is in Pentax/Ricoh's implementation of formatting.

*update*

Just did the same thing, uploaded images to a computer (this time a Chromebook) and when I put the card back in the K-3, it said "Card is not formatted".

*update 2*

Read a post on DPReview that helped. Put the card back in the computer, did a "eject" on the card, and now the K-3 recognizes it. How weird.

Last edited by Wolfeye; 11-10-2014 at 07:41 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
64gb, cameras, card, cards, dslr, issue, k-3, k-3 and lexar, k3, lexar, lexar pro sdxc, memory, pentax, pentax k-3, samsung, sd, sdxc, sony, timelapse
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
LEXAR SDXC 64gb PROBLEM (FORMATTING) sandpipe Troubleshooting and Beginner Help 9 07-30-2014 02:20 PM
64Gb SDXC card - Less Than Fifty Cents a Gig eddaytona Pentax Price Watch 4 04-07-2014 01:25 PM
64Gb Sandisk SDXC card for $47.95 Adam Pentax Price Watch 2 06-07-2013 11:15 PM
Sony 64Gb SDXC Card: $36.45 Adam Pentax Price Watch 3 05-22-2013 02:16 PM



All times are GMT -7. The time now is 09:08 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top