Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-15-2014, 12:01 PM   #1
New Member
JG49's Avatar

Join Date: Jul 2014
Location: Jefferson City, Missouri
Photos: Gallery | Albums
Posts: 5
K-3 Firmware Update

I just downloaded the firmware update for my K-3. I copied the bin file as instructed onto a reformatted sd card. Loaded it into my camera, turned the camera on while holding down the menu button as instructed. The LCD showed firmware version to be updated and I was instructed, using the four-way controller to click on start. Immediately it began flashing on my LCD screen " Now Loading". The instructions said that at the end of the uploading a message complete would appear on the LCD screen. Okay so while it is loading I went back to working on my computer and when I turned to check on the loading process the LCD screen is black. So if the word complete showed up I missed it. My question is did it upload? Is it safe to turn the camera off and check to see if the firmware uploaded correctly? It says do not turn off until complete. By the way I had two fully charged batteries in the camera. John

11-15-2014, 12:22 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,302
It sounds like the camera may have completed the update and turned itself off. In order to verify that the firmware update was successful, go to the firmware option under the setup (wrench icon) menu tab, and confirm that the indicated firmware version matches that of the update.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-15-2014, 12:25 PM   #3
Forum Member
rRnt's Avatar

Join Date: Dec 2009
Photos: Gallery | Albums
Posts: 83
When I updated the firmware on my K-3, the word "Complete" appeared only for a few seconds, then the screen went black.
11-15-2014, 12:26 PM   #4
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,716
The 'completed' shows only for a second, very easy to miss if you are not watching. The update takes about 2 minutes so if it has been longer than that just check the new version as Adam mentioned.

11-15-2014, 12:58 PM   #5
Emperor and Senpai
VoiceOfReason's Avatar

Join Date: Jun 2010
Location: Nashville, IN
Posts: 5,368
That's exactly what my K3 did when I updated from 1.00 to 1.11 day before yesterday. Things are fine.
11-15-2014, 01:07 PM   #6
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,315
About the firmware version. Why does the US site show 1.03 as the latest?
11-15-2014, 03:12 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,108
QuoteOriginally posted by Tjompen1968 Quote
About the firmware version. Why does the US site show 1.03 as the latest?
We are backward over here.


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, check, firmware, k-3, k-3 firmware, lcd, message, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 Firmware Update 1.10 Released sab Pentax News and Rumors 49 09-11-2014 07:31 PM
K-500 Firmware Update mmarquardt Troubleshooting and Beginner Help 9 06-26-2014 08:36 PM
K-3 firmware update coming next month DSims Pentax News and Rumors 7 06-25-2014 08:06 AM
Difficulty transferring K-3 firmware update file to SD card FW Birds Pentax K-3 8 12-31-2013 07:51 PM
K-3 video so much better , but ... please to update firmware ! pTom Pentax K-3 71 12-16-2013 08:43 PM



All times are GMT -7. The time now is 05:01 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top