Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-29-2014, 02:33 PM   #1
Forum Member
radeon7750's Avatar

Join Date: Aug 2014
Location: Romania
Posts: 95
K-3 and Sigma 50mm f1.4 EX HSM issue

Anyone else having issues with the Sigma lens mentioned in the thread title? Mine just refuses to lock in focus sometimes ( and it happens quite often). I press the button halfway, the subject is (almost) in focus but I don't hear the confirmation beep. If I keep the button halfway pressed I can hear a noise...the HSM motor of the lens produces a whir...but that;s all it does. If I press the AF button again it just refuses to focus, making the same strange quiet noise.... Sometimes it makes that little adjustment needed for the subject to be in perfect focus and I get the beep, but this only happens in less that half of the cases. And when it decides to lock in focus, it is very sharp.
I've tested in different situations, places, lighting conditions...it;s the same. The same behavior was on a K-5.
So...is anyone else having the same issue?

K-3 FW 1.11

None of the other lenses I've tested showed such behaviour.


Last edited by radeon7750; 11-29-2014 at 02:41 PM.
11-29-2014, 04:51 PM   #2
Loyal Site Supporter




Join Date: Apr 2010
Location: Tennessee
Posts: 5,803
I have not had any issues. Send it to Sigma and let them calibrate it. At the widest apertures my 50mm F/1.4 does struggle with accuracy, but it locks. My Sigma 85mm is my most accurate lens. Is your lens new or used? Sigma might need to update the firmware in the lens.
11-30-2014, 12:28 AM   #3
Forum Member
radeon7750's Avatar

Join Date: Aug 2014
Location: Romania
Posts: 95
Original Poster
QuoteOriginally posted by Winder Quote
I have not had any issues. Send it to Sigma and let them calibrate it. At the widest apertures my 50mm F/1.4 does struggle with accuracy, but it locks. My Sigma 85mm is my most accurate lens. Is your lens new or used? Sigma might need to update the firmware in the lens.
Thank you for replying Winder. The lens is new.
11-30-2014, 12:41 AM   #4
Loyal Site Supporter




Join Date: Apr 2010
Location: Tennessee
Posts: 5,803
QuoteOriginally posted by radeon7750 Quote
Thank you for replying Winder. The lens is new.
If it is brand new. Send it back for another copy. I have had my Sigma 50mm F/1.4 for 5 years now. It has been on my K-7, K-5 & now the K3. The AF has been faster than the DA* 55mm F/1.4 lenses that I have tried.

12-03-2014, 11:38 AM   #5
Forum Member
radeon7750's Avatar

Join Date: Aug 2014
Location: Romania
Posts: 95
Original Poster
QuoteOriginally posted by Winder Quote
If it is brand new. Send it back for another copy. I have had my Sigma 50mm F/1.4 for 5 years now. It has been on my K-7, K-5 & now the K3. The AF has been faster than the DA* 55mm F/1.4 lenses that I have tried.
It was a new lens but it wasn't mine. I had borrowed it from a friend so I had to give it back.

Today I've bought my own new Sigma 50mm f1.4 EX DG HSM lens and it locks in focus every time, without any issues.
12-03-2014, 12:50 PM - 1 Like   #6
Loyal Site Supporter




Join Date: Apr 2010
Location: Tennessee
Posts: 5,803
QuoteOriginally posted by radeon7750 Quote
It was a new lens but it wasn't mine. I had borrowed it from a friend so I had to give it back.

Today I've bought my own new Sigma 50mm f1.4 EX DG HSM lens and it locks in focus every time, without any issues.
Good. Its a great lens with really good bokeh.
12-07-2014, 03:56 PM   #7
New Member




Join Date: Aug 2014
Posts: 9
Got the same problem with my sigma 24-70mm 2,8 EX. I found out, that when i push the lens upward, the lens contacts loose their connection to the camera and i got problems with the autofocus too.
12-08-2014, 11:52 PM   #8
Forum Member




Join Date: Jan 2014
Posts: 50
I have seen a couple of older Sigma lenses lose contact when moved upwards. I found tightening the 3 screw on the lens's bayonet ring fixed the problem. Just nip them up don't overtighten them.


Last edited by Flasher; 12-09-2014 at 01:05 AM.
12-09-2014, 09:16 AM   #9
Forum Member
radeon7750's Avatar

Join Date: Aug 2014
Location: Romania
Posts: 95
Original Poster
out of the 4 lenses ( sigma 10-20 f3.5 ex hsm, sigma 50mm f1.4 ex hsm, tamron 17-50 f2.8, pentax 55-300) which I tested on 2 cameras (k3 and k5), only the 50mm f1/4 had issues. But then again, as I mentioned above, I bought my own 50mm f.4 and this one doesn't have the focus confirmation issue like the previous one (which was borrowed from a friend).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
beep, button, dslr, focus, k-3, k-3 and sigma, k3, lens, pentax k-3, sigma, sigma 50mm f1.4, sigma 50mm f1.4 ex hsm, subject
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anothe uterly uneccessary comparison Pentax-F 50mm f1.4 and Sigma Ex dg 50mm f1.4 HSM Stavri Pentax SLR Lens Discussion 18 09-18-2014 12:53 PM
For Sale - Sold: Sigma 50mm F1.4 EX DG HSM (price reduced/now shipping worldwide) pop4 Sold Items 3 04-11-2014 04:11 AM
Sigma 50mm f1.4 EX DG HSM ? Cregar Pentax SLR Lens Discussion 16 10-23-2011 09:21 AM
Sigma 50mm f1.4 EX DG HSM ? Big G Pentax SLR Lens Discussion 25 05-22-2009 05:59 AM



All times are GMT -7. The time now is 12:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top