Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-05-2014, 03:26 AM   #1
Junior Member




Join Date: Oct 2012
Location: Pathum Thani, Thailand
Photos: Gallery | Albums
Posts: 47
Connecting K3 via USB

When I connect the K3 to my computer the two cards both mount as 'NO NAME'.

On the K5 the camera mounts as 'K5'.

Anyone know if it is possible to get the cards to mount as K3-1 and K3-2, or K3A and K3B?

Cheers

Rob

12-05-2014, 03:40 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
You can rename each SD card when it's inserted into a card reader- and possibly also in USB mode, but right clicking on the icon and selecting "rename".

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-05-2014, 04:08 AM   #3
Forum Member




Join Date: Jan 2014
Posts: 98
Format the cards and they wil be named by the camera they were formatted in!
12-05-2014, 07:44 AM   #4
Junior Member




Join Date: Oct 2012
Location: Pathum Thani, Thailand
Photos: Gallery | Albums
Posts: 47
Original Poster
Thanks... These were brand new cards and so not formatted by the camera yet.

12-05-2014, 03:24 PM   #5
Senior Member
Stumpy's Avatar

Join Date: Sep 2014
Location: Devon UK
Posts: 105
I always format new cards in the camera to make sure they are set up correctly.
12-05-2014, 09:37 PM   #6
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,249
QuoteOriginally posted by Dave's clichés Quote
Format the cards and they wil be named by the camera they were formatted in!
Never had a camera which does this. !?

QuoteOriginally posted by Stumpy Quote
I always format new cards in the camera to make sure they are set up correctly.
A good tool for proper formatting and volume naming is SDFormatter from the official SD Association.
https://www.sdcard.org/downloads/formatter_4/
12-06-2014, 03:15 AM   #7
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 903
I format all my card in camera and the K3 does name the card K3, but both cards will be named K3, not K3-1/K3-2.
12-06-2014, 05:12 AM   #8
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,249
Well I don't have a K-3, but I have 4 Pentax cams at the moment and two others I sold. Not one named the volume when formatted in camera. Must be new to K-3

12-06-2014, 07:39 AM   #9
Senior Member
Stumpy's Avatar

Join Date: Sep 2014
Location: Devon UK
Posts: 105
QuoteOriginally posted by Steve.Ledger Quote
Well I don't have a K-3,
Sorry to be blunt, but then why are you answering questions in a dedicated K-3 specific section of the forum, when you don't know the answer

QuoteOriginally posted by Steve.Ledger Quote
A good tool for proper formatting and volume naming is SDFormatter from the official SD Association.
I have that program too, but if you read the manual, you should still format the card in the camera.

Last edited by Stumpy; 12-06-2014 at 08:08 AM.
12-06-2014, 12:27 PM   #10
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,249
Mr Stumpy, I was making a comment indicating my surprise and making a recommendation (which was earlier recommended to me by someone on PF).
Do I need to check in with you before I have something to say?

BTW: There's no mention in the manual (v1.08) that you should still format the card in the camera.

Last edited by Steve.Ledger; 12-06-2014 at 12:45 PM.
12-06-2014, 04:46 PM   #11
Junior Member




Join Date: Oct 2012
Location: Pathum Thani, Thailand
Photos: Gallery | Albums
Posts: 47
Original Poster
I've not seen any mention in the manual (doesn't mean it's not there, just I haven't seen it), but all I can say is that I only ever format the cards in-camera and, having done so now with the K3, that both it and the K5 name them according to the camera that formats them.

Problem and puzzlement solved.
12-06-2014, 05:01 PM   #12
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
I wish they include the USB 3.0 cable in the camera box, so you must have obtained your USB 3.0 cable from another source..... sorry I digress and don't mean to steal your thread.
12-06-2014, 06:31 PM   #13
Banned




Join Date: Feb 2013
Posts: 390
FWIW..... My K30 names the volume label, as does the K3. Don't recall if the K20 named the cards or not, don't think the *ist DL did.
12-06-2014, 10:45 PM   #14
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,189
QuoteOriginally posted by aleonx3 Quote
I wish they include the USB 3.0 cable in the camera box
We all wish that. It is lame for Ricoh to assume that the new owner has either the cable or a card reader. Of course, they don't include a card either, so I guess that explains it.


Steve
12-07-2014, 01:15 AM   #15
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,076
on Mac, right click on K-3 ( placed in slot 1) , get info, rename to K-3_1, do the same with K-3_2
K-s1 does not come with USB cable
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cards, dslr, k-3, k3, k5, mount, pentax k-3, usb
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 with USB not staying connected CopyRon Video and Pentax HDSLRs 3 06-28-2014 10:37 AM
Pentax K3 with 40 MP via sensor shift troenaas Pentax News and Rumors 129 10-07-2013 09:06 PM
K10D - GX10 1.30 Firmware Debug menu via usb activation Sam Pentax News and Rumors 43 06-12-2010 08:18 AM
Connecting Pentax Flashes via PC Cord Swift1 Flashes, Lighting, and Studio 5 01-15-2010 10:21 AM



All times are GMT -7. The time now is 03:12 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top