Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-14-2014, 03:29 PM   #1
Site Supporter
PC228A's Avatar

Join Date: Feb 2014
Photos: Gallery
Posts: 12
K-3 Autofocus

When I turn on my K-3 with the SMC Pentax-DA 1:3.5-6.3 18-250mm ED AL [IF] attached it begins to autofocus. As I move the camera around the autofocus kicks in. When I go to take a shot the AF symbol is lit in the viewfinder and the autofocus is locked. This problem has just started.
Can anyone suggest a solution before I ship it off to Ricoh?

12-14-2014, 03:49 PM   #2
Senior Member
jase036's Avatar

Join Date: Mar 2010
Location: Calgary, Alberta
Photos: Gallery
Posts: 170
QuoteOriginally posted by PC228A Quote
When I turn on my K-3 with the SMC Pentax-DA 1:3.5-6.3 18-250mm ED AL [IF] attached it begins to autofocus. As I move the camera around the autofocus kicks in. When I go to take a shot the AF symbol is lit in the viewfinder and the autofocus is locked. This problem has just started.
Can anyone suggest a solution before I ship it off to Ricoh?
What focus mode are you in? AF.S? AF.C? What do you mean it kicks in? Does it hunt around without shutter half press?
12-14-2014, 04:18 PM   #3
Site Supporter
PC228A's Avatar

Join Date: Feb 2014
Photos: Gallery
Posts: 12
Original Poster
I've just spent the last half hour trouble shooting and found that I had left my battery grip turned on. With it turned off everything appears to be back to normal. Weird.
12-14-2014, 04:31 PM   #4
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,482
I have both K-3 and DA18-250mm.

You need to use AF.S and put the camera to sleep (after 1 min).

Also use the OVF rather than Liveview.

ADD: I do not use the grip.

Hope that the comment will help.

12-14-2014, 11:58 PM   #5
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,403
Check to see if your hand is hitting the shutter button on the battery grip.
12-15-2014, 12:02 AM   #6
Forum Member




Join Date: May 2010
Location: Faroes Islands
Photos: Gallery
Posts: 65
QuoteOriginally posted by PC228A Quote
When I turn on my K-3 with the SMC Pentax-DA 1:3.5-6.3 18-250mm ED AL [IF] attached it begins to autofocus. As I move the camera around the autofocus kicks in. When I go to take a shot the AF symbol is lit in the viewfinder and the autofocus is locked. This problem has just started.
Can anyone suggest a solution before I ship it off to Ricoh?
Happen to me all the time during vacation, very annoying, I use the K3 with grip too, but on my K5 with grip, this never happened!
12-15-2014, 02:10 AM   #7
Senior Member




Join Date: Mar 2009
Location: Perth - Australia
Photos: Albums
Posts: 214
QuoteOriginally posted by gryphongryph Quote
Happen to me all the time during vacation, very annoying, I use the K3 with grip too, but on my K5 with grip, this never happened!
Happened on the k20 grip also.. when carrying it around and forgetting I had the grip "on" my palm would inadvertently 'focus' - How does the grip know its not meant to be working if its pressed?

Steve
12-15-2014, 02:24 PM   #8
Veteran Member
cbope's Avatar

Join Date: Dec 2011
Location: Helsinki
Posts: 664
Changing to back button focus should fix this issue, as well as bringing other benefits. Since discovering BBF, I never focus with the shutter release unless I need someone else to take a picture. Then I just put the camera in green mode. It also keeps others from accidentally changing the settings without knowing the camera.

12-15-2014, 07:57 PM   #9
Site Supporter
PC228A's Avatar

Join Date: Feb 2014
Photos: Gallery
Posts: 12
Original Poster
QuoteOriginally posted by hcc Quote
I have both K-3 and DA18-250mm.

You need to use AF.S and put the camera to sleep (after 1 min).

Also use the OVF rather than Liveview.

ADD: I do not use the grip.

Hope that the comment will help.
Thanks for the advice.

---------- Post added 12-15-14 at 07:59 PM ----------

QuoteOriginally posted by cbope Quote
Changing to back button focus should fix this issue, as well as bringing other benefits. Since discovering BBF, I never focus with the shutter release unless I need someone else to take a picture. Then I just put the camera in green mode. It also keeps others from accidentally changing the settings without knowing the camera.
Excellent advice. Thank you.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advice, autofocus, camera, dslr, focus, k-3, k3, pentax k-3, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 vs K-30 Autofocus leeak Pentax K-3 12 11-06-2014 06:21 PM
New K-3 sometimes won't autofocus on start up. miltona580 Pentax K-3 9 10-14-2014 06:18 AM
Pentax K-3 autofocus problems CindyV Pentax K-3 55 04-30-2014 03:59 PM
K-3 autofocus excellent in low light wizofoz Pentax K-3 24 03-26-2014 08:46 AM
K-3 vs K-5 Autofocus Paolo.Bosetti Pentax K-3 1 12-16-2013 08:19 AM



All times are GMT -7. The time now is 11:03 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top