Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-07-2015, 12:25 PM   #16
New Member




Join Date: Jan 2015
Posts: 7
Original Poster
After speaking with Pentax and Sigma customer service, the diagnostic of a change of protocol between K5 and K3 seems to be the good one, and the 530 old generation I have can t have the firmware upgraded only S/N higher than a certain number (about 6xxxxx) can be.

01-07-2015, 12:29 PM   #17
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,768
QuoteOriginally posted by Plouis Quote
After speaking with Pentax and Sigma customer service, the diagnostic of a change of protocol between K5 and K3 seems to be the good one, and the 530 old generation I have can t have the firmware upgraded only S/N higher than a certain number (about 6xxxxx) can be.
Well that sucks.
01-07-2015, 02:13 PM   #18
Pentaxian
audiobomber's Avatar

Join Date: May 2008
Location: Sudbury, Ontario
Photos: Albums
Posts: 6,677
My flash does work in wireless mode, just HSS is missing. I've emailed Sigma Canada to see if my flash can be updated (S/N 1038003).

This is not my original EF-530. I was having inconsistent exposure on my K20D so I sent it back to Sigma for a firmware update. They sent me a brand new unit instead, which is pretty impressive. Maybe they'll upgrade me to an EF-610 Super now. ;-)
01-07-2015, 04:26 PM   #19
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,295
QuoteOriginally posted by audiobomber Quote
Maybe they'll upgrade me to an EF-610 Super now. ;-)
Well, there's a thought!


Steve


Last edited by stevebrot; 01-08-2015 at 09:53 AM.
01-07-2015, 07:27 PM   #20
Pentaxian
audiobomber's Avatar

Join Date: May 2008
Location: Sudbury, Ontario
Photos: Albums
Posts: 6,677
QuoteOriginally posted by stevebrot Quote
Well, there's a though!
Not a very realistic one.
06-16-2015, 05:01 AM   #21
Pentaxian
audiobomber's Avatar

Join Date: May 2008
Location: Sudbury, Ontario
Photos: Albums
Posts: 6,677
QuoteOriginally posted by audiobomber Quote
My flash does work in wireless mode, just HSS is missing. I've emailed Sigma Canada to see if my flash can be updated (S/N 1038003).
No reply from Sigma Canada (Gentec). Dead silence. Not impressed.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dg, dslr, ef-530, fp, k-3, k-3 sigma ef-530, k3, pentax k-3, sigma, sigma ef-530 dg, sync
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 and sigma ef 530 dg super in M mode souless Pentax K-3 20 07-06-2015 09:23 AM
Sigma EF 530 DG Super exposure problem jlaubza Flashes, Lighting, and Studio 8 06-02-2014 05:39 AM
Sigma EF-530, High Speed Sync capable? excanonfd Flashes, Lighting, and Studio 5 01-25-2012 12:06 AM
Sigma EF 530 Super and high-speed sync mattdm Flashes, Lighting, and Studio 5 02-11-2008 05:52 PM
Sigma EF-530 DG SUPER or EF-500 DG SUPER figmental1978 Flashes, Lighting, and Studio 7 10-01-2007 06:06 AM



All times are GMT -7. The time now is 10:37 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top