Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-11-2015, 11:13 AM   #1
Inactive Account




Join Date: Apr 2014
Photos: Gallery
Posts: 31
K3 shutter/mirror flutter

got a K3 for Christmas and love it but have already experienced the infamous shutter/mirror fluttering problem...twice... Last time I got the signal that the battery was dead, so put in recharged battery and no problem. is it possible that the event happened because the battery was dead? B&H will exchange but I am trying to see if this problem has been solved by some sort of firmware upgrade or if there is any other information at hand about a solution..Have had a k5 for 2 years with no problems.

any suggestions?

01-11-2015, 11:22 AM - 1 Like   #2
Pentaxian




Join Date: Sep 2013
Location: Sydney
Photos: Albums
Posts: 844
Upgrade the firmware if you haven't already done so. It seems to fix the problem for most people.
01-11-2015, 11:24 AM   #3
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,829
Supposedly the latest firmware has a partial fix that catches and stops this if it happens. What firmware are you running? There is also supposed to be a fix that will be done under warranty but that has to go into the shop to be applied.

You need to decide whether you want to send it back for replacement or send it in to get warranty repair. Personally I would send it back to B&H for exchange.

The issue happened to me twice in about 20,000 exposures, so for me not an issue. And it has not happened since the latest firmware update. YMMV.
01-11-2015, 11:25 AM   #4
Site Supporter
Site Supporter




Join Date: May 2012
Posts: 2,685
Are you using old batteries or new ones? My K5 started acting weird and in the end it turned out my third party batteries were worn out/no good any more. I put in a new battery and all the issues went away.

01-11-2015, 11:25 AM   #5
Site Supporter
Site Supporter
savoche's Avatar

Join Date: Jun 2011
Location: Lowlands of Norway
Posts: 8,908
And yes, low charge is something several seem to link to the problem. I can't confirm since I haven't had this problem.

Might be because I usually change batteries as soon as I'm down to the last bar, I don't know.
01-11-2015, 11:29 AM   #6
Inactive Account




Join Date: Apr 2014
Photos: Gallery
Posts: 31
Original Poster
it came with version 1.11 and currently running same....so I assume there is nothing to upgrade to?
01-11-2015, 11:33 AM   #7
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,509
QuoteOriginally posted by Tandrew Quote
it came with version 1.11 and currently running same....so I assume there is nothing to upgrade to?
That is the current version. Sorry to hear of it. The only solution is that perhaps the battery was low; otherwise you probably should consider a return / repair.
01-11-2015, 11:51 AM   #8
Veteran Member




Join Date: May 2008
Location: SF Bay Area
Posts: 417
Sorry to hear that. Pls send it in to Precision Camera for a warranty fix or exchange it if you can.
I am yet to experience it so can only imagine how annoyed you will be.

01-11-2015, 03:48 PM   #9
Site Supporter
Site Supporter




Join Date: Nov 2009
Location: Michigan
Photos: Gallery
Posts: 309
Not a certain fix

After experiencing the problem a few times, I sent my camera in for repair. However, I did experience the problem once after the repair. So the repair is not a guaranteed fix. I've always used the more recent firmware.
01-11-2015, 04:10 PM   #10
Inactive Account




Join Date: Apr 2014
Photos: Gallery
Posts: 31
Original Poster
well, having given it some thought I will do the exchange...I mean the camera is worth the problem if I have to live with..it may happen on the next one,but since it is less than 20 days old and happened twice already it seems like an unnecessary risk.
thanks for the responses.
peace
tom
01-11-2015, 04:31 PM   #11
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 10,120
Can somebody me point me to a description of this kind of problem?
01-11-2015, 04:36 PM   #12
Pentaxian




Join Date: Sep 2013
Location: Sydney
Photos: Albums
Posts: 844
You'd know it if you experienced it. The mirror flaps uncontrollably and the camera becomes unresponsive. Removing the battery is the only way to stop the flapping. After that, the camera is back to normal again
01-11-2015, 09:17 PM   #13
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 10,120
QuoteOriginally posted by robthebloke Quote
You'd know it if you experienced it. The mirror flaps uncontrollably and the camera becomes unresponsive. Removing the battery is the only way to stop the flapping. After that, the camera is back to normal again
WOW! That sounds terrible. Is it a problem that was/is common?
01-11-2015, 09:54 PM - 1 Like   #14
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,509
The reports indicate that it is pretty unusual, and especially so since the firmware updates. Tandrew's situation is a real exception, and he should be fairly confident that the exchange will address the concern.

I haven't experienced it, and I am sure it is alarming. On the other hand, it is something easily addressed - and even the afflicted cameras are only experiencing the problem on fairly rare occasion.
01-11-2015, 10:00 PM - 1 Like   #15
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,829
I've had it twice in 20,000+ exposures. Which sounds scary but makes the k-3 more reliable than just about any other device own
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, dslr, flutter, k-3, k3, mirror, pentax k-3, shutter/mirror
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 Crazy Mirror Sickness (Mirror Flapping Lockup) - Report Yours Here! DRabbit Pentax K-3 928 01-17-2017 04:44 PM
Shutter Flutter Panic using BG-5 Battery Grip On Low Battery Rite Pentax K-3 46 06-30-2016 08:02 PM
K-3 mirror flutter - REPLY FROM RICOH PALADIN85020 Pentax K-3 95 12-21-2014 09:33 PM
K3 Crazy Mirror Sickness (Mirror Flapping Lockup) on firmware 1.10 SteveUK Pentax K-3 13 07-22-2014 08:08 PM



All times are GMT -7. The time now is 04:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top