Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-24-2015, 09:25 AM   #61
Pentaxian
bdery's Avatar

Join Date: Mar 2008
Location: Quebec city, Canada
Photos: Gallery
Posts: 5,653
QuoteOriginally posted by derekkite Quote
The bug is when the back screen is off, and you press shutter button halfway. The top screen illuminates (as normal)
It might be a custom setting that I changed, but the top LCD does not light up when I half-press the shutter button. The only way to get it to light up is to program Fx to do that. Which is annoying, because on the K20D the EV comp button used to light up the LCD.

QuoteOriginally posted by derekkite Quote
The new function is when you have your back screen off, hit Info. The info Settings screen shows up. Hit Info again, the selection box pops up, info again and the screen goes off. If you want to go to the status screen you have to arrow over in the selection box, and you can select with the Ok button or the Info button. Same sequence if you are in the Status screen. Hit info, it will show the Info Settings, info again Selection box, info again Settings.
Got it.

04-24-2015, 11:35 PM   #62
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
Just updated to v1.20, to pick up whatever AF improvements they may have introduced.

I normally shoot with the rear-LCD turned off all the time. The rear-LCD light bug is proving to be incredibly annoying. It's a BIG distraction even in daylight.

How could the Ricoh engineers have overlooked such an obvious bug? It is literally staring you in the face when you use the camera. It's such a basic QC testing fail.
04-25-2015, 02:23 AM   #63
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,287
I find the AF-C to be more accurate so I want to stay in 1.20 but the LCD bug really bugs me...
04-25-2015, 08:56 AM   #64
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,211
QuoteOriginally posted by Tjompen1968 Quote
I find the AF-C to be more accurate so I want to stay in 1.20 but the LCD bug really bugs me...
Indeed. AF is hard to quantify especially when you consider all the circumstances where it is used. I would say it is a marginal improvement.

I think I have gotten sharp shots that I otherwise would have missed. Especially with birds in flight. I had almost given up trying. The sel7 or higher seemed to not want to stick with what I was following, so I had it almost always on spot. With the upgrade the sel7 works better than spot, and I am going to try expanding the point count to see what happens.

The stubborn misfocus requiring refocus to acquire happens less often; it was a regular occurrence where a subject in the open with good contrast would be out of focus. Now the majority of oof shots are due to obstruction or some other factor.

The best way to describe it is that it seems to want to find focus where previously it had a certain hesitancy. Still not perfect but better.

04-25-2015, 09:07 AM   #65
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,161
QuoteOriginally posted by Supakatti Quote
Could someone test, does the focus trapping work with this new firmware. I have a fw 1.11 and focus trapping is not working in it.
That is news to me. It works fine on my K-3 with all capable of manual focus with the body being set to AF, except for those without conductive bases. If the conductive base issue is corrected in v1.20, that would be welcome.


Steve

Last edited by stevebrot; 04-25-2015 at 09:26 AM.
04-25-2015, 10:45 AM   #66
Site Supporter




Join Date: Feb 2014
Location: Tuusula, Southern Finland
Photos: Albums
Posts: 74
QuoteOriginally posted by stevebrot Quote
That is news to me. It works fine on my K-3 with all capable of manual focus with the body being set to AF, except for those without conductive bases. If the conductive base issue is corrected in v1.20, that would be welcome.


Steve
The non-conductive base issue is not corrected as far as I have tested. But My K-3 lost CIF after I updated to v 1.11. Now after update v 1.20 CIF works again using my Tamron Adaptals and Pentax manual lenses. I am very happy!
04-25-2015, 11:51 AM   #67
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,287
QuoteOriginally posted by stevebrot Quote
That is news to me. It works fine on my K-3 with all capable of manual focus with the body being set to AF, except for those without conductive bases. If the conductive base issue is corrected in v1.20, that would be welcome.


Steve
Having the AF-button set to deactivate AF and continous shooting selected the CIF did not work but it does now.
04-25-2015, 03:10 PM   #68
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,161
QuoteOriginally posted by Tjompen1968 Quote
Having the AF-button set to deactivate AF and continous shooting selected the CIF did not work but it does now.
Oh! My! Well, that should make some users here VERY happy. It is not enough to make me do this particular firmware update, however.


Steve

04-27-2015, 02:38 AM   #69
Senior Member




Join Date: Jul 2010
Posts: 237
And you feel that killing heat and radiation of back-lcd burning your grey matter? The're coming ...

-----
QuoteOriginally posted by rawr Quote
incredibly annoying. It's a BIG distraction even in daylight. [...] It is literally staring you in the face when you use the camera. It's such a basic QC testing fail.
04-27-2015, 04:47 AM   #70
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
QuoteOriginally posted by Prakticant Quote
that killing heat and radiation of back-lcd burning your grey matter? The're coming ...
? Wat ?
04-27-2015, 05:13 AM   #71
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,161
QuoteOriginally posted by Prakticant Quote
And you feel that killing heat and radiation of back-lcd burning your grey matter? The're coming ...

-----
QuoteOriginally posted by rawr Quote
? Wat ?
It is the mark of the hociR being burned into your flesh.


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
box, bug, button, dslr, eagle, firmware, focus, function, info, k-3, k3, lens, pentax k-3, press, screen, selection, sequence, settings, shots, status, water
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
new K-3 comes with latest firmware 1.11 aleonx3 Pentax K-3 51 04-02-2015 07:40 AM
K-3 Firmware Update JG49 Pentax K-3 6 11-15-2014 03:12 PM
Pentax releases firmware v1.03 for k-3 tava Pentax K-3 9 03-06-2014 05:10 PM
K-3 Firmware wishes.... RonHendriks1966 Pentax K-3 98 02-25-2014 08:46 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM



All times are GMT -7. The time now is 11:29 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top