Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-14-2015, 09:10 PM - 2 Likes   #1
Senior Member




Join Date: Oct 2013
Photos: Albums
Posts: 292
New K-3 Firmware v1.20

Latest K-3 Firmware Update : Software Downloads | RICOH IMAGING

04-14-2015, 09:44 PM   #2
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,258
A change. Hitting Info button turns the screen off.

But I get the screen not showing anything but slightly lit. Hmm.

Focus in movie mode before starting to record is as fast as in live view. Iirc it was very slow previously.

During movie mode it clicks three times as it tries both ways, then adjusts about twice as fast as before, not as fast as live view.

No focus peaking while recording. Focus peaking before recording. I think that is how it worked previously.

Quick focus test worked, and it seems different. It is dark in the house, press AF button and it hesitates slightly then focuses with a bit less chatter. I will have a better indication tomorrow in my more usual shooting situations. Seemed slightly different at least.

Still a delay for p-ttl flash discharge. I can't compare so don't know. Maybe slightly shorter, but hard to say. I remember it being noticeable before now I had to really concentrate to notice it. Not instantaneous for sure.

Now I'm really interested in exploring.

Last edited by derekkite; 04-14-2015 at 10:16 PM.
04-14-2015, 10:06 PM   #3
Senior Member




Join Date: Oct 2013
Photos: Albums
Posts: 292
Original Poster
No movie anti shake with sensor and the display bug is an issue for free 😄👍
I reported it.
Best regards
04-14-2015, 10:14 PM   #4
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,258
QuoteOriginally posted by asahi man Quote
No movie anti shake with sensor and the display bug is an issue for free 😄👍
I reported it.
Best regards
Thanks. I concur re sensor anti shake. Same noise if it is on or off.

04-14-2015, 10:26 PM   #5
New Member




Join Date: Aug 2014
Posts: 9
Info button work as it should on my K-3 and the Anti Shake seems to work in Video Mode also. Maybe reflash your K3 again and set it to factory defaults
04-14-2015, 10:31 PM   #6
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,258
QuoteOriginally posted by seeker68 Quote
Info button work as it should on my K-3 and the Anti Shake seems to work in Video Mode also. Maybe reflash your K3 again and set it to factory defaults
Previously to shut the screen off after hitting info you had to select Display Off and hit Ok. Now it is the same as the K5 where you hit Info repeatedly and it turns off. But the back screen is slightly illuminated at the same time as the top screen is illuminated. As asahi man says, it is a bug.
04-14-2015, 10:33 PM - 1 Like   #7
Senior Member




Join Date: Oct 2013
Photos: Albums
Posts: 292
Original Poster
So we need anti bug spray 😀👍
04-14-2015, 10:36 PM   #8
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,258
QuoteOriginally posted by asahi man Quote
So we need anti bug spray 😀👍
Or v1.21. It would be a great occasion to learn Japanese swear words being around when the bug report showed up.

04-14-2015, 11:29 PM   #9
Junior Member
dicks's Avatar

Join Date: Mar 2014
Location: Munich, Germany
Posts: 36
Too bad they did not add some of the new K-2S features...
04-14-2015, 11:50 PM   #10
Site Supporter
kenspo's Avatar

Join Date: Mar 2014
Location: Oslo
Posts: 1,949
QuoteOriginally posted by dicks Quote
Too bad they did not add some of the new K-2S features...
This isn't the last update.
04-15-2015, 12:44 AM   #11
Veteran Member




Join Date: Sep 2007
Location: Cracow
Posts: 457
QuoteOriginally posted by derekkite Quote
I concur re sensor anti shake. Same noise if it is on or off.
This is how it should be, since Movie SR is software based.
04-15-2015, 12:47 AM   #12
New Member




Join Date: Aug 2014
Location: Sydney
Posts: 6
Not sure if it's a placebo effect but focus on my da 60-250 seems faster and more accurate... I am hoping that future updates will have af-c focus tweaks...
04-15-2015, 01:07 AM   #13
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,322
QuoteOriginally posted by dicks Quote
Too bad they did not add some of the new K-2S features...
What features are you refering to?
04-15-2015, 02:17 AM   #14
Senior Member




Join Date: Jan 2014
Location: Melbourne
Posts: 109
QuoteOriginally posted by jaad75 Quote
This is how it should be, since Movie SR is software based.
On the K-3 it has been software SR (and still is with the latest version) but people are hoping to get sensor SR enabled in video mode, like on the K5s. I would also like my Sigma OS lens not to get powered down in video mode, its almost as if they are determined not not have any good SR in video mode.

John.
04-15-2015, 02:32 AM   #15
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,836
If there are more updates coming I'll skip this one for now. I don't need any of the features listed in the Read Me.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
box, bug, button, dslr, eagle, firmware, focus, function, info, k-3, k3, lens, pentax k-3, press, screen, selection, sequence, settings, shots, status, water
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
new K-3 comes with latest firmware 1.11 aleonx3 Pentax K-3 51 04-02-2015 07:40 AM
K-3 Firmware Update JG49 Pentax K-3 6 11-15-2014 03:12 PM
Pentax releases firmware v1.03 for k-3 tava Pentax K-3 9 03-06-2014 05:10 PM
K-3 Firmware wishes.... RonHendriks1966 Pentax K-3 98 02-25-2014 08:46 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM



All times are GMT -7. The time now is 06:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top