Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-28-2015, 08:34 AM   #31
Veteran Member




Join Date: Nov 2006
Location: Norway
Photos: Gallery
Posts: 385
QuoteOriginally posted by BarryE Quote
Before I update to 1.21 has anyone ever experienced a firmware release alter the AF adjustment settings ? I've fine tuned my lenses, and I don't want to bother doing it again unless I have to. I'm currently happy on 1.11, but if the AF has really (?) become a tad snappier/accurate, maybe I'd benefit on the odd occasion - and of course there's all those minor tweaks we're not told about that may help a little. My limited experience with upgrades suggest the AF doesn't get changed, but I've only upgraded the firmware occasionally...

Thanks
I tested for this today after upgrading from 1.11 to 1.21. The lenses I tested was still focusing correct and the adjustments was there with the same values as before.

05-28-2015, 08:50 AM   #32
Veteran Member




Join Date: May 2008
Location: SF Bay Area
Posts: 417
I dont believe a bit that AF speed increases with every firmware update. This is indeed a placebo effect.
If it indeed improved any AF apsect dont u think Pentax Ricoh will advertise it?
05-28-2015, 08:53 AM   #33
Pentaxian




Join Date: Feb 2015
Photos: Albums
Posts: 3,546
Woow, updated to v1.21, trial with Tamron 70-200 @200mm (screwdrive) , just press the button, camera AF punchy and AF is spot on.
05-28-2015, 09:03 AM   #34
Pentaxian




Join Date: Feb 2012
Posts: 362
QuoteOriginally posted by danny09 Quote
I dont believe a bit that AF speed increases with every firmware update. This is indeed a placebo effect.
If it indeed improved any AF apsect dont u think Pentax Ricoh will advertise it?
Maybe they don't upgrade from the 1.20
1.21 is of course a simple bugfixed version of 1.20

05-28-2015, 09:08 AM   #35
Senior Member
DarkShadow's Avatar

Join Date: May 2015
Location: CT
Posts: 131
QuoteOriginally posted by danny09 Quote
I dont believe a bit that AF speed increases with every firmware update. This is indeed a placebo effect.
If it indeed improved any AF apsect dont u think Pentax Ricoh will advertise it?
Maybe not but since general stability improvements was mentioned on firmware 1.20 it wouldn't surprise me if it did help the AF.I guess I will find out when I could field test it on some BIF.
05-28-2015, 09:39 AM   #36
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
QuoteOriginally posted by DarkShadow Quote
Maybe not but since general stability improvements was mentioned on firmware 1.20 it wouldn't surprise me if it did help the AF.I guess I will find out when I could field test it on some BIF.
"General Stability" improvements have been in every FW upgrade I've done since 2009...
05-28-2015, 09:50 AM   #37
Pentaxian
bobbotron's Avatar

Join Date: Jan 2015
Location: Ottawa, ON
Photos: Gallery
Posts: 1,901
I'll be upgrading from v1.0 to this latest update, I'm looking forward to it!
05-28-2015, 11:11 AM   #38
Veteran Member




Join Date: May 2008
Location: London, UK
Posts: 453
QuoteOriginally posted by whatsthisbuttondo Quote
Try running dust alert i have two k3s dust alert now not completing one one of them
As I have just said on the UK forum, this problem occurred on V1.11 on my K-3 on Saturday - so it is not unique to V1.21.

05-28-2015, 12:33 PM   #39
A Proud PENTAXER !!!
fwcetus's Avatar

Join Date: Sep 2006
Location: New England
Photos: Gallery | Albums
Posts: 1,213
QuoteOriginally posted by bobbotron Quote
I'll be upgrading from v1.0 to this latest update, I'm looking forward to it!
Well, since most of us (I think) have seemed to be upgrading from 1.20 or (at least) 1.11, and have been experiencing the subtle (at best) joys of the placebo effect (LOL), you, on the other hand, had better brace yourself against whiplash, as you accelerate up to warp drive -- it might be time to put aside your camera strap in favor of a seatbelt... :-)
05-28-2015, 12:52 PM   #40
Pentaxian




Join Date: Feb 2015
Photos: Albums
Posts: 3,546
Anyone tried AFC with firmware v1.21 ? With my K-3, it seems that focus priority/FPS priority / first shot as no effect, the camera just take the shot even if not in focus.
05-28-2015, 03:17 PM - 1 Like   #41
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,844
QuoteOriginally posted by Paul the Sunman Quote
Where did you get the lens? I didn't think the 150-450 was available in Australia yet.
CRK have been selling it for about a fortnight, via their eBay store 'dcexpert'.

---------- Post added 2015-05-29 at 08:22 AM ----------

QuoteOriginally posted by biz-engineer Quote
Anyone tried AFC with firmware v1.21 ?
Have you tried re-setting all your custom settings (Menu > C4 > Reset Custom Functions).
I do that after each firmware update just to make I start with a clean slate.

A reset doesn't [normally] affect stuff like your date, copyright, or AF fine-tuning settings.
05-28-2015, 04:26 PM   #42
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,474
QuoteOriginally posted by jeallen01 Quote
As I have just said on the UK forum, this problem occurred on V1.11 on my K-3 on Saturday - so it is not unique to V1.21.
No problem here doing dust alert with v1.11. That being said, I must admit to only using the feature twice in the year that I have owned the camera and a couple of times more to make sure before responding to this post. If there is dust on the sensor, it generally will show up when I start working with the images in PP.


Steve

Last edited by stevebrot; 05-28-2015 at 04:33 PM.
05-28-2015, 06:34 PM   #43
Pentaxian
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,655
Updated successfully, no problems. AF does feel a touch snappier. Only tested with the 16-50 thus far.
05-29-2015, 12:09 AM   #44
Veteran Member




Join Date: May 2008
Location: London, UK
Posts: 453
QuoteOriginally posted by stevebrot Quote
No problem here doing dust alert with v1.11. That being said, I must admit to only using the feature twice in the year that I have owned the camera and a couple of times more to make sure before responding to this post. If there is dust on the sensor, it generally will show up when I start working with the images in PP.


Steve
It usually seems to happen after you have run the dust alert cycle several times, with cleaning in between, as you try to progressively remove the crap - therefore I think it could be a battery depletion issue.
05-29-2015, 03:08 AM   #45
Forum Member




Join Date: Dec 2014
Photos: Gallery
Posts: 74
next we just need for 86k CAF to be implemented :O
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
custom, dslr, firmware, k-3, k3, pentax k-3, reset, settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 new firmware update problem mille19 Pentax DSLR Discussion 24 05-28-2015 04:43 PM
Where is the 1.21 Firmware atlrob Pentax K-3 3 04-27-2015 11:22 AM
645z Firmware 1.21 is out. Chris Giles Pentax Medium Format 8 04-01-2015 12:57 AM
Trouble Updating 1.21 Firmware Linemrkr Pentax Medium Format 2 03-30-2015 11:48 AM
pentax K3 dont recognise the new firmware 1.01 drunagr Pentax K-3 4 01-01-2014 08:43 AM



All times are GMT -7. The time now is 06:44 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top