Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-08-2015, 05:25 PM   #1
Senior Member




Join Date: Feb 2012
Photos: Gallery
Posts: 120
K-3 II memory card glitch

I just got some strange glitch on my K-3 II. Suddenly, if no card is inserted in camera, instead of saying no card(s) in slot(s), it just says memory card error and points to slot 2. And you can not use the camera. If I put a card in slot 1, and leave slot 2 empty, again, memory card error on slot 2. If I put a card in slot 2, camera turns on normally like nothing is wrong. If I remove the card from slot 2 after that and leave one in slot 1, image counter still says that I have a number of images left to shoot on slot 2 card like it was inserted. And if I make a shot, it goes back to memory card error. I use normal SDHC cards, both sandisk, one is extreme pro 8gb and other is standard ultra 32gb. Everything was fine until now, it just happened. I tried blowing in slots thinking it was something that is making the contact inside the slot and registering as if the card was inserted. But it can't be that. Anyone had a similar issue? I will call my service center tomorrow to see what will they suggest.

I had a problem wit PQI Air Card adapter but I doubt that it had something to do with this, because no matter what you do, if slot 2 is empty, it will be registered as something is inserted but in error and camera won't fire. I can even try to format the empty slot. Tried with fresh and almost empty batteries to dismiss the voltage issue.

09-09-2015, 03:33 AM   #2
Pentaxian
awaldram's Avatar

Join Date: May 2008
Location: Hampshire
Photos: Gallery
Posts: 720
The card detect switch/electronics have been jammed/shorted/burnt out

It's pin 1 and active low (2nd pin in on the angled side), I suspect the pin is bent or shorted in the socket

Either get it repaired or keep a card in slot2, Though pin 1 is also Data bit 3 so may cause issues (depending on address structure and card size)

Last edited by awaldram; 09-09-2015 at 03:41 AM.
09-09-2015, 06:20 AM   #3
Senior Member




Join Date: Feb 2012
Photos: Gallery
Posts: 120
Original Poster
I took the camera in for repair and repair guy found a piece of white plastic lodged under that pin and making contact. And only the second time he looked. It was very very small. It got in accidentally obviously.
09-09-2015, 06:32 AM   #4
Pentaxian




Join Date: Aug 2013
Photos: Gallery
Posts: 985
Nice to see you got it fixed and at least it's not a new defect where k-3II owners will have to watch out for.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, dslr, error, ii, ii memory card, issue, k-3, k-3 ii memory, k3, memory, pentax k-3, slot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 Glitch. very perplexing. AbadPhotography Troubleshooting and Beginner Help 5 09-16-2014 01:13 AM
K-3 Sony 32GB Class 10 Memory Card Error Leo315 Pentax K-3 10 08-06-2014 10:01 AM
Will 645z support UHS-II Memory Card? elsdad Pentax Medium Format 3 06-26-2014 06:57 AM
Pentax K-3 w/ free 50mm, BG-5 grip, memory card: deal is back, LIMITED TIME! Adam Pentax Price Watch 22 01-17-2014 12:40 PM
My First K-3 Glitch K David Pentax K-3 6 11-18-2013 02:40 PM



All times are GMT -7. The time now is 06:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top