Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-11-2015, 08:16 AM   #1
New Member




Join Date: Feb 2015
Posts: 9
K3 mode dial does not work anymore. It's always M now.

Problem:
My K3 suddenly stucked in M mode, no matter where the position of the mode dial is and which lens I'm using.

What I've tried:

1/ Reset the camera: not working!

2/ Take out the battery while the camera's on, then put it back: not working!

3/ Update the firmware: not able to update. I guess because my K3 already got the latest firmware.

4/ Clean the lens contact: not working!

Is there any other viable solution that you guys know? I don't want to send this to service because I'm going on vacation next week and photography is the reason of this vacation. I can shoot fine in M mode but there are User Settings that I really need in some circumstances.

12-11-2015, 08:24 AM   #2
Loyal Site Supporter




Join Date: Mar 2015
Photos: Gallery | Albums
Posts: 5,759
Welcome to photography as it used to be. At least you will have the comfort of instant review.
12-11-2015, 08:24 AM   #3
Senior Moderator
Loyal Site Supporter
Nass's Avatar

Join Date: Aug 2009
Location: The British Isles
Photos: Gallery
Posts: 2,247
Google around on this site, I once fixed a dial on a K5/K7 (can't remember which) by just spraying something into it from a can. Should be findable on the forum somewhere. Good luck!!
12-11-2015, 12:50 PM   #4
Tas
Site Supporter




Join Date: Aug 2013
Location: Brisbane, QLD
Photos: Gallery | Albums
Posts: 1,229
How are you trying to turn the mode dial?

On the K3 mode dial there is a button in the centre and a lever at the base of the dial. If you rotate the lever one way you don't need to depress and hold the button to unlock the dial and rotate it. Turn the locking lever the other way and you do. Whilst this is not a feature on my K5, I'd be checking the locking lever first before spraying anything near your camera.

As you've not identified in your description this aspect of what is happening and what you've tried I don't know if this info is relevant.

However if there is a problem and it relates to the locking lever needing some attention under warranty, I don't think it would look really good to find a liquid during disassembly if they think you've done something to cause the problem.

Best of luck mate, hopefully it's as simple as accidentally moving the locking lever. If you're stuck in just M mode on your vacation maybe you could just take it as a challenge to work through solutions and make the most of it.

Tas

12-11-2015, 12:50 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,782
Have you tried more than one lens?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-11-2015, 03:16 PM   #6
PJ1
Site Supporter
PJ1's Avatar

Join Date: Jul 2012
Location: Mosquito Creek, Australia
Photos: Gallery
Posts: 1,494
Is the Focus Mode Switch fully in the "A" position? It is a mistake I have made.
12-11-2015, 04:49 PM   #7
Site Supporter




Join Date: Jan 2014
Location: West Haven, CT USA
Photos: Albums
Posts: 991
QuoteOriginally posted by Nass Quote
Google around on this site, I once fixed a dial on a K5/K7 (can't remember which) by just spraying something into it from a can. Should be findable on the forum somewhere. Good luck!!
The "something in a can" was probably contact cleaner. Can get it lots of places, like automotive parts stores, Radio Shack (is that still a thing?), etc. Might follow up with compressed air to further clean the dial's electrical parts out and better flush out any contaminants.
12-12-2015, 06:10 AM   #8
Senior Member
Larrymc's Avatar

Join Date: Jun 2014
Posts: 216
QuoteOriginally posted by pres589 Quote
The "something in a can" was probably contact cleaner. Can get it lots of places, like automotive parts stores, Radio Shack (is that still a thing?), etc. Might follow up with compressed air to further clean the dial's electrical parts out and better flush out any contaminants.

The K-3 is a sealed system and I doubt very much that you will be able to get enough contact cleaner into the area to get what ever contacts there are clean.


Can you feel the detents as you rotate the mode dial? If no detents are felt something has to have come loose so the best thing to do use the camera while on vacation and then send it in for repair. Spraying contact cleaner not knowing what sort of material the mode dial is made of can be risky, I've seen contact cleaner destroy plastic. Just my two cents.


Larry

12-12-2015, 09:11 AM   #9
Site Supporter




Join Date: Jan 2014
Location: West Haven, CT USA
Photos: Albums
Posts: 991
Depends on the contact cleaner used. Non-chlorinated should be fairly benign to plastics.

Can you think of some other product used to clean electric components like those in the knob that comes in a can? Best way to do this would be to disassemble the knob and inspect and clean components with them in view but that is probably beyond what Really Cool is interested in doing.
12-12-2015, 10:24 AM - 1 Like   #10
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,471
If you figure out how you did it, let me know. I would like to apply this fix to my K-50 (make it stay in M forever).
12-12-2015, 10:28 AM   #11
Senior Member
Larrymc's Avatar

Join Date: Jun 2014
Posts: 216
QuoteOriginally posted by pres589 Quote
Depends on the contact cleaner used. Non-chlorinated should be fairly benign to plastics.

Can you think of some other product used to clean electric components like those in the knob that comes in a can? Best way to do this would be to disassemble the knob and inspect and clean components with them in view but that is probably beyond what Really Cool is interested in doing.

Yes there are some contact cleaners that "might be safe", but why risk it? I agree that the best way to check the mode dial is to disassemble it and inspect it but who has a repair manual for the K-3? I still say the best thing to do is send it in for repairs after his vacation is finished or possibly rent a K-3 if that's possible.


Larry

---------- Post added 12-12-15 at 11:30 AM ----------

QuoteOriginally posted by AquaDome Quote
If you figure out how you did it, let me know. I would like to apply this fix to my K-50 (make it stay in M forever).

Its called super glue
12-12-2015, 10:57 PM   #12
New Member




Join Date: Feb 2015
Posts: 9
Original Poster
Sorry for not describing the problem clearly!

The mode dial can be physically turned without any problem. But the mode displayed in the camera is always M even when the dial is at Av, Tv, U1, U2, etc. It happens with any every I have (20-40, 100f2.8, 50f1.8)

I don't understand the spraying solution because this is a sealed camera. How would the liquid reach the circuit part to clean it up?

Could be firmware bug. Does anyone know how to completely reset the camera? Because when I use the reset function in the menu, some settings like U1, U2,... are still there. So it does not wipe everything.
12-13-2015, 01:55 AM   #13
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,270
Sounds like a physical problem to me, something is not making the right contact within the camera. I think you'll need to send it for repairs and make do with manual mode until then.
12-14-2015, 11:51 AM   #14
Senior Moderator
Loyal Site Supporter
Nass's Avatar

Join Date: Aug 2009
Location: The British Isles
Photos: Gallery
Posts: 2,247
Fyi - at your own risk. https://www.pentaxforums.com/forums/116-pentax-k-r/145847-k-r-e-dial-repair.html
12-14-2015, 11:54 AM   #15
Pentaxian
bertwert's Avatar

Join Date: Jun 2015
Location: Golden, BC
Photos: Albums
Posts: 5,456
Someone else had this problem on their K-5 but never fixed it (IIRC) can't remember who it is.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
components, contact, dslr, firmware, k-3, k3, k3 mode, knob, lens, mode, pentax k-3, vacation
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV mode does not work amoringello Pentax K-5 4 07-09-2015 06:48 PM
AstroTracer Quirks: Does anybody know when it works/does not work? maxxxx Pentax Camera and Field Accessories 16 11-27-2014 01:13 PM
Question Image copy and paste does not work anymore? TropicalMonkey Site Suggestions and Help 7 06-08-2013 11:14 AM
K-X manual mode does not work with Pentax-M 1:3.5 24-35mm FreelancePolice Visitors' Center 2 11-07-2011 06:23 PM
Dial mode not work JoZ3 Pentax K-r 3 12-26-2010 06:27 AM



All times are GMT -7. The time now is 03:03 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top