Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-24-2016, 10:09 PM   #1
Forum Member




Join Date: Apr 2012
Location: Colorado
Posts: 75
K-3 Paperweight

I did a brief search, but am still seeking assistance. I took one for the team and gave my K3 to my daughter as I chose to use a K5ii for my primary shooter. Just got back from a trip to Oahu - no issues with my K5ii and K-01 (full spectrum). But I wish I could say the same for the K-3. It is totally bricked. I exchanged batteries, nothing. Popped out the battery, SD card and lens overnight and re-installed. Nothing. Not even the brief rear light came open when you insert an SD card. Got home and tried an AC power adapter. Nada. Then I just tried the grip...again, nothing. Not a single solitary hint of life to it. Of course, the daughter is just as surprised as I am Suggestions?

Thanks,
Z

06-24-2016, 10:20 PM   #2
Pentaxian




Join Date: May 2015
Location: New Orleans
Photos: Gallery
Posts: 411
Clean the battery contacts. My k100 had nada and I took a cotton bud with liquid wrench sprayed on it and wiped all contacts in the battery compartment down and it's working for a couple years now.
My only suggestion.
06-24-2016, 10:31 PM   #3
Site Supporter




Join Date: Jan 2011
Posts: 2,391
Is the sd card door firmly closed?
06-24-2016, 10:33 PM   #4
Forum Member




Join Date: Apr 2012
Location: Colorado
Posts: 75
Original Poster
Yes, it is firmly closed.. No sign of any issues what so ever. There are no dents/dings or any signs of droppage.

---------- Post added 06-24-16 at 11:35 PM ----------

I tried multiple SD cards and as I said, my other Pentax (K5-ii) will flash a brief LED light on the back when you insert an SD card, before the SD card door is closed. On the K3, nothing.

06-24-2016, 11:04 PM   #5
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,832
My K-3 flashes a light on the back (normally) when I insert SD card just like you describe your k-5ii doing.
06-24-2016, 11:40 PM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,433
Are you saying you think the K-3 took on water at some point during the trip?


Steve
06-25-2016, 12:03 AM   #7
amateur dirt farmer...
pepperberry farm's Avatar

Join Date: Dec 2014
Location: probably out in a field somewhere...
Photos: Gallery | Albums
Posts: 7,875
QuoteOriginally posted by stevebrot Quote
Are you saying you think the K-3 took on water at some point during the trip?


Steve
or the daughter did something unreported to the camera?
06-25-2016, 02:01 AM   #8
Veteran Member




Join Date: Mar 2009
Location: Australia
Photos: Gallery | Albums
Posts: 373
QuoteOriginally posted by HomeMadeSin Quote
the daughter is just as surprised as I am
Now that the first phase of the investigation has concluded, I'd be going back to the witness statement.

06-25-2016, 05:08 AM   #9
Pentaxian
D1N0's Avatar

Join Date: May 2012
Location: ---
Photos: Gallery
Posts: 4,349
Something is decidedly wrong. Hope you still have warranty.
06-25-2016, 08:01 AM   #10
Forum Member




Join Date: Apr 2012
Location: Colorado
Posts: 75
Original Poster
No water issues and honestly I used the camera a couple weeks before with no problems. She used it for school, but has not used since graduating - I guess that makes me the last user. And honestly, I forgot how good that camera is(was).
06-25-2016, 03:32 PM   #11
Senior Member
semaca's Avatar

Join Date: Nov 2014
Location: RO
Posts: 140
Hmmm...Last week I really got the camera wet...really wet. At first it was ok, but after that cold shower I went into the sun and soon after the battery was dead. New battery got the camera back on, but then it died again. And again with the third one. In my case I think it was some condensation inside the battery compartment. I have cleaned the contacts with a tissue and left the door open over the night and now it's ok.
But this was my case...

PS: I will post the short movie soon
06-25-2016, 09:41 PM   #12
Senior Member




Join Date: Oct 2008
Location: Prince George, British Columbia, Canada.
Posts: 129
Sounds like maybe somebody did a firmware update with a low battery,
06-25-2016, 10:15 PM   #13
Forum Member




Join Date: Apr 2012
Location: Colorado
Posts: 75
Original Poster
QuoteOriginally posted by BCtoad Quote
Sounds like maybe somebody did a firmware update with a low battery,
Only possible if it takes 3 months to brick...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
card, daughter, dslr, k-3, k3, k5ii, pentax k-3, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: KatzEye Focus Screen for K-3 (K-3, K-5, K-5II, K-7, K-30, K-50, K-500), New or LN fwcetus Sold Items 15 05-07-2016 08:01 PM
Yeah, it's not a pentax lens... but I will make sure to enjoy my new paperweight. Auzzie-Phoenix Pentax SLR Lens Discussion 13 04-16-2016 06:40 AM
A $98 Pentax Paperweight JeffJS General Talk 14 09-21-2010 05:12 AM
Did my 77ltd just become a paperweight? kristoffon Pentax SLR Lens Discussion 11 09-14-2009 06:19 PM
Looking Through a Paperweight Mike Cash Post Your Photos! 2 10-08-2007 06:31 AM



All times are GMT -7. The time now is 05:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top