Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2016, 01:02 PM   #1
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,160
Metz 58-AF-2 goes off by itself using HSS

I updated the firmware on my Metz today, so I can use HSS - beside that, I haven't used the Metz for a long time.

In P-TTL HSS mode and only in this mode, the flash behaves as if it's shot circuiting: it will trigger on it's own and if I twist and turn the flash (hotshoe), it flashes more frequently - however I haven't found a clear pattern and as mentioned, it only does this using HSS.

Sometimes it doesn't trigger at all when I take a picture, and it's not because the flash is charging. This happens also only when using HSS.

Has anyone else had similar issue?

09-13-2016, 01:07 PM   #2
Pentaxian
mattb123's Avatar

Join Date: Apr 2010
Location: Colorado High Country
Photos: Gallery
Posts: 7,406
I think I have seen mine (58 AF-2) do this and I also updated the firmware. I don't use it a lot but when I do I'll see if I can pinpoint any more correlation.
09-13-2016, 01:32 PM   #3
MSL
Pentaxian
MSL's Avatar

Join Date: Feb 2012
Location: Greater Toronto Area
Photos: Albums
Posts: 3,383
Which camera and which version of firmware? There have been a lot of issues with the Metz over the years...
One earlier thread I found talked about double shots occurring for example.
09-13-2016, 01:50 PM   #4
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,160
Original Poster
I'm using K-3 II and firmware version 5.0 on the flash.

I had issues related with K-30 back in the days too. I can't remember if it was HSS only too, or something more, but had to wait quiet a while before they had an firmware update.

Looking at the changes history, there a jump from 2013 (K-30 and K-5 II) to 2016 (K-1). K-3/II isn't mentioned anywhere
Save


09-13-2016, 01:57 PM   #5
Pentaxian
mattb123's Avatar

Join Date: Apr 2010
Location: Colorado High Country
Photos: Gallery
Posts: 7,406
I just updated to use with the K-1 and hadn't noticed the random flashes before then.
09-13-2016, 02:01 PM   #6
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,160
Original Poster
I had forgotten about the firmware for the camera and just updated that too. The flash behavior didn't improve

mattb123: So it worked fine before the update? That sucks

Save
09-13-2016, 02:09 PM   #7
Pentaxian
mattb123's Avatar

Join Date: Apr 2010
Location: Colorado High Country
Photos: Gallery
Posts: 7,406
QuoteOriginally posted by Zafar Iqbal Quote
I had forgotten about the firmware for the camera and just updated that too. The flash behavior didn't improve

mattb123: So it worked fine before the update? That sucks

Save
Not on the K-1, it wouldn't fire much of the time. Now that is better but I did notice some random flashes when I used it last. Still better than before the update.
09-13-2016, 02:19 PM   #8
Pentaxian
RAART's Avatar

Join Date: Apr 2013
Location: Oakville, ON
Photos: Gallery
Posts: 876
It looks like that Metz has again this problem. I had the same behaviour happen with K-3 and Metz 52... I reported that to Metz Deutschland and on my behalf they modified firmware to eliminate this. Here are some of the emails with them... just the relevant ones...

---------------------------------------------------------------------

Thank you very much for your e-mail and for details.

In the meantime we forwarded your e-mail to our development department.
Now, we also found that flash unit fires randomly by itself, however this happens very very seldom here.
To solve this problem we guess flash unit’s firmware needs to be improved. However, this may take some time. Unfortunately, a fast solution of this problem is not possible.

We will you inform by e-mail as soon as a new firmware version for your flash unit is available.

With kind regards

Wolfgang Becker
Technical Support


----------------------------------------------------------

As of now a new firmware version (1.3) for the flash unit mecablitz 52 AF-1 digital for Pentax is available by which the mentioned problem is solved. This new firmware can be downloaded from our homepage by following link:

http://www.metz.de/en/flash-units/firmware-download-flash-units/mecablitz-52...al/pentax.html
Best regards

i.A. Roland Laemmermann
Technical Support


--------------------------------------------------------------------------

It took them around 3 months to solve this. I had did also some tests with various lenses and submitted the results to them which helped them isolate the problem. I do not have K-1 or the Metz 58 to be more helpful with this.

The volks at Metz are good and if reported properly, backed up with solid and exact behaviour reference point they will take it right away into development centre for the resolution


Last edited by RAART; 09-13-2016 at 02:28 PM.
09-13-2016, 02:38 PM   #9
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,160
Original Poster
I wrote to Metz too, back when I had K-30. I think it took longer but they got back to me with an update and it solved the issue I was having at that time.

Now I'm just thinking, the K-3/II have been out for a while and apparently no-one has made them aware of this issue in all that time.

I'll send them an e-mail.

Edit: Done - e-mail sent.

Last edited by Zafar Iqbal; 09-13-2016 at 02:43 PM.
09-13-2016, 06:59 PM   #10
MSL
Pentaxian
MSL's Avatar

Join Date: Feb 2012
Location: Greater Toronto Area
Photos: Albums
Posts: 3,383
Any chance you've got the Metz set up as a Master? It seems there are limitations on using HSS and the Metz as a master, at least from my quick reading of a thread on a different site.
09-13-2016, 08:49 PM   #11
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,160
Original Poster
No, it's set to Off
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dslr, flash, hss, k-3, k3, metz, metz 58-af-2, mode, pentax k-3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Metz 58 AF-2 as off-camera flash dr_romix Flashes, Lighting, and Studio 4 08-15-2016 04:03 PM
Metz 58 AF-2, HSS and Controller Sol Invictus Pentax Camera and Field Accessories 10 07-31-2012 10:27 AM
Using the Metz 58 AF-2 in Wireless mode ollie31770 Pentax K-5 3 03-21-2012 04:23 PM
Metz 58 AF-2 and Wireless HSS 5shot Flashes, Lighting, and Studio 2 01-07-2011 08:14 PM
Pentax K20D and Metz 58 AF (HSS Mode) jasper Flashes, Lighting, and Studio 7 01-22-2009 02:41 PM



All times are GMT -7. The time now is 07:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top