Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-09-2016, 05:39 AM   #1
Junior Member




Join Date: Sep 2007
Location: Central Ohio
Posts: 31
K3 Grip AF button not working

Had my K3 with grip and Tamron 70-200 out yesterday and the grip af button would not engage autofocus... AF button on body worked fine, just not the af button on the grip... Any ideas?

Thanks - Roger

10-09-2016, 06:37 AM   #2
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,223
Did you have the grip turned to on? On/off is located where the shutter button is on the grip in case you don't know.
10-09-2016, 06:41 AM   #3
Junior Member




Join Date: Sep 2007
Location: Central Ohio
Posts: 31
Original Poster
QuoteOriginally posted by Oldbayrunner Quote
Did you have the grip turned to on? On/off is located where the shutter button is on the grip in case you don't know.
Yep. Grip turned on. Tried a couple other lenses. Gave the contacts (camera and grip) a wipe/rub with a lens cloth. Contacts appear clean and normal.
10-09-2016, 11:34 AM   #4
New Member
mikec100z's Avatar

Join Date: Aug 2011
Location: Calgary
Posts: 17
I had a similar problem some years ago on a k20. turned out that one of the pins in the grip was not contacting the body properly. Check to see if all the pins are the same height. I would depress them all then make sure they come back to the same height so they contact the body properly.

10-10-2016, 06:20 AM   #5
Junior Member




Join Date: Sep 2007
Location: Central Ohio
Posts: 31
Original Poster
Thanks guys. Culprit was dirty contacts. Took an isopropyl alcohol swab to the contacts and pins, let it air out and gave it another try. All is well. Thanks.

Roger
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, button, dslr, grip, grip af button, k-3, k3, k3 grip af, pentax k-3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery grip not working on K5IIs Gampa Troubleshooting and Beginner Help 7 05-18-2016 03:23 PM
Battery grip not working with AA lotech Pentax K-3 9 04-28-2016 06:43 AM
Samyang 10mm not working with k3 NIGEL PETERSON-WHITE Visitors' Center 7 01-14-2015 03:44 PM
K-r will not take photos, shutter button not working - HELP! seattledotcom Troubleshooting and Beginner Help 8 06-08-2011 04:19 PM
K1000 shutter button not working?! jzietman Pentax Film SLR Discussion 2 11-01-2010 09:41 PM



All times are GMT -7. The time now is 02:01 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top