Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-26-2017, 07:27 AM   #1
Loyal Site Supporter
Loyal Site Supporter




Join Date: May 2016
Location: East Coast
Posts: 2,515
K3II Mirror Flap

So, I was merrily taking pictures in single shot mode the other day, and suddenly my mirror went nuts flapping. I'd say it lasted 2-3 seconds. By the time I took the camera away from my eye and lowered it to look at the back screen, it had stopped. I was using an M42 mount lens in Av mode, and the camera was now prompting me to input the focal length like I had just turned it on. I hit the "OK" button on the displayed focal length, and went about my way, and it did not repeat. I had a Pentax brand battery in it with at least 3/4 charge, if not more. I've got the latest firmware update, and my S/N is 6295621, so I think it is after the initial release that I believe did have some issues. I've taken upwards of 10K trouble free shots with the camera, so I'm thinking this is a one time anomaly, but I am wondering what others have experienced and any input on the situation?

Thanks

03-26-2017, 08:39 AM   #2
Senior Member
Alnjpn's Avatar

Join Date: May 2015
Location: Osaka
Posts: 134
How old is your battery? This happened to my secondhand k3 with the old battery but hasn't happened since I replaced it - fingers crossed.
03-26-2017, 09:18 AM   #3
Senior Member




Join Date: Feb 2012
Photos: Gallery
Posts: 142
it happened to me once, or twice. But I remember it the first time. It was when camera was 2 months in use (first firmware installed). I had sigma 17-50 mounted. Original full charge battery. And it lasted exactly how you described it. I just ignored it and continued on with the session. I do not know what to think of it.
03-26-2017, 09:23 AM   #4
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,417
It happens with the k-3. Make sure your firmware is up to date. If I remember correctly there was an update that reset the camera if this happened thus stopping it. I used my k-3 for several years with around 40,000 images and had it happen twice.

If it starts happening regularly you will need to send it in for service but once only I would not worry about it at all. But it is really scary when it happens.

03-26-2017, 10:26 AM   #5
Senior Member
screwdriver222's Avatar

Join Date: Oct 2011
Location: Plymouth
Photos: Gallery | Albums
Posts: 139
This happened to me only once on a K-3 when I had a Sigma 10-20 attached and I had to remove the battery to stop it. It was just before the new firmware came out to reduce/stop it.
03-26-2017, 11:57 AM   #6
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 15,542
I had the mirror flap once or twice on my K-3. The first time, the mirror got stuck half way through its cycle when I took the battery out and I had to help it back into position. That was worrying The second time, if I remember correctly, was shortly after a firmware update... I got the short, rapid burst of flapping and then it sorted itself out. Two occasions out of many thousands of shots... I can live with that
03-26-2017, 12:08 PM   #7
Loyal Site Supporter
Loyal Site Supporter




Join Date: May 2016
Location: East Coast
Posts: 2,515
Original Poster
QuoteOriginally posted by Alnjpn Quote
How old is your battery? This happened to my secondhand k3 with the old battery but hasn't happened since I replaced it - fingers crossed.

The battery is probably close to a year old. I've got three OEM Pentax batteries, and two after market ones. I rotate them following a FIFO sequence on use and charging, so I don't think it's had that many clicks on it, but I can put a mark on this one to track it so if it happens again, I can see if it's the same battery or not.

This is all sounding hopeful that it's a one time thing.

Thanks for all the input.

Last edited by clickclick; 05-22-2017 at 08:18 AM.
03-26-2017, 12:38 PM   #8
Site Supporter
Site Supporter




Join Date: Aug 2015
Location: Alabama
Photos: Gallery
Posts: 421
May be check this:
Pentax K-3 II Service Advisory - Pentax Announcements | PentaxForums.com

04-07-2017, 05:00 AM   #9
Pentaxian




Join Date: Aug 2013
Location: Iloilo City
Photos: Gallery
Posts: 2,136
This is an old issue with only a few reported incidents. It happened to mine once and never happened again (fingers crossed). However, it's different compared to the K-3 mirror flap issue. The service advisory referred by bwgv001 is about unresponsive on/off switch regardless of camera settings and consistent freezing when accessing the GPS menu. I don't know if this has anything to do with the K-3II's mirror flap issue. I also don't know if the latest firmware update for the PLM lenses includes correction for this error. I myself am hoping that this is nothing serious. So far, like I said, it hasn't happened again.
05-21-2017, 11:40 AM   #10
Pentaxian




Join Date: Jan 2012
Photos: Gallery | Albums
Posts: 1,246
I just experienced the dreaded mirror flapping on my secondhand K3II. Is this a major problem for some people or is it typically a rare event?
05-21-2017, 01:19 PM   #11
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 15,542
QuoteOriginally posted by Mr Bassie Quote
I just experienced the dreaded mirror flapping on my secondhand K3II. Is this a major problem for some people or is it typically a rare event?
Typically very rare
05-21-2017, 02:45 PM   #12
Pentaxian




Join Date: Jan 2012
Photos: Gallery | Albums
Posts: 1,246
QuoteOriginally posted by BigMackCam Quote
Typically very rare
Thank you. Since I posted that message I had the camera lock up on me. I had to remove the battery and that seemed to fix it. I wonder if I got a lemon.
05-21-2017, 10:33 PM   #13
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 15,542
QuoteOriginally posted by Mr Bassie Quote
Thank you. Since I posted that message I had the camera lock up on me. I had to remove the battery and that seemed to fix it. I wonder if I got a lemon.
Have you updated it to the latest firmware?
05-22-2017, 08:21 AM   #14
Loyal Site Supporter
Loyal Site Supporter




Join Date: May 2016
Location: East Coast
Posts: 2,515
Original Poster
If it happens again, I'd also swap out the battery.

So far, I've only had the one occurrence of flap I originally posted about.
05-29-2017, 11:47 PM   #15
Junior Member




Join Date: Dec 2008
Location: Ashford, Kent
Posts: 40
It happened to me on holiday in New Zealand. My K3ii is about 8 months old on the latest firmware. Only happened once.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, input, k-3, k3, k3ii mirror, length, mirror, pentax k-3, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k3ii "mirror flap" when battery is low TroutHunterJohn Pentax K-3 16 12-08-2017 03:37 PM
Any reports of mirror flap on the K3 II? Fat Albert Pentax K-3 30 10-02-2017 03:07 PM
k-3 mirror flap to death Stargeezer Pentax K-3 51 10-15-2015 04:45 PM
K-3 Mirror Flap - Was It Ever Cured? Biro Pentax K-3 30 06-30-2015 04:45 PM
K3 Owners with No Mirror Flap Problem Little Ray Pentax K-3 46 10-13-2014 02:21 AM



All times are GMT -7. The time now is 01:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top