Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-18-2017, 09:11 AM   #1
New Member




Join Date: Apr 2013
Location: Toronto
Posts: 14
K-3 locks up

I have a K-3, and use the Auto Focus button on the back. Sometimes in Live View , the camera won't auto focus, and the screen locks up. Even when I move the dial to Off, the image remains on the screen. I can get the camera back to normal if I remove the battery, and put it in again. This happens most often with my 16-45mm lens.
Is there a way of getting around this problem?
Thanks

09-18-2017, 09:53 AM   #2
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 32,706
The conventional response is to ask about your batteries. Are they fully charged? How has battery life been (does it drain quickly)? Are you powering through the grip?

Live view creates a significant draw on the battery as does running the AF motor. Powering sensor, rear LCD, and motor simultaneously may result in a transient voltage drop below the tolerance of the camera main board. The same might also happen if the built-in flash were used.


Steve
09-18-2017, 10:14 AM   #3
Loyal Site Supporter
Loyal Site Supporter
Crooski's Avatar

Join Date: Feb 2013
Location: Rozenburg , Zuid-Holland
Photos: Gallery
Posts: 2,179
did you install the latest firmware ?
09-18-2017, 05:49 PM   #4
New Member




Join Date: Apr 2013
Location: Toronto
Posts: 14
Original Poster
[quote=stevebrot;4094618]The conventional response is to ask about your batteries. Are they fully charged? How has battery life been (does it drain quickly)? Are you powering through the grip?

Live view creates a significant draw on the battery as does running the AF motor. Powering sensor, rear LCD, and motor simultaneously may result in a transient voltage drop below the tolerance of the camera main board. The same might also happen if the built-in flash were used.


Thanks. The batteries are fairly well-charged, but I think I will order new ones. I alternate two batteries and have used them for about a year. I don't use a grip and almost never use flash.




Last edited by philosopher1123; 09-19-2017 at 03:17 AM.
09-18-2017, 07:17 PM   #5
New Member




Join Date: Apr 2013
Location: Toronto
Posts: 14
Original Poster
QuoteOriginally posted by Crooski Quote
did you install the latest firmware ?
Thanks. I am using v1.30 of the firmware. I think it is the latest version.
09-23-2017, 11:15 AM   #6
New Member




Join Date: Dec 2016
Location: Reinholds, Pennsylvania
Posts: 16
QuoteOriginally posted by philosopher1123 Quote
I have a K-3, and use the Auto Focus button on the back. Sometimes in Live View , the camera won't auto focus, and the screen locks up. Even when I move the dial to Off, the image remains on the screen. I can get the camera back to normal if I remove the battery, and put it in again. This happens most often with my 16-45mm lens.
Is there a way of getting around this problem?
Thanks
I've had this problem, but seem to have resolved it. I'm using a K-3ii with battery grip. I changed the option for battery selection to "automatic" - prior to that I had it set to use the grip battery first. I don't know why, but it hasn't happened to me since,
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, dslr, focus, k-3, k-3 locks, k3, locks, pentax k-3, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K 5 "locks up"?? grhazelton Troubleshooting and Beginner Help 10 05-13-2017 01:51 PM
Using Astrotracer with K3II locks up with exposures over about 40 sec ddbarchitect Pentax K-3 2 05-10-2016 02:50 PM
Brand new K-3 locks up during picture playback mode wabibito Troubleshooting and Beginner Help 11 11-04-2015 09:19 AM
K-50 continually locks up / freezes snej Troubleshooting and Beginner Help 3 10-17-2015 09:03 PM
K20 D Locks up flashpete Troubleshooting and Beginner Help 5 10-25-2011 08:12 PM



All times are GMT -7. The time now is 05:33 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top