Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2018, 12:16 AM   #31
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,423
Original Poster
OK this gets really weird now, I haven't had a lot of time for things photographic lately but last weekend I decided to see if there were any remnants of my Gimp 2.8 install lurking after it was uninstalled, So a quick search through the registry found lots of instances of gimp 2.8. I decided to unistall gimp 2.10.06 so no more gimp on my system at all. I then went through the registry and removed any keys with ref to gimp 2.8 or 2.10, After that I reinstalled 2.10.06, loaded up a JPG file & checked exif - all there as expected, I then exported the file and rechecked exif in gimp and it was there ! normally what would have happened is the exif would not have been there after the export command had been executed (viewing the exif data in gimp it would be no longer there).

this is promising I thought. So I checked the file properties in windows and all the exif was in tact, finally I thought, that's sorted. However, the next day when I tried the same process the exif data was not contained in the exported JPG, although strangely reading within gimp after export the exif is still there, where as before the registry clean up & reinstall it was gone after export. Just to remind people this only happens with Pentax JPG files, Sony, Nikon and Canon JPG files are all ok with exif fully intact.

---------- Post added 09-21-18 at 06:08 PM ----------

NOW THIS WILL GET YOUR INTEREST - So I right click my Pentax JPG file and go Properties / details and all exif intact as expected, I click on "Camera Make" and change it from "PENTAX" to "Nikon". I open the file in gimp view meta data and check camera make = "Nikon" I export the file and inspect the properties and all the exif data is there ! it all works as expected .....go figure, It's Like the word Pentax has been left of a list of manufacturers or something !


Last edited by Cee Cee; 09-21-2018 at 01:28 AM.
09-21-2018, 01:27 AM   #32
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,423
Original Poster
the very latest... So I edit the camera make from "PENTAX" to "Pentax" before opening in gimp and exporting works fine with all the exif data intact. The 3 cameras I have all have "PENTAX" as the camera make (K30, K20D, OptioE40) I wonder if later models have the word "Pentax"
well at least this gives me a work around, any photos I want to process I'll just have edit the exif to "Pentax" before starting. Good thing I don't take too many good photos.
I'll have to try "NIKON" and see what happens.
09-21-2018, 10:34 PM   #33
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,676
Well like I said before, report it on the GitHub for Gimp. Seems like an easy enough fix. Either to a case in-sensitive match or and an "or" for both cases.
09-22-2018, 07:00 AM   #34
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,423
Original Poster
QuoteOriginally posted by Not a Number Quote
Well like I said before, report it on the GitHub for Gimp. Seems like an easy enough fix. Either to a case in-sensitive match or and an "or" for both cases.
I have submitted a report.

after more tests it seems the exif "Camera Make" can be any thing you like or even nothing at all and it works fine, but just not the word "PENTAX", which was what was used up until the K5 after that it's "RICOH IMAGING COMPANY, LTD"

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
click, data, exif, export, features, file, files, gimp, home, issue, jpegs, jpg, linux, pentax, performance, photography, post, properties, registry, tiff, w10, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gimp 2.10 is out! Zelig Digital Processing, Software, and Printing 9 05-01-2018 09:04 PM
Night Post processing in Rawtherapee & Gimp Kodiak Photo Critique 3 10-28-2017 12:48 AM
Can new Windows 8 desktop be loaded with Windows 7? barondla Digital Processing, Software, and Printing 8 08-19-2013 10:13 AM
GIMP 2.6.12 vs. GIMP 2.8.0 Vasyl Digital Processing, Software, and Printing 13 06-19-2012 02:00 PM
Windows users: upgrading to windows 7? bonovox General Talk 56 11-09-2009 07:55 AM



All times are GMT -7. The time now is 04:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top