Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2018, 06:53 AM   #1
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
"PENTAX" vs "Pentax" in exif

I've been struggling with the latest GIMP 2.10.6 removing the exif data when I export jpg files from gimp. Anyhow after lots of trial & error I've figured out that Gimp 2.10.6 doesn't like the Camera Maker data in capitals ie. "PENTAX" however if you edit the data using windows file properties / details and change it to "Pentax" it all works fine. Mind you the SONY, NIKON, CASIO, CANON files seem ok with capitals or lower case.

So my Pentax cameras K30, K20D,Optio40 and probably istDS (but I haven't looked at this) all use capitals In the "Camera Maker" field. I'm wondering if later models use "Pentax" which may explain why I'm not hearing of this problem from others.

edit: I've been looking at exif data in photo sharing forum, K5 is "PENTAX" after that its "RICOH IMAGING COMPANY, LTD"


Last edited by Cee Cee; 09-21-2018 at 07:08 AM.
09-21-2018, 08:29 AM   #2
New Member
Dakobed's Avatar

Join Date: Feb 2017
Posts: 5
For pictures taken with my K-70, the camera maker field is all caps. i.e "PENTAX K-70" It is in all caps both before and after export.
09-21-2018, 03:28 PM   #3
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
Original Poster
QuoteOriginally posted by Dakobed Quote
For pictures taken with my K-70, the camera maker field is all caps. i.e "PENTAX K-70" It is in all caps both before and after export.
It may depend on what your using to view the exif as to Camera Make & Camera Model, the K70 files I view here have "PENTAX K-70" in the Camera Model, as does the K30 exif say "PENTAX K-30" this doesn't seem to be an Issue, rather it's Camera Make field which is the issue, I think there the K70 says "RICOH IMAGING COMPANY, LTD"

I've since discovered that anything other than "PENTAX" in capitals will work eg. If I change to Nikon or NIKON it works fine, in fact I can leave it blank and it works, but if it's "PENTAX" with all capitals then all the exif data is missing from the exported image
09-21-2018, 06:26 PM   #4
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
Original Poster
So I issue a challenge to any one running GIMP 2.10.x on Windows 10 to edit exif on a jpg file (rick click file - properties/details ) the change the camera make from " RICOH IMAGING COMPANY LTD" to "PENTAX" all capitals then load the file into gimp and export the file, check the properties of the exported file in windows or reload that image back into gimp and see if the file still contains exif data.

09-21-2018, 06:37 PM   #5
retired sw engineer
Loyal Site Supporter
reh321's Avatar

Join Date: Nov 2014
Location: South Bend, IN, USA
Photos: Gallery | Albums
Posts: 16,939
QuoteOriginally posted by Cee Cee Quote
So I issue a challenge to any one running GIMP 2.10.x on Windows 10 to edit exif on a jpg file (rick click file - properties/details ) the change the camera make from " RICOH IMAGING COMPANY LTD" to "PENTAX" all capitals then load the file into gimp and export the file, check the properties of the exported file in windows or reload that image back into gimp and see if the file still contains exif data.
I have done your test on my Linux system, and it seems to show the same results you got. With "PENTAX" as camera brand, EXIF is missing or truncated from exported result {I'm having trouble telling which}; with "Pentax" as camera brand, EXIF is fine.
09-21-2018, 07:26 PM   #6
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
Original Poster
QuoteOriginally posted by reh321 Quote
I have done your test on my Linux system, and it seems to show the same results you got. With "PENTAX" as camera brand, EXIF is missing or truncated from exported result {I'm having trouble telling which}; with "Pentax" as camera brand, EXIF is fine.
thanks for your input, I thought I was going mad for a while as I couldn't understand how anybody else wasn't having this problem. . All my files are "PENTAX" but at least I have a work around now by replacing or removing the Camera Make on the files I edit in Gimp. Cheers.
09-21-2018, 07:36 PM   #7
retired sw engineer
Loyal Site Supporter
reh321's Avatar

Join Date: Nov 2014
Location: South Bend, IN, USA
Photos: Gallery | Albums
Posts: 16,939
QuoteOriginally posted by Cee Cee Quote
thanks for your input, I thought I was going mad for a while as I couldn't understand how anybody else wasn't having this problem. . All my files are "PENTAX" but at least I have a work around now by replacing or removing the Camera Make on the files I edit in Gimp. Cheers.
Have you filed a bug report with gimp?
09-21-2018, 10:45 PM   #8
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
Original Poster
QuoteOriginally posted by reh321 Quote
Have you filed a bug report with gimp?
I tried but it was late at night and I had to sign up and was waiting for confirmation email & password but eventually had to give up on it, but I don't think it ever came
I'll have to try again now that the nature of the glitch has been narrowed down somewhat. I posted something on the gimpuser site but got little response.

09-22-2018, 06:51 AM   #9
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,399
Original Poster
Report now submitted
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
capitals, data, exif, files, gimp, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 vs MZ-S vs LX vs PZ-1p vs ist*D vs K10D vs K20D vs K-7 vs....... Steelski Pentax K-5 2 06-28-2017 04:59 PM
"sensor size" EXIF vs published value for photogrammetry danielmerrick Troubleshooting and Beginner Help 3 03-27-2017 01:02 PM
O-GPS1 and your EXIF data - When the GPS is on, it strips data from the EXIF? Sagitta Troubleshooting and Beginner Help 17 11-23-2016 02:25 AM
Enthusiast vs Prosumer vs Semi Pro vs Pro vs APSC vs Full Frame mickyd Pentax DSLR Discussion 10 11-12-2013 07:14 PM
77ltd vs Cosina 55 1.2 vs Helios 58 vs Vivitar 28 CF vs DA 35 jsherman999 Pentax SLR Lens Discussion 18 04-26-2009 12:32 PM



All times are GMT -7. The time now is 02:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top