Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
5 Days Ago   #1
Junior Member




Join Date: Jan 2012
Location: stroud,
Posts: 35
access to pentax user

has any brit , or anyone else for that matter, on here had troubles signing in to that site. have tried yesterday and today but cannot get past the log in page. If i have upset the Pentax Police i would at least like to know how.

5 Days Ago   #2
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 16,960
Which site are you referring to? Please post a link.
5 Days Ago   #3
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by MarkJerling Quote
Which site are you referring to? Please post a link.
This one? Works for me.
https://www.pentaxuser.com

5 Days Ago   #4
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 16,960
Aha! Works for me too.

5 Days Ago   #5
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by MarkJerling Quote
Aha! Works for me too.
I take it back, I can't log in.



---------- Post added 11-24-21 at 10:45 AM ----------

I even tried getting a password reset and still can't log in.
5 Days Ago   #6
Junior Member




Join Date: Jan 2012
Location: stroud,
Posts: 35
Original Poster
Seems to be a fault their end then
5 Days Ago   #7
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by redbusa Quote
Seems to be a fault their end then
If @MarkJerling really can log in maybe he can ask about it.



5 Days Ago   #8
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 16,960
Odd. Works for me, logging on also.
5 Days Ago   #9
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by MarkJerling Quote
Odd. Works for me, logging on also.
Are you on a phone or PC? I haven't tried from a PC yet.

5 Days Ago   #10
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 16,960
There is a thread on the forum about some users struggling to log in, but that was end of September. The suggestion was to reset browser history and cookies. That appears to have solved the issue for users there who were having issues. Perhaps you guys can try that?
5 Days Ago   #11
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 16,960
QuoteOriginally posted by slartibartfast01 Quote
Are you on a phone or PC? I haven't tried from a PC yet.
PC. Win10, Edge browser.
5 Days Ago   #12
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by MarkJerling Quote
There is a thread on the forum about some users struggling to log in, but that was end of September. The suggestion was to reset browser history and cookies. That appears to have solved the issue for users there who were having issues. Perhaps you guys can try that?
I see you have proved you can log in by posting . I wonder if a new account works and older accounts don't.

5 Days Ago   #13
Junior Member




Join Date: Jan 2012
Location: stroud,
Posts: 35
Original Poster
Will try that, thanks
5 Days Ago   #14
Pentaxian




Join Date: May 2015
Photos: Gallery
Posts: 1,234
QuoteOriginally posted by redbusa Quote
Will try that, thanks
Any luck, I can't log in from a PC or a phone.

5 Days Ago   #15
Site Supporter
Site Supporter
sarge's Avatar

Join Date: Feb 2016
Location: Illinois
Photos: Gallery | Albums
Posts: 370
I was able to log in.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
access to pentax, email, issue, log, pentax, pentaxuser, photography, report
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax KP playback crashes with orange card access light on VE950 Troubleshooting and Beginner Help 10 11-22-2021 06:13 AM
KS2 User 1 and User 2: Unique Display Color Selection Won't Save in Each User Mode. chimpit! Troubleshooting and Beginner Help 2 06-07-2017 08:10 PM
Hello folks, old GR user and 645 user - new GRV user and 645Z user, coming fr Leica. bilbrown Welcomes and Introductions 3 02-28-2016 03:59 AM
K3 - User 1, User 2, User 3... hjoseph7 Pentax K-3 & K-3 II 14 01-21-2015 02:57 PM
For Sale - Sold: Tamron 75-250mm, Access 35-70mm f/2.5-3.5, Access 70-210mm f3.5, Kenlock 80-20 hinman Sold Items 14 03-20-2010 12:25 PM



All times are GMT -7. The time now is 08:45 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top