Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-10-2018, 03:24 AM   #31
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2009
Location: Gladys, Virginia
Photos: Gallery
Posts: 25,375
Probably simply a weight issue. The K-S1 is very light and if you attach a heavier lens or even a flash, it probably dampens some of the shutter shock issues. Those who have reported it with the K-1 seem to think that the DFA 28-105, for some reason, is worse than the other DFA zooms.

03-10-2018, 07:27 PM   #32
Forum Member
alex-virt's Avatar

Join Date: Jun 2014
Photos: Albums
Posts: 56
Original Poster
QuoteOriginally posted by ShawnH Quote
Is it possibly a lens element vibration issue?
I don't think so. It happens with different lenses.
04-27-2018, 08:52 AM   #33
Senior Member




Join Date: May 2011
Posts: 126
QuoteOriginally posted by alex-virt Quote
I recently bought a second K-S1 body with two kit zooms (18-55 and 50-200) and a small AF-200FG flash. Couldn't resist a great offer from the Canadian Ebay.
I can confirm that with the flash attached there is no shutter shock at 1/100s.
it has the same characteristics of k7 issue. With BG mounted on, the problem is reduced.
There will be a sort of resonance frequency giving blur as result.
05-30-2018, 12:45 PM   #34
Forum Member
alex-virt's Avatar

Join Date: Jun 2014
Photos: Albums
Posts: 56
Original Poster
Update: No shutter shock with the 70mm/F2.4 Limited lens.

05-31-2018, 10:06 AM   #35
Forum Member




Join Date: May 2017
Posts: 60
It could be that your lens mount on your camera is somehow loose. That would explain why the viberation is lens dependent but not exclusive to one lens.
05-31-2018, 06:32 PM   #36
Forum Member
alex-virt's Avatar

Join Date: Jun 2014
Photos: Albums
Posts: 56
Original Poster
QuoteOriginally posted by ShawnH Quote
It could be that your lens mount on your camera is somehow loose. That would explain why the viberation is lens dependent but not exclusive to one lens.
I have two K-S1s both having similar vibration issues. It's highly unlikely for two cameras to have loose mounts.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, effect, images, k-s1, k-s2, kit, lens, mirror, owners shutter, pentax, pentax k-s1, pentax k-s1 owners, question to pentax, shock, shutter, slap, speeds, sr, vibration
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter vibration test derekkite Pentax K-3 & K-3 II 13 02-10-2015 12:36 PM
Pentax K-7 shutter vibration rrstuff Pentax DSLR Discussion 2 12-31-2014 12:58 PM
Question to Pentax 17-70 Owners phatio Pentax SLR Lens Discussion 8 09-09-2014 07:29 AM
K-r Shutter... vibration? teljalis Pentax K-r 9 03-21-2011 09:03 PM
Question to K-5 Owners kevinschoenmakers Pentax K-5 & K-5 II 3 10-19-2010 06:40 PM



All times are GMT -7. The time now is 05:48 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top