Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-04-2016, 02:27 AM   #1
New Member




Join Date: May 2016
Posts: 4
Dark LiveView when using external flash in Manual (K-S2)

Hello,
when the K-S2 is set in M mode, it darkens the LiveView display in order to simulate what the present exposition parameters will produce. Ok, this could be usefull (I personally prefer just histogram).
I don't know is there is any way to disable this feature when using a flash: when I use studio flashes (with wireless trigger), the camera have to be set obviously in M mode -- and, as it is not aware of all the flashes installed, the exposure seems to be extremely low -- and so the display is nearly black. Using LiveView is however extremely useful in this situation when the camera is on a tripod. So, just for the moment I need to focus (manually) I have to chenge the mode to one of the automatic modes, focus in LiveView, change again to M - mode, look at the model (hoping she is not outside the frame because the display is dark)... Really not a nice workflow.
What am I missing?
Any way to set off this display darkening -- or how to say to the camera "Yes, there is a flash (not-TTL), don't worry about exposure"?
Any idea?

05-04-2016, 03:47 AM   #2
Pentaxian




Join Date: May 2015
Location: New Orleans
Photos: Gallery
Posts: 411
There's a thread under k3 discussion about that yesterday called annoying live view blah blah. Last response says a fix about TAv and setting iso very narrow. I am going to try it out.
05-04-2016, 04:38 AM   #3
New Member




Join Date: May 2016
Posts: 4
Original Poster
Thank you, swanlefitte. The hack you mention sounds interesting, I will try it tonight...
So, it seems no option to switch off this feature on the horizon :-( However will also link my post to the thread you mention ( https://www.pentaxforums.com/forums/172-pentax-k-3/297162-annoying-liveview-b...ble-bug-4.html )
Anybody there has another solution? My hack is to turn the mode temporary to the Bulb mode (because it is just near M on the roller), then I focus, set the model etc. -- and before making the image I turn on the M again. But... you can imagine how many times I forget the B-mode set...
05-04-2016, 04:49 AM   #4
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,829
Right, I've been posting about this (annoying) behavior on K-3 and K-1. In short, there are two workarounds that seem to work:

1) If your lens has an aperture ring, take it off the A position and control the aperture using the ring rather than from the camera body. (Don't forget to also enable "Using Aperture Ring" in the custom menus, or the camera may refuse to fire.)
2) Set the camera to TAv mode and control ISO by setting a very narrow range of possible values - like say from 200 to 250 if you want to shoot ISO 250. (Note that the ISO setting will flash red because the camera mistakenly thinks the shot will be underexposed. Also, I don't think you'll be able to shoot ISO 100. It will bottom out at ISO 125, with a range of 100-125.)

At least with my K-3, both of these methods cause the dimming of the screen to be disabled. Here are the two previous threads about it: one and two.


Last edited by Doundounba; 05-04-2016 at 04:59 AM.
05-05-2016, 12:10 AM - 1 Like   #5
New Member




Join Date: May 2016
Posts: 4
Original Poster
So, I confirm that the TAv method (read: hack) works well on K-S2 fw 1.11, it solves effectively the problem, with the only minor issue that you are not able to use ISO100 (the narrowest option is setting ISO 100-200 -- so the camera will use ISO200 as it is convinced there is low light) -- I can live with it.
However, if someone from Ricoh is reading this thread, a firmware update with clear option for disabling the "exposure preview" feature will be highly appreciated.
05-05-2016, 04:32 AM   #6
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,829
QuoteOriginally posted by tomas.paier Quote
So, I confirm that the TAv method (read: hack) works well on K-S2 fw 1.11, it solves effectively the problem, with the only minor issue that you are not able to use ISO100 (the narrowest option is setting ISO 100-200 -- so the camera will use ISO200 as it is convinced there is low light) -- I can live with it.
However, if someone from Ricoh is reading this thread, a firmware update with clear option for disabling the "exposure preview" feature will be highly appreciated.
You might be able to go to ISO 125. Go to the custom menus, make sure "EV Steps" is set to 1/3 EV (this is the default) and then set "Sensitivity Steps" to "As EV Steps". You should now have access to ISO 125. This assumes the K-S2 has similar menus as the K-3...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dark, display, flash, flashes, focus, k-s1, k-s2, liveview, mode
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3II No Flash Mounted Using External Flash C_Jones Pentax K-3 13 09-18-2015 11:35 AM
K-S2 No sync pulse using M when above 1/160 fb_penpho Pentax K-S1 & K-S2 4 07-08-2015 05:04 AM
k-s2 external flash sync swanlefitte Pentax K-S1 & K-S2 8 05-20-2015 10:44 PM
K-r: built-in flash stopped working after using external flash wedge Troubleshooting and Beginner Help 7 01-12-2014 07:57 PM
K-x : manual focus using LiveView skb0 Pentax DSLR Discussion 2 02-09-2010 12:23 PM



All times are GMT -7. The time now is 04:41 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top