Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2016, 03:47 AM   #1
New Member




Join Date: Jul 2016
Posts: 10
Pentax K-S2 and Sigma 50-200mm F4-5.6 DC OS HSM lens

Hi there,

I recently purchased a K-S2 body, and am trying it out with my lens collection.

For some reason, my Sigma 50-200 4-5.6 HSM acts weird. It sometimes works, but very often it won't focus, and the indications in the viewfinder go berzerk.

The lens works flawlessly on my Samsung GX-10 (Aka Pentax K10d), and all my other lenses work fine on the K-S2 (although the Sigma is the only one with a built-in focus motor)

Anyone experienced something similar?

Regards,

Peter.

08-03-2016, 05:11 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,822
I'd contact Sigma to see if the lens needs a firmware update. I know that there can sometimes be issues specifically in live view.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-06-2016, 05:37 AM   #3
New Member




Join Date: Jul 2016
Posts: 10
Original Poster
QuoteOriginally posted by Adam Quote
I'd contact Sigma to see if the lens needs a firmware update. I know that there can sometimes be issues specifically in live view.
Don't think that is possible. At least, my lens is not mentioned in the list of compatible lenses for the Sigma USB dock, which is needed for updating firmware.
Anyway, I have updated the firmware in my K-S2 (was still the original 1.00 version). Maybe that helps. Can't check it right now, as I have lent the lens to my daughter.
08-06-2016, 01:40 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,822
QuoteOriginally posted by Peter van Baarle Quote
Don't think that is possible. At least, my lens is not mentioned in the list of compatible lenses for the Sigma USB dock, which is needed for updating firmware.
Anyway, I have updated the firmware in my K-S2 (was still the original 1.00 version). Maybe that helps. Can't check it right now, as I have lent the lens to my daughter.
That's for updating the firmware at home. Older lenses can only be updated by a Sigma service center, so I would still contact them to see what they say.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-07-2016, 10:20 AM   #5
New Member




Join Date: Jul 2016
Posts: 10
Original Poster
QuoteOriginally posted by Adam Quote
That's for updating the firmware at home. Older lenses can only be updated by a Sigma service center, so I would still contact them to see what they say.
Thanks. I have sent the supplier of the camera a mail, see how they can help.
In the mean time I did some more tests. Firmware update of the camera did not help.
Seems the problem only happens between certain focal lenghts (between approx. 90 and 100mm and 150 and 200mm. Outside these areas the lens works correctly.
Also, when passing the abovementioned positions, the image shifts a little bit vertical, and a mechanical sound is heard.
09-26-2016, 09:53 AM   #6
New Member




Join Date: Jul 2016
Posts: 10
Original Poster
Update:
Today I went to Sigma Benelux, who were able to update the firmware of the lens. That did solve my problem.
Lens works like a charm now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50-200mm f4-5.6 dc, dc os hsm, f4-5.6 dc os, focus, hsm, k-s1, k-s2, lens, pentax, sigma, sigma 50-200mm f4-5.6
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Sigma 50-200mm F4-5.6 DC OS HSM for Pentax K-Mount leonsroar Sold Items 0 10-13-2014 11:15 PM
For Sale - Sold: Sigma 50-200mm f/4-5.6 DC OS HSM for Pentax (Price Reduced Further) gstool Sold Items 12 03-14-2013 02:35 PM
Pentax DA 50-200mm f/4-5.6 ED (Used) or Sigma 50-200mm F4-5.6 DC OS HSM (New) toaruna Pentax SLR Lens Discussion 2 06-27-2012 04:45 AM
SIGMA 50-200mm F4-5.6 DC OS HSM spanky66d Pentax SLR Lens Discussion 2 09-22-2010 07:23 AM



All times are GMT -7. The time now is 01:41 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top