Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-24-2016, 12:09 AM   #1
New Member




Join Date: Aug 2016
Posts: 5
K-S2 wont turn on!

I recently took my camera out on a fishing expedition. It got some mist of salt water but I rinsed it off with clean water. I turned it on and viewed photos fine. 5 hours later I tried to turn it on and all I got was an orange light that either blinks and I hear some clicky noises or stays orange and does nothing. It stays orange even when the camera is in the OFF position. I rinsed it again when I got home in clean fresh water and let it dry. I turned it on and everything seemed to work fine then a couple minutes after it went back to the orange light. When I turn on the camera, I do not see anything on the LCD screen. There is a foggy, hazy viewfinder as well. Whats happening?

08-24-2016, 12:19 AM   #2
Moderator
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,101
Sorry to hear about this. Can I ask, what was the exact make and model of lens you had attached when you were got water on it, and when you rinsed it off?
08-24-2016, 12:27 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,631
Sounds like water got in. How did you rinse it?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-24-2016, 12:28 AM   #4
New Member




Join Date: Aug 2016
Posts: 5
Original Poster
QuoteOriginally posted by BigMackCam Quote
Sorry to hear about this. Can I ask, what was the exact make and model of lens you had attached when you were got water on it, and when you rinsed it off?
its the original kit lens. smc pentax dal 1:4-5.6 18-50mm DC WR RE lens

08-24-2016, 12:28 AM   #5
New Member




Join Date: Aug 2016
Posts: 5
Original Poster
QuoteOriginally posted by Adam Quote
Sounds like water got in. How did you rinse it?
i just rinsed it in the sink. ran water on top of it.

---------- Post added 08-24-16 at 12:33 AM ----------

i just turned it on again and it works (LCD screen shows stuff on it). however, the viewfinder is still hazy and when i press the shutter, the camera seems to try to focus but looking through the viewfinder, it is still hazy. when i turned it off again, i heard the lens making some gear sounds like its moving a lot. after about 15 seconds it turned off without the orange light coming back. i turned it back on and same thing, hazy view finder.
08-24-2016, 12:46 AM   #6
Moderator
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,101
OK... well, for now, I'd suggest you take the battery and SD card out, then put the camera (with the lens still fitted) into a plastic bag with a few of handfuls of dry, uncooked rice, loosely seal the bag and leave it somewhere warm (not hot!) and dry... The rice will absorb any moisture, but the process can take several days. If you can, I'd let it sit for a week, then test it again. If you still have a hazy viewfinder and/or the camera doesn't operate correctly, you'd need to send it for repair.

For future reference, remember that the K-S2 and the lens you mentioned are "WR" rated - weather resistant, not "water proof". That means under normal use, they are much less likely to get water inside, for instance if you're taking photographs in light rain - but it's still *possible* to get water inside. Regardless of videos you may see on youtube showing others dunking cameras in buckets of water or cleaning them off under the bathroom shower, that's not recommended.

Good luck, and let us know how you get on?

Last edited by BigMackCam; 08-24-2016 at 12:51 AM.
08-24-2016, 12:46 AM   #7
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,631
Put the camera in a bowl of rice overnight. With a bit of luck, that'll suck the moisture out and the camera will be back to normal.

Next time I wouldn't recommend putting the camera directly in the sink. Wiping it with a moist towel would be a better approach, since this wouldn't put any pressure on the seals.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-24-2016, 08:10 AM   #8
New Member




Join Date: Aug 2016
Posts: 5
Original Poster
i just turned it on after waiting overnight. turns on and everything, no orange light. focuses and there is no more hazy viewfinder. however i cant remember if i ever noticed hearing to focus motor. maybe im more keen to the sound because im wondering if there is anything wrong with my camera.

is there anything else you guys think i should do? sensor cleaning? going into the menu and using dust cleaning? ill be using it today to take pictures at kachemak state park so hopefully nothing happens then.

08-24-2016, 08:57 AM   #9
Moderator
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,101
QuoteOriginally posted by gigaorange Quote
i just turned it on after waiting overnight. turns on and everything, no orange light. focuses and there is no more hazy viewfinder. however i cant remember if i ever noticed hearing to focus motor. maybe im more keen to the sound because im wondering if there is anything wrong with my camera.
That's good news, but the reason I suggested the bag of rice and leaving it in there for a while was to get rid of ALL the moisture. If there are any circuits in the camera that still have moisture on them, and you power from the battery running through them, you can actually cause further damage.

QuoteOriginally posted by gigaorange Quote
is there anything else you guys think i should do? sensor cleaning? going into the menu and using dust cleaning? ill be using it today to take pictures at kachemak state park so hopefully nothing happens then.
Are you confident in how to check the sensor for any water marks / debris, and in cleaning it if there are any? If not, have a local camera shop with service facilities check it for you, and clean it if necessary.
08-25-2016, 09:15 PM   #10
New Member




Join Date: Aug 2016
Posts: 5
Original Poster
QuoteOriginally posted by BigMackCam Quote
That's good news, but the reason I suggested the bag of rice and leaving it in there for a while was to get rid of ALL the moisture. If there are any circuits in the camera that still have moisture on them, and you power from the battery running through them, you can actually cause further damage.



Are you confident in how to check the sensor for any water marks / debris, and in cleaning it if there are any? If not, have a local camera shop with service facilities check it for you, and clean it if necessary.
thanks! i think ill check with a local camera shop then.
08-25-2016, 10:27 PM   #11
Site Supporter




Join Date: Sep 2014
Location: SF Bay Area, CA
Photos: Albums
Posts: 329
Excellent advice there from BigMackCam. Open it all the doors, lens off and let it thoroughly dry for days if necessary. Hopefully it was just fresh water that got inside and not salt water.

The latter does nasty things to electronics over time.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-s1, k-s2, light, viewfinder, water
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lenses that wont fit on the K-1 melander Pentax K-1 33 06-24-2016 06:48 PM
My new k-30 wont turn on stewa1cg Pentax K-30 & K-50 5 05-18-2013 03:16 PM
K200D and D-BG3 Grip - lock-up or wont turn on?? cruro02 Troubleshooting and Beginner Help 7 01-02-2012 11:36 PM
Optio E85 wont turn on figgy67 Pentax Compact Cameras 2 11-27-2010 04:11 PM
Shake Reduction wont turn on in video jupzchris Pentax DSLR Discussion 2 06-13-2010 09:43 PM



All times are GMT -7. The time now is 06:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top