Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-26-2017, 09:41 AM   #1
Senior Member




Join Date: Apr 2017
Location: Central California
Posts: 145
K-S2 Burst Issue

Hi Gang!

I have an issue with the burst on my K-S2. It will only burst for about 8-10 shots. Then I have to pause and start firing again after a few seconds. I suspected my SD card write speed might be too slow, so I bought a 16Gb Sandisk Extreme Pro 95mb/s. I believe the reported write speed is 80mb/s one of the fastest I could find. I removed most of the in camera processing settings, but nothing changed. It also behaves the same whether it is the high speed burst or the low speed burst. Is this just the normal function of this camera?

07-26-2017, 10:07 AM   #2
Moderator
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 7,216
Assuming you're shooting RAW, this is normal... the buffer size is around 9 shots, after which the camera will take around 8 seconds to clear fully. You could shoot burst in high quality JPEG format instead, which gives you around 28 shots before the buffer fills.

All digital cameras have this kind of limitation to a greater or lesser extent. Basically, the camera is taking shots faster than it can process them, so they stack up in memory. Eventually, that memory (or "buffer") gets full. Those cameras with more internal memory and faster processing will typically allow more shots to be taken in a single burst.
07-26-2017, 10:45 AM   #3
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery
Posts: 712
QuoteOriginally posted by chunkiness Quote
Hi Gang!

I have an issue with the burst on my K-S2. It will only burst for about 8-10 shots. Then I have to pause and start firing again after a few seconds. I suspected my SD card write speed might be too slow, so I bought a 16Gb Sandisk Extreme Pro 95mb/s. I believe the reported write speed is 80mb/s one of the fastest I could find. I removed most of the in camera processing settings, but nothing changed. It also behaves the same whether it is the high speed burst or the low speed burst. Is this just the normal function of this camera?
And the faster SD card won't matter anyway as your KS-2 isn't capable of moving data at even half the speed that card can handle. So yes it's perfectly normal.
07-26-2017, 11:38 AM - 1 Like   #4
Senior Member




Join Date: Apr 2017
Location: Central California
Posts: 145
Original Poster
Thanks, I just wanted to make sure the buffering was normal. Using JPEG for bursts is a great tip, thanks!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
burst, camera, issue, k-s1, k-s2
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-S2 PDAF issue Maerlyn Troubleshooting and Beginner Help 5 07-06-2016 09:20 AM
K-3 II burst speed faster in live view with K lens Leoi Pentax K-3 5 06-16-2016 08:15 PM
K-3ii + Sigma 70-200 HSM II Exposure Issue in Burst Shooting jawsy Troubleshooting and Beginner Help 3 05-27-2016 05:28 AM
Pentax S2 35mm SLR film winder issue Penduboy Pentax Film SLR Discussion 6 01-14-2016 11:57 PM
How to maximize K-50 burst rate? jswilson64 Pentax DSLR Discussion 12 11-30-2015 09:10 AM



All times are GMT -7. The time now is 06:18 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top