Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-03-2016, 07:33 AM   #16
mee
Site Supporter




Join Date: May 2010
Posts: 5,251
Maryjo, It has been a week and 3 days now.. is it still in repair? Have you prodded Precision lately?

03-03-2016, 01:22 PM   #17
New Member




Join Date: May 2014
Photos: Gallery
Posts: 24
Original Poster
K-3 repaired and repaired within 3 weeks

OK, here's what I hope is the final update on my broken K-3. Precision Camera received it on Feb 12 , and after a very slight wait for parts, it was repaired and returned to me. It arrived home on March 2, and although I have not had a chance to do much more than try it out, it appears to be operating just fine. I think 3 weeks is a reasonable amount of time. The repair ticket says they replaced the Flash Circuit, the Main Circuit, and the AF Drive Block. They did an auto focus test, check, recalibration and realignment, firmware download and a complete cleaning internal and external.
The manufacture date changed to Feb 23 2016 , and the shutter count now is 151.

Anyway , at this point I am satisfied with the repair , unless of course I run into other problems in the future.
I have no complaints regarding Precision Camera's service.

---------- Post added 03-03-16 at 02:23 PM ----------

QuoteOriginally posted by mee Quote
Maryjo, It has been a week and 3 days now.. is it still in repair? Have you prodded Precision lately?
mee, got it back yesterday , just under 3 weeks. i consider that not too bad. all seems well.
03-03-2016, 05:42 PM   #18
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,161
QuoteOriginally posted by maryjo Quote
Anyway , at this point I am satisfied with the repair , unless of course I run into other problems in the future.
I have no complaints regarding Precision Camera's service.
I am glad your repair was processed quickly and (apparently) successfully.


Steve
03-03-2016, 05:52 PM   #19
mee
Site Supporter




Join Date: May 2010
Posts: 5,251
QuoteOriginally posted by maryjo Quote
OK, here's what I hope is the final update on my broken K-3. Precision Camera received it on Feb 12 , and after a very slight wait for parts, it was repaired and returned to me. It arrived home on March 2, and although I have not had a chance to do much more than try it out, it appears to be operating just fine. I think 3 weeks is a reasonable amount of time. The repair ticket says they replaced the Flash Circuit, the Main Circuit, and the AF Drive Block. They did an auto focus test, check, recalibration and realignment, firmware download and a complete cleaning internal and external.
The manufacture date changed to Feb 23 2016 , and the shutter count now is 151.

Anyway , at this point I am satisfied with the repair , unless of course I run into other problems in the future.
I have no complaints regarding Precision Camera's service.

---------- Post added 03-03-16 at 02:23 PM ----------


mee, got it back yesterday , just under 3 weeks. i consider that not too bad. all seems well.
Excellent news. See, No worries, they seem to do much better with camera bodies!

03-03-2016, 06:02 PM   #20
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,716
I bought an extended warranty for my *ist. The main circuit board failed about 2 months before and it was replaced, and there were no further problems with the camera. So I wouldn't be overly concerned. But after 6 months, even with Canada's laws, you don't get a new camera. Mind you if you'd gone for an insurance policy like many offer now, they would have upgraded you to a K-3II if your k-3 was the current top of the line when you bought it.

I believe in Canada you have one week for your money back, two for an over the counter exchange, and many stores will give you a store credit for the full price, for up to 30 days after you buy it.
01-10-2017, 02:01 PM   #21
New Member




Join Date: May 2014
Photos: Gallery
Posts: 24
Original Poster
A followup on my K-3 camera repair.
I do not know if it is related to the original problem.

About 2 months after I got the camera back from Precision I developed the following problems-
1. Sometimes the camera just freezes up . Won't turn off , won't take a shot. So far, removing the battery has solved that problem.
2. Ocasionally , my images show up as totally black screens. I shoot in both Raw and JPEG, 2 separate cards.Later when reviewing the photos on the PC, the JPEG was okay , but the RAW is blank Black. Sometimes both are blank totally black shots. This most often happens when I have the camera set to take multiple shots , but has also happened when shooting just one shot at a time.
Again, so far, removing the battery and the SD cards and starting over will get it working again. One evening , this happened multiple times. Most times , it's just one or two times.

I bought brand new SD cards , the best recommended , and now format my cards on my PC with SDFormatter, but that doesnt seem to help.
I am up to date on all firmware updates, just did that last one recently.

Altho it was still under warranty thru August , I declined to send it again for another month to Precision.
It only happens occasionally , although once it was as the most inopportune time and I did not get the shot I really wanted.

What it has done is caused me to doubt my investment in Pentax/Ricoh. I would really like to invest in a longer zoom as well as a wide angle lens, but that isn't going to happen when I don't have a lot of faith in this camera anymore. If/When it fails, I guess I'll have to explore my options. I only have 5 pentax lenses and am not going to invest any more .
I'm sorry to have lost my confidence in Pentax, as I loved both of my DSLRs, the Kr and the K-3 . I absolutely love the K-3. I never doubted my choice of Pentax till now.
01-10-2017, 02:25 PM   #22
Moderator
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,175
What firmware version are you on?
01-10-2017, 05:09 PM   #23
mee
Site Supporter




Join Date: May 2010
Posts: 5,251
QuoteOriginally posted by maryjo Quote
A followup on my K-3 camera repair.
I do not know if it is related to the original problem.

About 2 months after I got the camera back from Precision I developed the following problems-
1. Sometimes the camera just freezes up . Won't turn off , won't take a shot. So far, removing the battery has solved that problem.
2. Ocasionally , my images show up as totally black screens. I shoot in both Raw and JPEG, 2 separate cards.Later when reviewing the photos on the PC, the JPEG was okay , but the RAW is blank Black. Sometimes both are blank totally black shots. This most often happens when I have the camera set to take multiple shots , but has also happened when shooting just one shot at a time.
Again, so far, removing the battery and the SD cards and starting over will get it working again. One evening , this happened multiple times. Most times , it's just one or two times.

I bought brand new SD cards , the best recommended , and now format my cards on my PC with SDFormatter, but that doesnt seem to help.
I am up to date on all firmware updates, just did that last one recently.

Altho it was still under warranty thru August , I declined to send it again for another month to Precision.
It only happens occasionally , although once it was as the most inopportune time and I did not get the shot I really wanted.

What it has done is caused me to doubt my investment in Pentax/Ricoh. I would really like to invest in a longer zoom as well as a wide angle lens, but that isn't going to happen when I don't have a lot of faith in this camera anymore. If/When it fails, I guess I'll have to explore my options. I only have 5 pentax lenses and am not going to invest any more .
I'm sorry to have lost my confidence in Pentax, as I loved both of my DSLRs, the Kr and the K-3 . I absolutely love the K-3. I never doubted my choice of Pentax till now.
Is it not warrantied anymore? If it is I'd get it in pronto!! at some point, if it keeps failing they'll likely just replace it entirely.. I know its a big hassle, I've experienced it myself... but it is worth getting what you paid for right?

01-12-2017, 10:34 AM   #24
New Member




Join Date: May 2014
Photos: Gallery
Posts: 24
Original Poster
QuoteOriginally posted by MarkJerling Quote
What firmware version are you on?
well, I recently updated to version 1.30.
I have experienced the black shots just once since updating the firmware .
my SD cards:
SanDisk Extreme Plus 90MB/s HC I class 10 32GB and
SanDisk Ultra 30MB/s HC I class 10 32 GB,
both are relatively new.
I probably should have sent it back again before the warranty expired, but just did not want to deal with it , and it does happen infrequently.
01-12-2017, 01:40 PM   #25
Moderator
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,175
That's pretty unfortunate. I was hoping a firmware update might fix your problem.
01-13-2017, 03:15 PM   #26
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,161
QuoteOriginally posted by maryjo Quote
well, I recently updated to version 1.30.
I have experienced the black shots just once since updating the firmware .
Which makes me wonder if this is the fail-over behavior for the runaway mirror fix. I have no experience with either the runaway mirror or the fix, but my understanding is the fix senses the exposure cycle error condition and aborts the exposure. It was never clear to me whether this resulted in a missing file number in the sequence or a black frame.


Steve
01-14-2017, 04:34 PM   #27
New Member




Join Date: May 2014
Photos: Gallery
Posts: 24
Original Poster
QuoteOriginally posted by stevebrot Quote
Which makes me wonder if this is the fail-over behavior for the runaway mirror fix. I have no experience with either the runaway mirror or the fix, but my understanding is the fix senses the exposure cycle error condition and aborts the exposure. It was never clear to me whether this resulted in a missing file number in the sequence or a black frame.


Steve
thanks, I'll do some research and see what I can find on the runaway mirror problem.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, circuit, experience, feb, k-3, main circuit board, pentax service, person, precision, precision camera k-3, repair, ricoh, service, voltage, warranty, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need repair from anywhere but Precision Camera geomez Troubleshooting and Beginner Help 4 08-12-2015 09:22 PM
Precision Camera Repair Lewser89 Pentax DSLR Discussion 48 07-12-2015 02:33 PM
K3 Warranty Repair, Precision Camera K-Three Pentax K-3 3 06-10-2015 09:33 AM
Precision camera repair nightmare BYilg Pentax K-30 & K-50 10 12-12-2014 05:17 PM
Precision Camera repair taking forever jbw Pentax Medium Format 8 11-24-2014 03:11 PM



All times are GMT -7. The time now is 10:04 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top