Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-11-2016, 01:28 PM   #1
New Member




Join Date: Dec 2014
Posts: 4
Light sensor off?

Hi,

I've had my K-30 for about 4, 5 years now. It has all been fine until yesterday.

Yesterday I had a chance to go on a walk for some photography. However, all the pictures I took is really really dark.

Under day light, at ISO 100, automatic mode, I need to up the -/+ meter all the way to +5 to get a "normal", properly exposed photo. At first I thought it's a lens problem, but doesn't change a thing when after I made a switch. It's not too long ago since I took a photo, and they are properly stored in my camera bag since, no bump, no drop, nothing.

I asked a friend and he said it could be my metering sensor is off.

Any idea what could be the problem?
Why it'd occur?
Any way I can fix it besides sending for a repair service?

Thank you.

08-11-2016, 01:36 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,842
Sounds like the infamous aperture block failure. Some members have reported that using AA batteries will temporarily fix the issue, but ultimately the camera does need to be serviced or replaced.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-16-2016, 06:51 AM   #3
New Member




Join Date: Dec 2014
Posts: 4
Original Poster
Yea, I bring to a local store, and it's the aperture block failure. The fixing cost is more than buying a new one, so....
Bye bye Pentax, it's been great, but now I'm a Nikonian =)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
light, light sensor, pentax service, photo, repair, sensor, service, warranty, yesterday
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5IIs Live View manual focusing, slightly off in low light (recently) 85Civic Troubleshooting and Beginner Help 5 08-11-2016 01:25 AM
1 inch sensor performance.. low light? neostyles Non-Pentax Cameras: Canon, Nikon, etc. 12 07-01-2015 09:33 AM
Optio M20 light sensor issue michla Troubleshooting and Beginner Help 2 01-12-2011 11:30 PM
Light sensor problem on DL2? sweetsmk Pentax DSLR Discussion 2 09-02-2010 08:39 AM



All times are GMT -7. The time now is 11:47 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top