Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2017, 07:10 AM   #1
Veteran Member




Join Date: May 2014
Location: Maryland
Photos: Gallery
Posts: 775
live view sound after camera being repaired

I got my k-3 back from Precision about a week ago. I had focus issues and on the notes of the ticket, it said:
af unit and associated items repair,
main flex circuit and cpu repair,
af test, refocus and realignment.

description of parts used:
AF Unit and associated parts

So, today was the first day I used in live view, (used it in the last week with viewfinder) and it sounded like popcorn popping inside the camera, and I could feel something moving around in the camera, knocking against the sides. In the 4 years I have had the camera, I have never noticed that sound before while in live view (or at all). I am assuming it is the stabilization inside the camera, would that be correct? Is it normal to be that loud or did something happen during the repair?

09-13-2017, 07:27 AM   #2
Pentaxian
dcshooter's Avatar

Join Date: Jan 2011
Location: Washington DC
Photos: Gallery | Albums
Posts: 4,673
There is a flex cable to the back of the sensor that might be part of the "main flex circuit" that they mention having repaired. If that's the case, it could be stiff or out of position and making noise as the sensor shifts around.

This link shows what it looks like on the K-5. It's similar on the K-3.
Google Image Result for http://img.photobucket.com/albums/v313/RiceHigh/K-5/Inside/1005209_1333816429.jpg

(sorry, photobucket link, so no embedding in themessage)

I'd use it a bit to see if it settles itself in and quiets down. If not, I'd send it back to Precision.
09-13-2017, 12:43 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,684
While it's normal for you to hear a sound, especially at longer focal lengths, it should be smooth & consistent, and inaudible several feet away from the camera.

If the knocking noise makes it sound like the sensor is hitting the limit of its travel, or if it's overly loud, I would send it back to precision.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-13-2017, 03:56 PM   #4
Veteran Member




Join Date: May 2014
Location: Maryland
Photos: Gallery
Posts: 775
Original Poster
QuoteOriginally posted by dcshooter Quote
There is a flex cable to the back of the sensor that might be part of the "main flex circuit" that they mention having repaired. If that's the case, it could be stiff or out of position and making noise as the sensor shifts around.

This link shows what it looks like on the K-5. It's similar on the K-3.
Google Image Result for http://img.photobucket.com/albums/v313/RiceHigh/K-5/Inside/1005209_1333816429.jpg

(sorry, photobucket link, so no embedding in themessage)

I'd use it a bit to see if it settles itself in and quiets down. If not, I'd send it back to Precision.
It seems to have died down, no more "popcorn" or knocking sound when turning it on. Hopefully that is it for the noise.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, pentax service, repair, service, sound, sound after camera, unit, view, view sound, warranty, week
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressing Live View and Preview buttons result in clicking sound Joyce Keay Troubleshooting and Beginner Help 6 07-21-2017 04:07 PM
live view noise and smc dfa 100mm f2.8 macro lens not focusing in live view tommygunn84 Troubleshooting and Beginner Help 7 11-24-2016 08:59 PM
K50 Exposure is much different from live view to view finder neptune Troubleshooting and Beginner Help 20 08-04-2016 08:45 PM
Typical live view humming, when not in live view. lightsource Pentax K-1 8 05-05-2016 02:20 AM
The K7 live view sound check Daan Pentax DSLR Discussion 17 05-29-2010 01:54 PM



All times are GMT -7. The time now is 02:56 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top