Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-30-2018, 02:27 AM   #1
Pentaxian




Join Date: May 2014
Location: Linz
Photos: Albums
Posts: 1,091
Faulty film winder in SFXn camera

As the title says is the winder in one of my SFXn not working (I can hear the motor but the film doesn't advance). I have a second one so no real problem for me, but I wanna try to repair it if possible.
I would apreciate any direction you can provide on which part probably is causing the issue and what I (if anything) can do about it

Regards Patrick

08-30-2018, 07:27 AM   #2
Forum Member




Join Date: Aug 2014
Location: New Hampshire
Posts: 61
Hi Patrick,


Based on how old the SF series bodies are I would try to disassemble it to see if there is any visual problem you may be able to fix. Other wise you can keep it for parts for your other one. Other wise you can find a another one or newer autofocus film camera for a low cost.
08-30-2018, 07:40 AM   #3
Pentaxian




Join Date: May 2014
Location: Linz
Photos: Albums
Posts: 1,091
Original Poster
QuoteOriginally posted by jimfellows Quote
Based on how old the SF series bodies are I would try to disassemble it to see if there is any visual problem you may be able to fix.
I will try that, I was just curious if someone had any experience with this model.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
film, film winder, pentax service, repair, service, sfxn, warranty, winder, winder in sfxn
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Super Program and Winder ME II - not working, is it the camera or the winder (or me)? OldChE Pentax Film SLR Discussion 22 10-17-2018 07:50 PM
The goofiest winder ever? ME Winder II Wolfeye Pentax Film SLR Discussion 12 08-17-2016 02:59 PM
Just discovered the ME Super but worried I may have a faulty camera and/or winder MewersDad Troubleshooting and Beginner Help 4 07-03-2016 03:09 PM
Faulty equipment or faulty photographer? (K-x) mamba909 Pentax DSLR Discussion 22 02-15-2010 12:16 PM



All times are GMT -7. The time now is 04:51 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top