Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-13-2018, 12:31 PM   #1
Forum Member
ubjy's Avatar

Join Date: Apr 2014
Location: Vale of Glamorgan
Posts: 57
k-30 moving sensor --stabilsation problem?

I wonderif you can help. My K-30 sensor shakes all the time. Its worse in live view andwhen it is autofocusing, there only was I can describe it in words is like aintension tremor -- it is worse when you try to do things. I can still takephotographs but the number of keepers is very low. I have attached a view ofscreen in live view and view of sensor. There are no decent camera repair shopsnear by -- all send camera away, so I thought I would do some initial troubleshooting with fellow Pentax users.

What Iwas hoping to find to was if this is a common fault and if it relatively easy/ inexpensiveto fix. If the consensus is that it is a big/expensive job I will probably justupgrade as I feel I am ready for a better camera.

Attached Files
File Type: mpeg me.mpeg (1.09 MB, 30 views)
File Type: mpeg me2.mpeg (1,008.0 KB, 20 views)
12-13-2018, 02:49 PM - 1 Like   #2
Loyal Site Supporter
Loyal Site Supporter
Cee Cee's Avatar

Join Date: Aug 2011
Location: Glenroy, Melbourne
Photos: Gallery | Albums
Posts: 3,419
trouble I fear, It seems like a problem with control electronics or drive servo. It's looks like it's hunting ie. can't find it's resting or neutral position, could be as simple as a detached wire or as complex as a faulty microcontroller, perhaps someone here has had a similar problem or similar symptoms and may be able to offer advice but the same symptoms doesn't necessarily mean the same fault or repair procedure. Unfortunately I think you will have to spend some money to find out.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-30, k-30 moving sensor, pentax service, repair, sensor, sensor --stabilsation, service, sr problem, view, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is the moving sensor slowing autofocus???? Gutta Perka Pentax DSLR Discussion 91 09-29-2017 09:10 AM
K-30 sensor problem zoomlens Troubleshooting and Beginner Help 22 01-31-2016 10:47 AM
Pentax k-30 sensor problem? TomCotton Troubleshooting and Beginner Help 13 06-17-2014 01:29 AM
About what can be done with a moving sensor: benefits of being late and cheap... Douglas_of_Sweden Photographic Industry and Professionals 9 10-09-2013 10:42 AM
K10D "Sensor moving" possible problem? jaitas Troubleshooting and Beginner Help 6 05-07-2009 02:08 PM



All times are GMT -7. The time now is 01:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top