Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-04-2020, 02:32 PM   #1
Site Supporter
Site Supporter




Join Date: Jul 2008
Location: Albuquerque
Posts: 25
macro lens - repair or replace

I have a Pentax 100 macro (SMC PENTAX-DFA 1:2.8 100mm MACRO 49mm). When I attach it to a K-20D body and turn the camera on I get a flashing 'F--' and that's all. I've tried it on 2 different bodies and get the same result. I've cleaned the contacts but that hasn't made any difference. Is it work repairing this lens or better to get another one? Thanks for any advice.

07-04-2020, 03:22 PM   #2
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,080
If it's the non-WR lens with aperture ring make sure the ring is set to "A".
07-04-2020, 03:46 PM   #3
Seeker of Knowledge
Loyal Site Supporter
aslyfox's Avatar

Join Date: Aug 2016
Location: Topeka, Kansas
Photos: Gallery | Albums
Posts: 18,933
what happens if you enter " 100 " ?

does the camera and lens then work ?
07-04-2020, 04:12 PM   #4
maw
Site Supporter
Site Supporter
maw's Avatar

Join Date: Feb 2014
Location: Sassari (Italy)
Posts: 666
QuoteOriginally posted by ljlayne Quote
When I attach it to a K-20D body and turn the camera on I get a flashing 'F--' and that's all.
I have the Pentax K20D and the FA 50mm Macro, almost certainly put the lens not in 'A' position in that case it will appear "F - -" in the display, you have to set the 'A' in the lens.


Last edited by maw; 07-04-2020 at 04:16 PM. Reason: correction
07-04-2020, 05:05 PM   #5
Site Supporter
Site Supporter
jumbleview's Avatar

Join Date: May 2012
Location: Concord, CA
Posts: 493
QuoteOriginally posted by maw Quote
I have the Pentax K20D and the FA 50mm Macro, almost certainly put the lens not in 'A' position in that case it will appear "F - -" in the display, you have to set the 'A' in the lens.
If it is SMC PENTAX-DFA 1:2.8 100mm MACRO 49mm it does not have aperture ring. If cleaning does not help indeed it looks like broken.
07-04-2020, 05:47 PM - 1 Like   #6
Seeker of Knowledge
Loyal Site Supporter
aslyfox's Avatar

Join Date: Aug 2016
Location: Topeka, Kansas
Photos: Gallery | Albums
Posts: 18,933
QuoteOriginally posted by jumbleview Quote
If it is SMC PENTAX-DFA 1:2.8 100mm MACRO 49mm it does not have aperture ring. If cleaning does not help indeed it looks like broken.
does it have an Aperture ring ?

this one does

SMC Pentax-D FA 100mm F2.8 Macro

SMC Pentax-D FA 100mm F2.8 Macro Reviews - D FA Prime Lenses - Pentax Lens Reviews & Lens Database

this one does not

SMC Pentax-D FA 100mm F2.8 Macro WR

SMC Pentax-D FA 100mm F2.8 Macro WR Reviews - D FA Prime Lenses - Pentax Lens Reviews & Lens Database

although it is impossible to be sure, I think the OP has the no WR model

QuoteOriginally posted by ljlayne Quote
I have a Pentax 100 macro (SMC PENTAX-DFA 1:2.8 100mm MACRO 49mm). . . ..
07-04-2020, 08:07 PM   #7
Site Supporter
Site Supporter
jumbleview's Avatar

Join Date: May 2012
Location: Concord, CA
Posts: 493
Right, I did not even know there is 100mm Macro D FA version with no aperture ring. The one I have (WR) does not have it.
07-04-2020, 08:54 PM   #8
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,680
QuoteOriginally posted by jumbleview Quote
Right, I did not even know there is 100mm Macro D FA version with no aperture ring. The one I have (WR) does not have it.
The lens review section is full of odd lenses and variants. The WR version is the one I have as well.

07-04-2020, 08:56 PM   #9
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,680
QuoteOriginally posted by ljlayne Quote
I have a Pentax 100 macro (SMC PENTAX-DFA 1:2.8 100mm MACRO 49mm). When I attach it to a K-20D body and turn the camera on I get a flashing 'F--' and that's all. I've tried it on 2 different bodies and get the same result. I've cleaned the contacts but that hasn't made any difference. Is it work repairing this lens or better to get another one? Thanks for any advice.
EDIT: Fix was free! Happy outcome. Read more in the thread for details.

The cost will most likely exceed the value. If it is the version with an aperture ring you can use it in manual mode and manually focus and use green button M mode. If it's the WR you have few good options.

Last edited by UncleVanya; 07-05-2020 at 08:16 AM.
07-05-2020, 02:44 AM   #10
Seeker of Knowledge
Loyal Site Supporter
aslyfox's Avatar

Join Date: Aug 2016
Location: Topeka, Kansas
Photos: Gallery | Albums
Posts: 18,933
QuoteOriginally posted by jumbleview Quote
Right, I did not even know there is 100mm Macro D FA version with no aperture ring. The one I have (WR) does not have it.
QuoteOriginally posted by UncleVanya Quote
The lens review section is full of odd lenses and variants. The WR version is the one I have as well.
the progression of the 100mm F2.8 Macro

F, FA, D FA, D FA with WR

all share the same optical design

all but the WR share the same shape of blades


QuoteQuote:
The optical design is the tried-and-proven formula of the previous generation D FA 100mm F2.8 Macro lens, which in turn had inherited the optical design from the well-respected FA 100mm F2.8 and F 100mm F2.8 macro lenses introduced in 1991 and 1987, respectively. None of these earlier lenses had rounded aperture blades.
Read more at: Pentax-D FA 100mm F2.8 WR Macro Review - Specifications | PentaxForums.com Reviews

can be used either manual or autofocus all have the " A " setting except the WR

check the reviews and the market place

none of the F, FA, or D FA require the use of the green button M mode


QuoteQuote:
Pentax Green Button Guide
A look at one of Pentax's secrets
Read more at: https://www.pentaxforums.com/articles/photo-articles/pentax-green-button-gui...#ixzz6RJS5i4KJ

Last edited by aslyfox; 07-05-2020 at 03:38 AM.
07-05-2020, 07:18 AM   #11
Site Supporter
Site Supporter




Join Date: Jul 2008
Location: Albuquerque
Posts: 25
Original Poster
QuoteOriginally posted by Not a Number Quote
If it's the non-WR lens with aperture ring make sure the ring is set to "A".
Well go figure. That was the issue, Not a Number. What a moron I am.
07-05-2020, 07:36 AM   #12
Seeker of Knowledge
Loyal Site Supporter
aslyfox's Avatar

Join Date: Aug 2016
Location: Topeka, Kansas
Photos: Gallery | Albums
Posts: 18,933
QuoteOriginally posted by ljlayne Quote
Well go figure. That was the issue, Not a Number. What a moron I am.
some of us [ ] have been there

so welcome to the club

glad it was a simple fix
07-05-2020, 08:15 AM - 1 Like   #13
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 16,680
QuoteOriginally posted by ljlayne Quote
Well go figure. That was the issue, Not a Number. What a moron I am.
Not a moron, you were able to (with help) take corrective steps and you asked for help. Glad it was simple.
07-05-2020, 09:26 AM   #14
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,080
QuoteOriginally posted by ljlayne Quote
Well go figure. That was the issue, Not a Number. What a moron I am.
If you've never had cause to use the aperture ring before unfamiliarity of the operation does not make one a moron. However, one may feel foolish at least on the discovery of such a simple cause.

Although the ring has a lock button to prevent moving in or out of the "A" setting it is possible to push the button and turn the ring while mounting or dismounting the lens.

The bonus of having the aperture ring is you would be able to use aperture settings when using the ring on extension tubes or bellows.
07-05-2020, 12:02 PM   #15
Site Supporter
Site Supporter
jumbleview's Avatar

Join Date: May 2012
Location: Concord, CA
Posts: 493
Setting A-ring in to wrong position is nothing. I have the story to tell. That happened more then 20 year ago. We bought multi unit stereo player/tuner at Costco. It had push button +/- to adjust volume. I set it at some comfortable level and never touched it again. Several weeks later I turned device on and could not hear any audio (it was too quiet). I checked wiring between turner/audio dynamic: everything was in place. As this thing was almost new I brought it back to Costco and start to look for a replacement. I looked at all models and came to conclusion that the only one we bought first suites our needs. So I decided to buy it again assuming that first time it was just bad luck. Back home I connected dynamics and start to adjust volume. And here memory returned to me. The day before original unit lost its voice we had guests at our house. One of them needed to make the phone call and asked me to turn down the volume: and that was only occasion when I corrected the sound.

Last edited by jumbleview; 07-05-2020 at 05:18 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
lens, macro, macro lens repair, pentax service, repair, service, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
FA 50 1.4 issue, repair or replace? selfnoise Repairs and Warranty Service 4 08-08-2017 07:50 AM
To repair or replace and how to decide Bill2849 Visitors' Center 13 01-06-2012 06:49 PM
My K10D died. What should I do? - Repair, Replace, Upgrade? jacksonpritt Pentax DSLR Discussion 9 02-15-2010 08:16 PM
Help me decide: Repair or replace my nice Pentax film P&S? ChrisPlatt Pentax Compact Cameras 3 04-26-2009 04:30 AM
Repair *istDs or Replace? kimbelj Pentax DSLR Discussion 6 02-17-2009 12:39 PM



All times are GMT -7. The time now is 01:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top