Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-07-2022, 08:42 AM   #1
Site Supporter
Site Supporter




Join Date: Oct 2015
Posts: 119
Battery problem on K1

Hello, just looking for a bit of advice.
After performing flawlessly for a few years, my K1 is now not recognising the battery in the grip. When I go to the battery options in the menu, it shows the battery in camera body is fully charged but the battery in the grip is either flat or non existent. Definitely not the battery itself because swapping them round brings the same result. Could this be some kind of connection problem?
Any advice or wisdom much appreciated.
Don.

04-07-2022, 09:03 AM   #2
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 9,299
On other grips it has been reported that the connector pins some times get stuck and don't stick out enough to make contact. Check the pins and see if they are all about the same length. And maybe a cleaning of the contacts on the camera and pins on the grip with a micro fiber cloth might help.

If you leave the battery out of the body does it recognize the battery in the grip?
04-07-2022, 11:23 AM   #3
Site Supporter
Site Supporter




Join Date: Jun 2008
Location: Idaho
Photos: Gallery
Posts: 1,817
Check the terminals right at the battery and see if there are any signs of corrosion or they have gotten mis-positioned somehow. Also check the terminals going into the camera if you have a voltmeter and see if there is voltage on them. If not, the issue is in your grip.
04-07-2022, 11:44 AM   #4
Pentaxian
Kobayashi.K's Avatar

Join Date: Mar 2013
Photos: Albums
Posts: 683
Actually the pins on a battery grip can have various lengths. This is by design to ensure certain pins are making an early contact before others do when the grip is mounted with power on (which is not advisable). For example, on my DBG-4 I count 3 different lengths. Some pins, I guess for power, have also a larger diameter.

The pins are spring-loaded so you can test if they move easily up and down.

However, never touch the pins with your bare fingers, the pins are very easily contaminated with skin fat (which is non-conductive), because it is the very top which is making contact with the connector on the camera.

04-09-2022, 12:27 AM   #5
Site Supporter
Site Supporter




Join Date: Oct 2015
Posts: 119
Original Poster
Thanks for all comments. I'll try to clean all connections somehow as it seems that is likely the issue and take it from there.
Thank you.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advice, battery, dslr, full frame, full-frame, grip, k-1, k-1 ii, k1, pentax k-1
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax Battery Grip D-BG6 for K1, K1 Mark II tscip22 Sold Items 2 09-27-2019 01:56 PM
Battery problem or Charger Problem? troika Troubleshooting and Beginner Help 10 10-01-2018 09:59 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 & K-5 II 39 11-03-2010 06:02 PM



All times are GMT -7. The time now is 06:01 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top