Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-11-2019, 10:19 PM   #22696
Pentaxian




Join Date: Apr 2011
Photos: Albums
Posts: 5,408
QuoteOriginally posted by BruceBanner Quote
Ok, so I have the exact same lens and it performs flawlessly on the KP, however when I connect it to the K-1 I get a lot of weirdness;
  • AF doesn't always work. Sometimes I have to switch the mode dial to Manual and then the AF works and I can then toggle back to Av where it will work.
  • On switching the camera on it wants a Focal length, further cementing it thinks it's manual focus glass.
  • I think I might not always be able to get the mirror up, hitting the Info button to access the shortcuts (to change FF>APS Crop Mode), sometimes it won't let me in, kicks me back out
All in all it's just weird on the K-1. KP however it acts like every other lens.

What gives?


I have heard of the same phenomenon with a Sigma lens that worked fully on one body but did not work properly with another. Cannot remember the details.

02-11-2019, 10:56 PM   #22697
Forum Member




Join Date: Jan 2017
Photos: Gallery
Posts: 75
I'm sorry to hear about troubles with this lens. This Sigma is screw drive lens, right? At least the one I have is. No issues at all. Behaves in the same way as it does on another Pentax camera K-5 II. Have you heard of stories of any other screw drive lens that has issues on Pentax K-1? I haven't. It could all be related to the Sigma lenses that have motor in them. Maybe your lens is faulty or camera.
02-12-2019, 12:25 AM   #22698
Site Supporter
Site Supporter
BruceBanner's Avatar

Join Date: Dec 2015
Location: Blue Mountains, NSW, Australia
Posts: 3,574
QuoteOriginally posted by tim60 Quote
I have heard of the same phenomenon with a Sigma lens that worked fully on one body but did not work properly with another. Cannot remember the details.
QuoteOriginally posted by 5r82 Quote
I'm sorry to hear about troubles with this lens. This Sigma is screw drive lens, right? At least the one I have is. No issues at all. Behaves in the same way as it does on another Pentax camera K-5 II. Have you heard of stories of any other screw drive lens that has issues on Pentax K-1? I haven't. It could all be related to the Sigma lenses that have motor in them. Maybe your lens is faulty or camera.
Yeah it's a bit of a weird one. I think it must be the lens. Every other lens I have owned and used that is also Screw drive behaves perfectly fine between the two systems. Odd indeed.
02-12-2019, 12:46 AM - 9 Likes   #22699
New Member




Join Date: Aug 2018
Photos: Gallery
Posts: 21
Mountains.

K-1 ii + DA* 300mm F/4.
The association of these two products is terrible.

Attached Images
View Picture EXIF
PENTAX K-1 Mark II  Photo 

Last edited by Le Fanfoué; 02-12-2019 at 03:42 AM.
02-12-2019, 04:44 AM - 16 Likes   #22700
Pentaxian
Hattifnatt's Avatar

Join Date: Mar 2013
Photos: Gallery
Posts: 3,387
Few pictures from a cold spell we had over here in Bucharest recently... everything was frozen.







02-12-2019, 04:58 AM - 5 Likes   #22701
Site Supporter
Site Supporter
longbow's Avatar

Join Date: Jan 2015
Location: NW Oregon
Posts: 740
A couple more of the otters from yesterday morning- DFA 150-450


02-12-2019, 07:58 AM   #22702
Loyal Site Supporter
Loyal Site Supporter
WPRESTO's Avatar

Join Date: Aug 2010
Location: Massachusetts
Photos: Gallery | Albums
Posts: 37,513
QuoteOriginally posted by Hattifnatt Quote
Few pictures from a cold spell we had over here in Bucharest recently... everything was frozen.
The second image is the one that makes me want to stay near the fire,
02-12-2019, 08:50 AM - 6 Likes   #22703
Loyal Site Supporter
Loyal Site Supporter
jcdoss's Avatar

Join Date: Nov 2012
Location: Kansas City, MO or Jasper, AR
Photos: Gallery | Albums
Posts: 2,620


Glory Hole Falls
Newton County, Arkansas
Pentax K-1 mII Ltd Silver, A100f2.8 Macro & Tamron 1.4x

02-12-2019, 11:39 AM - 9 Likes   #22704
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 4,834
K-1 • FF Mode • 100 ISO • Tamron SP AF Di 90mm F2.8 Macro • Metz Flash 52 AF-1 Digital with softbox


K-1 • FF Mode • 1600 ISO • Sigma Art 18-35mm F1.8 DC HSM


K-1 • FF Mode • 100 ISO • Pentax FA 35mm F2 AL
02-12-2019, 01:20 PM - 6 Likes   #22705
Loyal Site Supporter
Loyal Site Supporter




Join Date: Aug 2010
Location: Toronto
Posts: 2,220
Quite a storm today in Toronto
Attached Images
View Picture EXIF
PENTAX K-1  Photo 
View Picture EXIF
PENTAX K-1  Photo 
02-12-2019, 05:11 PM - 6 Likes   #22706
Loyal Site Supporter
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 12,816
*Of course* I've collected stamps. Isn't it obvious?

K-1, Sigma 105mm f2.8 Macro, cheap extension tubes.



02-12-2019, 05:21 PM   #22707
Loyal Site Supporter
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 12,816
QuoteOriginally posted by BruceBanner Quote
Ok, so I have the exact same lens and it performs flawlessly on the KP, however when I connect it to the K-1 I get a lot of weirdness;
  • AF doesn't always work. Sometimes I have to switch the mode dial to Manual and then the AF works and I can then toggle back to Av where it will work.
  • On switching the camera on it wants a Focal length, further cementing it thinks it's manual focus glass.
  • I think I might not always be able to get the mirror up, hitting the Info button to access the shortcuts (to change FF>APS Crop Mode), sometimes it won't let me in, kicks me back out

All in all it's just weird on the K-1. KP however it acts like every other lens.

What gives?
This is a hazard of third-party lenses. They rely on reverse engineering. They don't actually know the protocols of the Canon or Nikon or Pentax AF system, they figure out what they can from an oscilloscope connected to a camera as they try stuff - and they didn't have a K-1 when the 10-20 was designed.

The Sigma 70-200 can have real problems, but a new firmware is available for it if someone's copy is affected.
02-12-2019, 05:24 PM   #22708
Loyal Site Supporter
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 12,816
QuoteOriginally posted by HoustonBob Quote
Portrait of a Texas ranch hand. Tamron 70-200 f2.8 Macro 122mm@ 1/125 f7.1
Love this sensitive shot, Bob … is it a composite?
02-12-2019, 09:43 PM   #22709
Site Supporter
Site Supporter
BruceBanner's Avatar

Join Date: Dec 2015
Location: Blue Mountains, NSW, Australia
Posts: 3,574
QuoteOriginally posted by clackers Quote
This is a hazard of third-party lenses. They rely on reverse engineering. They don't actually know the protocols of the Canon or Nikon or Pentax AF system, they figure out what they can from an oscilloscope connected to a camera as they try stuff - and they didn't have a K-1 when the 10-20 was designed.

The Sigma 70-200 can have real problems, but a new firmware is available for it if someone's copy is affected.
Could my 10-20 be updated on the Sigma dock perhaps, so that it works with the K-1?
02-12-2019, 09:58 PM - 2 Likes   #22710
Loyal Site Supporter
Loyal Site Supporter
eaglem's Avatar

Join Date: Feb 2009
Location: Perth Western Australia
Photos: Gallery
Posts: 32,345
Summery colours

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, copy, crop, da* 200mm f2.8, dslr, f2.8, focus, friend, full frame, full-frame, images, k-1, k1, pentax, pentax k-1, pics, pm, post, post your k-1, review, sample, shots, squirrel, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post pictures made with your worst lens! LensBeginner Pentax SLR Lens Discussion 27 08-02-2018 10:27 AM
Post your K5IIs pictures here... SECELEE Pentax K-5 2 02-21-2015 09:30 PM
There should be a post your K-30 pictures thread memo90061 Pentax K-30 & K-50 3 10-30-2012 02:06 AM
Thematic Post your winter pictures ohce Mini-Challenges, Games, and Photo Stories 10 03-22-2012 06:17 PM
Who can post pictures in the post your pictures category? Sitting Bull Troubleshooting and Beginner Help 3 12-14-2010 05:41 AM



All times are GMT -7. The time now is 11:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top