Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-04-2016, 11:39 AM   #91
Site Supporter




Join Date: Apr 2016
Posts: 88
QuoteOriginally posted by deepbluish Quote
You're making this sound like we're discussing a faulty lens, which it isn't. All forum members who complained about the lack of compatibility have used this lens successfully on their previous Pentax made cameras. They've recently paid good money for a new camera made by the same manufacturer, and it does not operate as it's supposed to.

May I remind you all that the camera freezes! And that it's brand new. A thing bought completely new should not behave this way. It's something that has to be fixed.

Don't get me wrong, I'm not trying to bash Pentax, I've been using their camera's for a long time and I will buy the K-1 in spite of this problem, and I actually own the dreaded Sigma lens, but be honest with yourself, is it acceptable for a completely new product to freeze like this?
See previous post.

QuoteQuote:
And the same lens had problems on k-5 and k-3 until Sigma did a firmware update. So again, Sigma problem.


05-04-2016, 11:53 AM   #92
Pentaxian




Join Date: Apr 2007
Location: Romania
Posts: 8,406
QuoteOriginally posted by deepbluish Quote
You're making this sound like we're discussing a faulty lens, which it isn't.
That's exactly what it is.
05-04-2016, 11:59 AM   #93
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,284
QuoteOriginally posted by deepbluish Quote
They've recently paid good money for a new camera made by the same manufacturer, and it does not operate as it's supposed to.
Yes it does. The lens doesn't. Call Sigma and insist they fix their problem.

This is not a Pentax problem, it is not their responsibility to test and be compatible with other manufacturer's products. It is Sigma's job to test their products with the camera they are supposed to be compatible with. If Pentax made a lens to fit on a Sigma camera the situation would be reversed.

Sorry you have a problem with your third party lens, you should contact Sigma and let them know they have problem.
05-04-2016, 01:14 PM   #94
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by deepbluish Quote
Maybe, but since the lens already works without a glitch with my K-5, I find it unacceptable that a far more advanced camera is not compatible at all. If compatibility was lost somewhere between several models of camera development, and the lens stayed exactly the same, it would be reasonable to assume that it's not entirely up to the lens alone, right?
It sound`s perfectly reasonable, I feel sure that Pentax or Sigma will produce a solution for you in due time. Have you tried asking Sigma?
These things do unfortunately happen with any brand of camera. I gave up on independent lenses 40 years ago so I have only Pentax glass.
Have you tried cleaning the contacts on your lens? I had an occasion when my old 50-135 stopped working on my K3 but when I put it on my K5II it worked perfectly. I cleaned my contacts with isopropyl alcohol and all was well.
I hope that you find a solution very quickly.

Best Regards

---------- Post added 05-04-16 at 09:27 PM ----------

QuoteOriginally posted by deepbluish Quote
You're making this sound like we're discussing a faulty lens, which it isn't. All forum members who complained about the lack of compatibility have used this lens successfully on their previous Pentax made cameras. They've recently paid good money for a new camera made by the same manufacturer, and it does not operate as it's supposed to.

May I remind you all that the camera freezes! And that it's brand new. A thing bought completely new should not behave this way. It's something that has to be fixed.

Don't get me wrong, I'm not trying to bash Pentax, I've been using their camera's for a long time and I will buy the K-1 in spite of this problem, and I actually own the dreaded Sigma lens, but be honest with yourself, is it acceptable for a completely new product to freeze like this?
You only need to look at Microsoft Windows! I have slide scanners and operating programmes which will not run on Windows 10. I have to keep another PC on which I installed XP to utilise my old stuff. I can`t blame Microsoft for not supporting third party gear.

05-04-2016, 08:04 PM   #95
Senior Member




Join Date: Dec 2015
Location: Calgary Alberta Canada
Photos: Gallery
Posts: 101
I think there is a Pentax issue here -- the camera shouldn't freeze, even with an incompatible lens mounted. It isn't Pentax's job to make the Sigma lens work, but they shouldn't let it crash the camera.
05-05-2016, 01:06 AM   #96
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by Cthulhugan Quote
I think there is a Pentax issue here -- the camera shouldn't freeze, even with an incompatible lens mounted. It isn't Pentax's job to make the Sigma lens work, but they shouldn't let it crash the camera.
I do sympathise with you, These days everything seems to have a chip in it! The Autofocus on the K1 is a substantial improvement on my K5II and K3. But you cannot expect Pentax to test every lens from each of it`s competitors to ensure they work! The camera would have taken even longer to release and cost considerably more!
Camera manufacturers make much of their income from lens sales. The latest 70-200 from Pentax is superb. But if there were issues with compatibility then I would have cause for redress with Pentax. Otherwise I can only hope that the problem that you have is resolved swiftly.

Best Regards
05-05-2016, 01:29 AM   #97
Site Supporter




Join Date: Jun 2013
Photos: Gallery
Posts: 74
QuoteOriginally posted by jatrax Quote
Originally posted by phoebus
I think you would be at least a little upset if your next camera didn't work with third party equipment.
That's why I don't buy third party lenses. It is the third party's responsibility to make their gear work with the first party, not the other way around.
Jatrax - the point I was making was that the poster that disagreed so vehemently that any fault lay at Pentax's feet didn't list a single Pentax lens in his signature; sort of ironic really.

Agreed that the 3rd party needs to get their act together, but Pentax also needs to program the K-1 to reject non-compliant lenses a little more gracefully. Just freezing is not really the correct response. What I've tried so far with my K-1 informs me that Pentax (Ricoh) have designed and built a truly superb camera that performs even better than my wildest expectations. Unsurprisingly, there are a few software bugs that need fixing and extra functionality that others have highlighted as being desirable. I have little doubt they will be addressed in future firmware updates.

Here's to the future!
05-05-2016, 02:01 AM - 1 Like   #98
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by phoebus Quote
Jatrax - the point I was making was that the poster that disagreed so vehemently that any fault lay at Pentax's feet didn't list a single Pentax lens in his signature; sort of ironic really.

Agreed that the 3rd party needs to get their act together, but Pentax also needs to program the K-1 to reject non-compliant lenses a little more gracefully. Just freezing is not really the correct response. What I've tried so far with my K-1 informs me that Pentax (Ricoh) have designed and built a truly superb camera that performs even better than my wildest expectations. Unsurprisingly, there are a few software bugs that need fixing and extra functionality that others have highlighted as being desirable. I have little doubt they will be addressed in future firmware updates.

Here's to the future!
I too have failed to list my Pentax equipment on my signature! Personally I don`t feel that it is relevant to do so. I have a vast range of Pentax lenses which I purchased in the 1970`s along with my KM and three MX`s. All primes ranging from 20mm-300mm. And all of which I still own and occasionally use. Currently My gear is K5II (soon to be passed on to my daughter) K3 and K1, x2 540FGZ , x2 1.4 converters and the new 24-70,70-200 and 150-450 plus a 300mmF4 that I have not tried on the K1 and a FA 100mm macro. In addition I have APSC 16-50 and 50-135 which I no longer use.

I understand and sympathise with all those affected and I hoped that a solution can be found as soon as possible.
I do feel however that the problem should be directed at Sigma. Pentax make lenses that are compatible with Pentax camera`s. They have always allowed other manufacturers to use their mount (Ricoh and Praktica in the 1970`s come to mind) but are not responsible for the way that they operate.

Best Regards

05-05-2016, 02:34 AM   #99
Site Supporter




Join Date: Jun 2013
Photos: Gallery
Posts: 74
QuoteOriginally posted by PeteL Quote
I too have failed to list my Pentax equipment
@PeteL, you don't list ANY equipment, but @bobmaxja does - all 3rd party... ...he was the one I originally quoted

;-)

Last edited by phoebus; 05-05-2016 at 02:37 AM. Reason: spelling
05-05-2016, 03:24 AM   #100
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by phoebus Quote
@PeteL, you don't list ANY equipment, but @bobmaxja does - all 3rd party... ...he was the one I originally quoted

;-)
Don`t worry, I didn't take it as anything personal! :-)

It may take a little while but I`m sure a solution will emerge.

Best of luck with sorting it out!
05-05-2016, 05:50 AM   #101
Site Supporter
K-amps's Avatar

Join Date: Mar 2016
Location: Fishers, IN
Posts: 228
QuoteOriginally posted by stevebrot Quote
You mean something like this?






Steve

Water marks on top of the OVF latch.... Tsk Tsk Tsk, That's no way to treat an SX-70


05-05-2016, 09:26 AM   #102
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,284
QuoteOriginally posted by phoebus Quote
didn't list a single Pentax lens in his signature; sort of ironic really.
OK, I didn't notice and I can see the irony but not sure it matters to the point, but OK.
QuoteOriginally posted by phoebus Quote
Pentax also needs to program the K-1 to reject non-compliant lenses a little more gracefully
100% agree. The issue with the lens is IMHO a Sigma problem, but having the camera lock up for ANY reason is a Pentax problem. Failing gracefully is the desired result. The camera should either display an error message or act as if there is no lens attached, it should not lock up.

Hopefully Sigma will address their issue and Pentax will address their issue and we can move on to enjoying this wonderful camera.
05-05-2016, 01:16 PM   #103
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by jatrax Quote
OK, I didn't notice and I can see the irony but not sure it matters to the point, but OK.

100% agree. The issue with the lens is IMHO a Sigma problem, but having the camera lock up for ANY reason is a Pentax problem. Failing gracefully is the desired result. The camera should either display an error message or act as if there is no lens attached, it should not lock up.

Hopefully Sigma will address their issue and Pentax will address their issue and we can move on to enjoying this wonderful camera.
And that is the aim of us all! Simply to enjoy our hobby!

Some people use their camera without a lens so that would not be an option. I`m thinking of pinhole photography using aluminium foil with a pinprick, or those that hold the lens a little in front of the camera to take shots

I`m sorry the pleasure of your new camera has been tainted with this problem. I look forward to hearing of a resolution soon.

Best Regards - PeteL
05-07-2016, 07:26 AM   #104
Junior Member




Join Date: Nov 2013
Posts: 25
QuoteOriginally posted by robthebloke Quote
press 'info', then press 'info' again, and select 'no display'. taa daa!
That is what I am doing at present for SR on off Pixel shift etc etc. But unlike the K3 the Focus point selector is in the Menu so I have to select that to change the type of focusing and AFS or AFC. It would be rather nice if those wheels on top could be used for their intended purpose rather than being ornamental! It`s no big deal but would be nice! :-)

Last edited by PeteL; 05-07-2016 at 07:28 AM. Reason: needed to add something
05-07-2016, 10:04 AM   #105
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,211
QuoteOriginally posted by biz-engineer Quote
I should say that what I wrote in from my personal preferences. If I'll get the K-1 , I don't think I'll use more than what's available on K-5 and K-3. Other users may feel otherwise.
To be able to quickly as I shoot adjust the exposure compensation in TAV mode will be worth it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
astrotracer, button, camera, dslr, exif, feature, fl, full frame, full-frame, function, interval, k-1, k-1 new firmware, k1, lens, lenses, menu, new firmware k-1, pentax, pentax k-1, post, reduction, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
new K-3 comes with latest firmware 1.11 aleonx3 Pentax K-3 51 04-02-2015 07:40 AM
K-5 Firmware Suggestions kevinschoenmakers Pentax K-5 260 08-04-2011 08:14 AM
Pentax K7 1.11 Firmware suggestions LaurenOE Pentax DSLR Discussion 26 06-21-2011 07:08 AM
New Firmware Officially Posted (1.02 K-5, 1.01 K-r and 645D) nixcamic Pentax News and Rumors 9 01-05-2011 08:47 PM
New firmware to PENTAX K-7: 1.03 Hox Pentax News and Rumors 84 06-14-2010 11:01 PM



All times are GMT -7. The time now is 01:26 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top